File python-os-client-config.spec of Package python-os-client-config
#
# spec file for package python-os-client-config
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_with test
Name: python-os-client-config
Version: 1.6.3
Release: 0
Summary: OpenStack Client Configuation Library
License: Apache-2.0
Group: Development/Languages/Python
Url: http://www.openstack.org/
Source: https://pypi.python.org/packages/source/o/os-client-config/os-client-config-%{version}.tar.gz
BuildRequires: openstack-suse-macros
BuildRequires: python-devel
BuildRequires: python-pbr
%if %{with test}
# test requirements
BuildRequires: python-PyYAML
BuildRequires: python-appdirs
BuildRequires: python-extras
BuildRequires: python-fixtures
BuildRequires: python-keystoneclient
BuildRequires: python-oslosphinx
BuildRequires: python-oslotest
BuildRequires: python-python-subunit
BuildRequires: python-sphinx
BuildRequires: python-testrepository
BuildRequires: python-testscenarios
BuildRequires: python-testtools
%endif
Requires: python-PyYAML >= 3.1.0
Requires: python-appdirs >= 1.3.0
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
os-client-config is a library for collecting client configuration for
using an OpenStack cloud in a consistent and comprehensive manner. It
will find cloud config for as few as 1 cloud and as many as you want to
put in a config file. It will read environment variables and config files,
and it also contains some vendor specific default values so that you dont
have to know extra info to use OpenStack
%prep
%setup -q -n os-client-config-%{version}
%build
%{__python2} setup.py build
%install
%{__python2} setup.py install --prefix=%{_prefix} --root=%{buildroot}
%if %{with test}
%check
testr init && testr run
%endif
%files
%defattr(-,root,root,-)
%doc ChangeLog LICENSE README.rst AUTHORS
%{python2_sitelib}/*
%changelog