File python-oslo.log.spec of Package python-oslo.log
#
# spec file for package python-oslo.log
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-oslo.log
Version: 1.0.0
Release: 0
Summary: OpenStack logging API
License: Apache-2.0
Group: Development/Languages/Python
Url: https://launchpad.net/oslo/
Source: https://pypi.python.org/packages/source/o/oslo.log/oslo.log-%{version}.tar.gz
BuildRequires: python-devel
BuildRequires: python-pbr
# Test requirements
BuildRequires: python-coverage
BuildRequires: python-fixtures
BuildRequires: python-mock
BuildRequires: python-oslo.config
BuildRequires: python-oslo.context
BuildRequires: python-oslo.i18n
BuildRequires: python-oslo.serialization
BuildRequires: python-oslo.utils
BuildRequires: python-oslosphinx
BuildRequires: python-oslotest
BuildRequires: python-python-subunit
BuildRequires: python-sphinx
BuildRequires: python-testrepository
BuildRequires: python-testscenarios
BuildRequires: python-testtools
Requires: python-Babel >= 1.3
Requires: python-iso8601 >= 0.1.9
Requires: python-oslo.config >= 1.9
Requires: python-oslo.context >= 0.2
Requires: python-oslo.i18n >= 1.3
Requires: python-oslo.serialization >= 1.2
Requires: python-oslo.utils >= 1.2
Requires: python-six >= 1.9
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
OpenStack logging configuration library provides standardized configuration for
all openstack projects. It also provides custom formatters, handlers and
support for context specific logging (like resource ids etc).
%prep
%setup -q -n oslo.log-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%check
testr init && testr run --parallel
%files
%defattr(-,root,root,-)
%doc README.rst LICENSE AUTHORS ChangeLog
%{python_sitelib}/*
%changelog