File python-Babel.spec of Package python-Babel

#
# spec file for package python-Babel
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python-Babel
Version:        1.3
Release:        0
Url:            http://babel.edgewall.org/
Summary:        Internationalization utilities
License:        BSD-3-Clause
Group:          Development/Languages/Python
Source:         http://pypi.python.org/packages/source/B/Babel/Babel-%{version}.tar.gz
# FIX-BUILD-OPENSUSE 0001-disable_timezone_tests.patch sfalken@opensuse.org -- disable failing timezone tests
Patch0:         0001-disable_timezone_tests.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  fdupes
BuildRequires:  python-devel
BuildRequires:  python-setuptools
# Documentation requirements:
BuildRequires:  python-Sphinx
# Test requirements:
BuildRequires:  python-py >= 1.4.14
BuildRequires:  python-pytest >= 2.3.5
BuildRequires:  python-pytz
Requires:       python-pytz
Requires(post): update-alternatives
Requires(postun): update-alternatives
Provides:       python-babel = %{version}
Obsoletes:      python-babel < %{version}
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
BuildRequires:  python-argparse
Requires:       python-argparse
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch:      noarch
%endif

%description
A collection of tools for internationalizing Python applications.

%prep
%setup -q -n Babel-%{version}
%patch0 -p1
sed -i "s/pybabel =/pybabel-%{py_ver} =/" setup.py

%build
python setup.py build
python setup.py build_sphinx && rm build/sphinx/html/.buildinfo

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
ln -s  %{_bindir}/pybabel-%{py_ver} %{buildroot}%{_bindir}/pybabel
%fdupes %{buildroot}%{python_sitelib}

%check
LC_ALL=C py.test tests

%pre
# Since /usr/bin/pybabel became ghosted to be used with update-alternatives, we have to get rid
# of the old binary resulting from the non-update-alternativies-ified package:
[ -h %{_bindir}/pybabel ] || rm -f %{_bindir}/pybabel

%post
update-alternatives --install %{_bindir}/pybabel pybabel %{_bindir}/pybabel-%{py_ver} 20

%preun
if [ $1 -eq 0 ] ; then
    update-alternatives --remove pybabel %{_bindir}/pybabel-%{py_ver}
fi

%files
%defattr(-,root,root,-)
%doc LICENSE CHANGES README build/sphinx/html
%ghost %{_bindir}/pybabel
%{_bindir}/pybabel-%{py_ver}
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by