File python-cinderclient.spec of Package python-cinderclient
#
# spec file for package python-cinderclient
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define component cinderclient
%define version_unconverted 1.4.0
Name: python-%{component}
Version: 1.4.0
Release: 0
Summary: Openstack Block Storage (Cinder) API Client
License: Apache-2.0
Group: Development/Languages/Python
Url: http://launchpad.net/python-cinderclient
Source: https://pypi.python.org/packages/source/p/python-cinderclient/python-cinderclient-%{version}.tar.gz
Source99: %name-rpmlintrc
BuildRequires: openstack-suse-macros
BuildRequires: python-devel
BuildRequires: python-pbr
# Documentation build requirements:
BuildRequires: python-PrettyTable
BuildRequires: python-Sphinx
BuildRequires: python-oslosphinx
BuildRequires: python-requests
Requires: python >= 2.6.8
Requires: python-Babel >= 1.3
Requires: python-PrettyTable >= 0.7
Requires: python-pbr >= 1.6
Requires: python-requests >= 2.5.2
Requires: python-simplejson >= 2.2.0
Requires: python-six >= 1.9.0
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
Requires: python-argparse
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
This is a client for the OpenStack Volume API. There's a Python API (the
cinderclient module), and a command-line script (cinder). Each implements 100%
of the OpenStack Volume API.
%package doc
Summary: Openstack Block Storage (Cinder) API Client - Documentation
Group: Documentation/HTML
Requires: %{name} = %{version}
%description doc
This package contains documentation files for %{name}.
%package test
Summary: Openstack Block Storage (Cinder) API Client - Testsuite
Group: Development/Languages/Python
Requires: %{name} = %{version}
%if 0%{?suse_version} <= 1110
Requires: python-discover
%endif
Requires: python-fixtures >= 1.3.1
Requires: python-mock >= 1.2
Requires: python-python-subunit >= 0.0.18
Requires: python-testrepository >= 0.0.18
Requires: python-testtools >= 1.4.0
%description test
This package contains testsuite files for %{name}.
%prep
%setup -q
%openstack_cleanup_prep
echo %{version} > cinderclient/versioninfo
%build
python setup.py build
python setup.py build_sphinx
%install
python setup.py install --skip-build --prefix=%{_prefix} --root=%{buildroot}
rm doc/build/html/.buildinfo
### bash-completion
install -p -D -m 644 tools/cinder.bash_completion %{buildroot}%{_sysconfdir}/bash_completion.d/openstack-cinder.sh
### test subpackage
%openstack_test_package_install
%files
%defattr(-,root,root,-)
%doc LICENSE README.rst
%{_sysconfdir}/bash_completion.d/openstack-cinder.sh
%{_bindir}/cinder
%{python_sitelib}/%{component}/
%{python_sitelib}/python_%{component}-*.egg-info
%files doc
%defattr(-,root,root,-)
%doc LICENSE doc/build/html
%files test
%defattr(-,root,root,-)
%{_localstatedir}/lib/%{name}-test/
%changelog