File python-openstackclient.spec of Package python-openstackclient
#
# spec file for package python-openstackclient
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define component openstackclient
Name: python-%{component}
Version: 1.7.2
Release: 0
Summary: OpenStack Unified Command Line Client
License: Apache-2.0
Group: Development/Languages/Python
Url: http://launchpad.net/python-openstackclient
Source: https://pypi.python.org/packages/source/p/python-openstackclient/python-openstackclient-%{version}.tar.gz
Source99: rpmlintrc
# PATCH-FIX-UPSTREAM 0001-Fix-shared-block-migration-options.patch bsc#1034062 igarcia@suse.com -- Fix reverse options for migration command https://review.openstack.org/#/c/385138/
Patch1: 0001-Fix-shared-block-migration-options.patch
BuildRequires: openstack-suse-macros
BuildRequires: python-pbr >= 0.5.21
# Documentation requirements:
BuildRequires: python-Sphinx
# Test requirements:
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
BuildRequires: python-discover
%endif
BuildRequires: python-Babel >= 1.3
BuildRequires: python-cinderclient
BuildRequires: python-cliff >= 1.4.3
BuildRequires: python-cliff-tablib >= 1.0
BuildRequires: python-fixtures
BuildRequires: python-glanceclient >= 0.9.0
BuildRequires: python-keystoneclient
BuildRequires: python-mock >= 1.0
BuildRequires: python-mox3 >= 0.7.0
BuildRequires: python-neutronclient
BuildRequires: python-novaclient >= 2.15.0
BuildRequires: python-oslo.i18n
BuildRequires: python-oslo.utils
BuildRequires: python-oslotest
BuildRequires: python-pycrypto >= 2.6
BuildRequires: python-requests >= 1.1
BuildRequires: python-requests-mock
BuildRequires: python-six >= 1.7.0
BuildRequires: python-testrepository >= 0.0.17
BuildRequires: python-testtools >= 0.9.32
Requires: python-WebOb >= 1.2.3
Requires: python-cinderclient >= 1.3.1
Requires: python-cliff >= 1.14.0
Requires: python-cliff-tablib >= 1.0
Requires: python-glanceclient >= 0.18.0
Requires: python-keystoneclient >= 1.6.0
Requires: python-neutronclient >= 2.6.0
Requires: python-novaclient >= 2.28.1
Requires: python-os-client-config >= 1.4.0
Requires: python-oslo.config >= 2.3.0
Requires: python-oslo.i18n >= 1.5.0
Requires: python-pbr >= 1.6
Requires: python-requests >= 2.5.2
Requires: python-six >= 1.9.0
Requires: python-stevedore >= 1.5.0
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%py_requires
%else
BuildArch: noarch
%endif
Provides: %{name}-test = %{version}
#TODO(saschpe): Change back to '<' after next version update:
Obsoletes: %{name}-test <= %{version}
%description
A unified command-line client for OpenStack. Combines the
functionality of the individual OpenStack project clients.
%prep
%setup -q
%patch1 -p1
%openstack_cleanup_prep
%build
python setup.py build
python setup.py build_sphinx && rm doc/build/html/.buildinfo
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%check
testr init && testr run --parallel
%files
%defattr(-,root,root,-)
%doc LICENSE README.rst doc/build/html
%{_bindir}/openstack
%{python_sitelib}/%{component}/
%{python_sitelib}/python_%{component}-*.egg-info
%changelog