File python-pyOpenSSL.spec of Package python-pyOpenSSL
#
# spec file for package python-pyOpenSSL
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-pyOpenSSL
Version: 0.15.1
Release: 0
Url: https://github.com/pyca/pyopenssl
Summary: Python wrapper module around the OpenSSL library
License: Apache-2.0
Group: Development/Languages/Python
Source: http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-%{version}.tar.gz
Patch0: bug-lp-1265482.diff
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python-Sphinx
BuildRequires: python-cryptography >= 0.2
BuildRequires: python-devel
BuildRequires: python-setuptools
Requires: python-cryptography >= 0.2
Provides: pyOpenSSL = %{version}
Provides: python-openssl = %{version}
Obsoletes: python-openssl < %{version}
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
pyOpenSSL is a set of Python bindings for OpenSSL. It includes some low-level
cryptography APIs but is primarily focused on providing an API for using the
TLS protocol from Python.
pyOpenSSL is now a pure-Python project with a dependency on a new project,
cryptography (<https://github.com/pyca/cryptography>), which provides (among
other things) a cffi-based interface to OpenSSL.
%package doc
Summary: Documentation for %{name}
Group: Documentation/HTML
%description doc
Provides documentation for %{name}.
%prep
%setup -q -n pyOpenSSL-%{version}
%patch0
%build
CFLAGS="%{optflags} -fno-strict-aliasing" python setup.py build
python setup.py build_sphinx && rm build/sphinx/html/.buildinfo
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%files
%defattr(0644,root,root,0755)
%doc LICENSE README.rst TODO
%{python_sitelib}/OpenSSL/
%{python_sitelib}/pyOpenSSL-%{version}-py*.egg-info/
%files doc
%defattr(0644,root,root,0755)
%doc build/sphinx/html/
%doc examples/
%changelog