File python-osc-lib.spec of Package python-osc-lib
#
# spec file for package python-osc-lib
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-osc-lib
Version: 3.1.0
Release: 0
Summary: OpenStackClient Library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/developer/osc-lib
Source0: https://files.pythonhosted.org/packages/source/o/osc-lib/osc-lib-3.1.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: python3-cliff
BuildRequires: python3-fixtures
BuildRequires: python3-keystoneauth1
BuildRequires: python3-openstacksdk
BuildRequires: python3-oslo.i18n
BuildRequires: python3-oslo.utils
BuildRequires: python3-oslotest
BuildRequires: python3-osprofiler
BuildRequires: python3-pbr
BuildRequires: python3-platformdirs
BuildRequires: python3-requests-mock
BuildRequires: python3-simplejson
BuildRequires: python3-stestr
BuildRequires: python3-stevedore
BuildRequires: python3-testtools
BuildArch: noarch
%description
OpenStackClient (aka OSC) is a command-line client for OpenStack. osc-lib
is a package of common support modules for writing OSC plugins.
%package -n python3-osc-lib
Summary: OpenStackClient Library
Requires: python3-cliff
Requires: python3-keystoneauth1
Requires: python3-openstacksdk
Requires: python3-oslo.i18n
Requires: python3-oslo.utils
Requires: python3-pbr
Requires: python3-platformdirs
Requires: python3-simplejson
Requires: python3-stevedore
%description -n python3-osc-lib
OpenStackClient (aka OSC) is a command-line client for OpenStack. osc-lib
is a package of common support modules for writing OSC plugins.
This package contains the Python 3.x module.
%package -n python-osc-lib-doc
Summary: Documentation for the OpenStack client library
BuildRequires: python3-Sphinx
BuildRequires: python3-openstackdocstheme
BuildRequires: python3-reno
BuildRequires: python3-sphinxcontrib-apidoc
%description -n python-osc-lib-doc
Documentation for the OpenStack client library.
%prep
%autosetup -p1 -n osc-lib-3.1.0
%py_req_cleanup
%build
%{py3_build}
%install
%{py3_install}
# generate html docs
PBR_VERSION=%{version} PYTHONPATH=. %sphinx_build -a -E -d doc/build/doctrees -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%check
%{openstack_stestr_run}
%files -n python3-osc-lib
%license LICENSE
%doc README.rst ChangeLog
%{python3_sitelib}/osc_lib
%{python3_sitelib}/*.egg-info
%files -n python-osc-lib-doc
%license LICENSE
%doc doc/build/html
%changelog