File python-WebOb.spec of Package python-WebOb
#
# spec file for package python-WebOb
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-WebOb
Version: 1.4.1
Release: 0
Summary: WSGI request and response object
License: MIT
Group: Development/Languages/Python
Url: http://webob.org/
Source: http://pypi.python.org/packages/source/W/WebOb/WebOb-%{version}.tar.gz
BuildRequires: python-devel
BuildRequires: python-setuptools
# Test requirements:
# for ssl module:
BuildRequires: python
BuildRequires: python-nose
# Documentation requirements:
BuildRequires: python-Sphinx
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Provides: python-webob = %{version}
Obsoletes: python-webob < %{version}
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
WebOb provides wrappers around the WSGI request environment, and an
object to help create WSGI responses.
The objects map much of the specified behavior of HTTP, including
header parsing and accessors for other standard parts of the
environment.
%package doc
Summary: WSGI request and response object - Documentation
Group: Documentation/HTML
Requires: %{name} = %{version}
%description doc
This package contains documentation files for %{name}.
%prep
%setup -q -n WebOb-%{version}
%build
python setup.py build
python setup.py build_sphinx && rm build/sphinx/html/.buildinfo
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%check
python setup.py test
%files
%defattr(-,root,root,-)
%doc docs/license.txt
%{python_sitelib}/*
%files doc
%defattr(-,root,root,-)
%doc build/sphinx/html
%changelog