File python-WebTest.spec of Package python-WebTest
#
# spec file for package python-WebTest
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-WebTest
Version: 2.0.18
Release: 0
Url: http://webtest.pythonpaste.org/
Summary: Helper to test WSGI applications
License: MIT
Group: Development/Languages/Python
Source: http://pypi.python.org/packages/source/W/WebTest/WebTest-%{version}.zip
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python-PasteDeploy
BuildRequires: python-WSGIProxy2
BuildRequires: python-base
BuildRequires: python-beautifulsoup4
BuildRequires: python-cssselect
BuildRequires: python-mock
BuildRequires: python-pyquery
BuildRequires: python-setuptools
BuildRequires: python-six
BuildRequires: python-waitress
BuildRequires: unzip
# Documentation build requirements:
BuildRequires: python-Sphinx
# Test build requirements:
BuildRequires: python-WebOb
BuildRequires: python-coverage
BuildRequires: python-nose
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
BuildRequires: python-unittest2
%endif
Requires: python-WebOb >= 1.2
Requires: python-beautifulsoup4
Requires: python-six
Requires: python-waitress
Provides: python-webtest = %{version}
Obsoletes: python-webtest < %{version}
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
This wraps any WSGI application and makes it easy to send test
requests to that application, without starting up an HTTP server.
This provides convenient full-stack testing of applications written
with any WSGI-compatible framework.
%package doc
Summary: Helper to test WSGI applications - Documentation
Group: Documentation/HTML
Requires: %{name} = %{version}
%description doc
This package contains documentation files for %{name}.
%prep
%setup -q -n WebTest-%{version}
# remove version limitation for nose
sed -i 's/nose<1\.3\.0/nose/' setup.py
%build
python setup.py build
python setup.py build_sphinx && rm build/sphinx/html/.buildinfo
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%if 0%{?suse_version} > 1110
%check
python setup.py -q test
%endif
%files
%defattr(-,root,root,-)
%doc README.rst docs/license.rst
%{python_sitelib}/*
%files doc
%defattr(-,root,root,-)
%doc build/sphinx/html
%changelog