File python-requests.spec of Package python-requests

#
# spec file for package python-requests
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%if 0%{?suse_version} < 1120
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
%endif
Name:           python-requests
Version:        2.9.1
Release:        0
Summary:        Awesome Python HTTP Library That's Actually Usable
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            http://python-requests.org/
Source:         http://pypi.python.org/packages/source/r/requests/requests-%{version}.tar.gz
# PATCH-FIX-OPENSUSE no-default-cacert.patch -- Completely ignore the internal CA bundle.
Patch0:         no-default-cacert.patch
BuildRequires:  python
BuildRequires:  python-devel
BuildRequires:  python-py
BuildRequires:  python-setuptools
Requires:       python
# Really needed?
#Requires:       python-ndg-httpsclient
Requires:       python-pyOpenSSL
Requires:       python-pyasn1
%if 0%{?suse_version} >= 1120 && !(0%{?suse_version} == 1315 && !0%{?is_opensuse})
BuildRequires:  ca-certificates
Requires:       ca-certificates
%endif
%if 0%{?suse_version} >= 1120
BuildArch:      noarch
%else
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%endif

%description
Requests is an ISC Licensed HTTP library, written in Python, for
human beings.

Most existing Python modules for sending HTTP requests are
extremely verbose and cumbersome. Python's builtin urllib2 module
provides most of the HTTP capabilities you should need, but the api
is thoroughly broken. It requires an enormous amount of work (even
method overrides) to perform the simplest of tasks.

Features:
 - Extremely simple GET, HEAD, POST, PUT, DELETE Requests:
   + Simple HTTP Header Request Attachment.
   + Simple Data/Params Request Attachment.
   + Simple Multipart File Uploads.
   + CookieJar Support.
   + Redirection History.
   + Redirection Recursion Urllib Fix.
   + Auto Decompression of GZipped Content.
   + Unicode URL Support.
 - Simple Authentication:
   + Simple URL + HTTP Auth Registry.

%prep
%setup -q -n requests-%{version}
%if 0%{?suse_version} >= 1120 && !(0%{?suse_version} == 1315 && !0%{?is_opensuse})
%patch0 -p1
rm -f requests/cacert.pem
%endif

%build
python setup.py build

%install
python setup.py install \
  --root=%{buildroot} --prefix=%{_prefix}

# Tests require network access.
# %check
# python test_requests.py

%files
%defattr(-,root,root)
%doc HISTORY.rst LICENSE NOTICE README.rst
%{python_sitelib}/requests/
%{python_sitelib}/requests-*

%changelog
openSUSE Build Service is sponsored by