File python-websocket-client.spec of Package python-websocket-client

#
# spec file for package python-websocket-client
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


# RHEL provides this backport in its own repository
%if 0%{?rhel} == 7
%define backports python-backports-ssl_match_hostname
%else
%define backports python-backports.ssl_match_hostname
%endif

Name:           python-websocket-client
Version:        0.37.0
Release:        0
Summary:        WebSocket client implementation
License:        LGPL-2.1
Group:          Development/Languages/Python
Url:            https://github.com/liris/websocket-client/releases
Source0:        https://pypi.io/packages/source/w/websocket-client/websocket_client-%{version}.tar.gz
BuildRequires:  %backports
BuildRequires:  python-setuptools
BuildRequires:  python-six
Requires:       %backports
Requires:       python
Requires:       python-six
Requires(post): update-alternatives
Requires(postun): update-alternatives
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
BuildRequires:  python-argparse
BuildRequires:  python-unittest2
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch:      noarch
%endif

%description
websocket-client module  is WebSocket client for python. This provide the
low level APIs for WebSocket. All APIs are the synchronous functions.

websocket-client supports only hybi-13.

%package test
Summary:        Unit tests
Group:          Development/Languages/Python
Requires:       python-websocket-client = %{version}

%description test
Unit tests for websocket-client

%prep
%setup -q -n websocket_client-%{version}

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
# Use the system certs
rm %{buildroot}/%{python_sitelib}/websocket/cacert.pem
# update alternatives
mv %{buildroot}%{_bindir}/wsdump.py %{buildroot}%{_bindir}/wsdump.py-%{py_ver}
mkdir -p %{buildroot}%{_sysconfdir}/alternatives
touch %{buildroot}%{_sysconfdir}/alternatives/wsdump.py
ln -sf %{_sysconfdir}/alternatives/wsdump.py %{buildroot}/%{_bindir}/wsdump.py

%check
python websocket/tests/test_websocket.py

%post
update-alternatives \
    --install %{_bindir}/wsdump.py wsdump.py %{_bindir}/wsdump.py-%{py_ver} 20

%postun
if [ $1 -eq 0 ] ; then
    update-alternatives --remove wsdump.py %{_bindir}/wsdump.py-%{py_ver}
fi

%files
%defattr(-,root,root,-)
%doc LICENSE README.rst
%dir %{python_sitelib}/websocket
%dir %{python_sitelib}/websocket_client-%{version}-py*.egg-info
%{_bindir}/wsdump.py
%{_bindir}/wsdump.py-%{py_ver}
%exclude %{python_sitelib}/websocket/tests/
%{python_sitelib}/websocket/*
%{python_sitelib}/*egg-info/*
%ghost %{_sysconfdir}/alternatives/wsdump.py

%files test
%defattr(-,root,root,-)
%dir %{python_sitelib}/websocket/tests
%{python_sitelib}/websocket/tests/*

%changelog
openSUSE Build Service is sponsored by