File python-manilaclient.spec of Package python-manilaclient

#
# spec file for package python-manilaclient
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%global sname python-manilaclient
Name:           python-manilaclient
Version:        1.14.0
Release:        0
Summary:        Client Library for OpenStack Share API
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://launchpad.net/%{sname}
Source0:        https://pypi.io/packages/source/p/%{sname}/%{sname}-%{version}.tar.gz
BuildRequires:  openstack-macros
BuildRequires:  openstack-tempest
BuildRequires:  python-ddt >= 1.0.1
BuildRequires:  python-devel
BuildRequires:  python-fixtures >= 3.0.0
BuildRequires:  python-mock >= 2.0
BuildRequires:  python-openstackclient >= 3.3.0
BuildRequires:  python-oslotest >= 1.10.0
BuildRequires:  python-testrepository >= 0.0.18
BuildRequires:  python-testtools >= 1.4.0
Requires:       python-Babel >= 2.3.4
Requires:       python-PrettyTable >= 0.7.1
Requires:       python-keystoneclient >= 3.8.0
Requires:       python-oslo.config >= 3.14.0
Requires:       python-oslo.log >= 3.11.0
Requires:       python-oslo.serialization >= 1.10.0
Requires:       python-oslo.utils >= 3.18.0
Requires:       python-requests >= 2.10.0
Requires:       python-simplejson >= 2.2.0
Requires:       python-six >= 1.9.0
BuildArch:      noarch

%description
Client library and command line utility for interacting with Openstack
Share API.

%package doc
Summary:        Documentation for OpenStack Share API Client
Group:          Documentation
BuildRequires:  python-Sphinx
BuildRequires:  python-oslosphinx >= 4.7.0

%description      doc
Client library and command line utility for interacting with Openstack
Share API.
This package contains auto-generated documentation.

%package test
Summary:        Testsuite for OpenStack Share API Client
Group:          Development/Languages/Python
Requires:       %{name} = %{version}
Requires:       openstack-tempest
Requires:       python-ddt >= 1.0.1
Requires:       python-fixtures >= 3.0.0
Requires:       python-mock >= 2.0
Requires:       python-openstackclient >= 3.3.0
Requires:       python-oslotest >= 1.10.0
Requires:       python-testrepository >= 0.0.18
Requires:       python-testtools >= 1.4.0

%description    test
Client library and command line utility for interacting with Openstack
Share API.
This package contains the testsuite.

%prep
%autosetup -n %{sname}-%{version}
%py_req_cleanup

%build
%{py2_build}

%{__python2} setup.py build_sphinx
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}

%install
%{py2_install}
# man page
install -p -D -m 644 doc/build/man/python-manilaclient.1 %{buildroot}%{_mandir}/man1/python-manilaclient.1
# bash completion
install -p -D -m 644 tools/manila.bash_completion %{buildroot}%{_sysconfdir}/bash_completion.d/%{name}
# handle the test subpackage
%openstack_test_package_install manilaclient

%check
%{__python2} setup.py testr

%files
%doc README.rst
%license LICENSE
%{python2_sitelib}/manilaclient
%{python2_sitelib}/*.egg-info
%{_sysconfdir}/bash_completion.d/%{name}
%{_mandir}/man1/python-manilaclient.1.gz
%{_bindir}/manila

%files doc
%license LICENSE
%doc doc/build/html

%files test
%license LICENSE
%openstack_test_package_dir

%changelog
openSUSE Build Service is sponsored by