File python-psycopg2.spec of Package python-psycopg2
#
# spec file for package python-psycopg2
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-psycopg2
Version: 2.6.2
Release: 0
Summary: Python-PostgreSQL Database Adapter
License: LGPL-3.0+ and (LGPL-3.0+ or ZPL-2.0) and SUSE-GPL-2.0-with-openssl-exception
Group: Development/Languages/Python
Url: http://initd.org/psycopg/
Source: http://pypi.python.org/packages/source/p/psycopg2/psycopg2-%{version}.tar.gz
BuildRequires: fdupes
BuildRequires: postgresql-devel
BuildRequires: python-Sphinx
BuildRequires: python-devel
Suggests: postgresql-server
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitearch: %global python_sitearch %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%endif
%description
psycopg2 is a PostgreSQL database adapter for the Python programming
language. psycopg2 was written with the aim of being very small and fast,
and stable as a rock.
psycopg2 is different from the other database adapter because it was
designed for heavily multi-threaded applications that create and destroy
lots of cursors and make a conspicuous number of concurrent INSERTs or
UPDATEs. psycopg2 also provide full asycronous operations and support
for coroutine libraries.
%package doc
Summary: Documentation for psycopg python PostgreSQL database adapter
Group: Documentation/HTML
Requires: %{name} = %{version}
%description doc
Documentation and example files for the psycopg python PostgreSQL database adapter.
%prep
%setup -q -n psycopg2-%{version}
# use the year from source gzip header instead of current one to make reproducible rpms
year=$(perl -e 'sysread(STDIN, $h, 8); print (1900+(gmtime(unpack("l",substr($h,4))))[5])' < %{S:0})
sed -i "s/^year =.*/year=$year/" doc/src/conf.py
%build
CFLAGS="%{optflags} -fno-strict-aliasing" python setup.py build
rm -rf doc/build # Remove junk
sphinx-build doc/src doc/build/html
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
rm -rf %{buildroot}%{python_sitearch}/psycopg2/tests # Don't package testsuite
%fdupes -s %{buildroot}/%{_mandir} # Create symlinks for man pages
%fdupes %{buildroot} # Create hardlinks for the rest
%files
%defattr(-,root,root,-)
%doc AUTHORS LICENSE NEWS README.rst
%{python_sitearch}/psycopg2/
%{python_sitearch}/psycopg2-%{version}-py%{py_ver}.egg-info
%files doc
%defattr(-,root,root)
%doc doc/build/html examples/
%changelog