File python-Paste.spec of Package python-Paste

#
# spec file for package python-Paste
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%bcond_without tests

%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%define oldpython python
Name:           python-Paste
Version:        2.0.3
Release:        0
Url:            http://pythonpaste.org
Summary:        Tools for using a Web Server Gateway Interface stack
License:        MIT
Group:          Development/Languages/Python
Source:         https://files.pythonhosted.org/packages/source/P/Paste/Paste-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRequires:  %{python_module six > 1.4.0}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
# Documentation build requirements:
BuildRequires:  python3-Sphinx
# Test build requirements:
BuildRequires:  %{python_module nose}
%if 0%{?suse_version} >= 1000 || 0%{?fedora_version} >= 24
Suggests:       python-flup
%endif
Requires:       python-six > 1.4.0
%ifpython2
%if 0%{?suse_version} >= 1000 || 0%{?fedora_version} >= 24
Suggests:       python-python-openid
%endif
Provides:       %{oldpython}-paste = %{version}
Obsoletes:      %{oldpython}-paste < %{version}
%endif
%ifpython3
%if 0%{?suse_version} >= 1000 || 0%{?fedora_version} >= 24
Suggests:       python3-python3-openid
%endif
%endif
BuildArch:      noarch
%python_subpackages

%description
These provide several pieces of "middleware" (or filters) that can be nested
to build web applications.  Each piece of middleware uses the WSGI (PEP 333)
interface, and should be compatible with other middleware based on those
interfaces.

%prep
%setup -q -n Paste-%{version}
# remove test requiring internet access
rm tests/test_proxy.py
# remove .orig files (see https://bitbucket.org/ianb/paste/issues/11/pypi-tarball-of-version-202-contains-orig)
rm paste/urlmap.py.orig
rm paste/httpserver.py.orig
rm paste/util/template.py.orig

%build
%python_build
%{__python3} setup.py build_sphinx && rm build/sphinx/html/.buildinfo

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%if %{with tests}
%check
%python_exec setup.py -q test
%endif

%files %{python_files}
%defattr(-,root,root,-)
%doc docs/license.txt
%doc build/sphinx/html/
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by