File python-pifpaf.spec of Package python-pifpaf
#
# spec file for package python-pifpaf
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name: python-pifpaf
Version: 2.1.1
Release: 0
Summary: Suite of tools and fixtures to manage daemons for testing
License: Apache-2.0
Group: Development/Languages/Python
Url: https://github.com/jd/pifpaf
Source: https://pypi.io/packages/source/p/pifpaf/pifpaf-%{version}.tar.gz
BuildRequires: %{python_module devel}
BuildRequires: %{python_module pbr}
BuildRequires: python-rpm-macros
Requires: python-Jinja2
Requires: python-click
Requires: python-daiquiri
Requires: python-fixtures
Requires: python-mock
Requires: python-psutil
Requires: python-requests
Requires: python-six
Requires: python-testrepository
Requires: python-testtools
Requires: python-xattr
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Requires(post): update-alternatives
Requires(postun): update-alternatives
BuildArch: noarch
%python_subpackages
%description
Pifpaf is a suite of `fixtures`_ and a command-line tool that allows to start
and stop daemons for a quick throw-away usage. This is typically useful when
needing these daemons to run `integration testing`_. It originaly evolved from
its precussor `overtest`_.
%prep
%setup -q -n pifpaf-%{version}
%build
export LC_ALL=en_US.utf8
%python_build
%install
export LC_ALL=en_US.utf8
%python_install
%python_clone -a %{buildroot}%{_bindir}/pifpaf
%post
%python_install_alternative pifpaf
%postun
%python_uninstall_alternative pifpaf
%files %{python_files}
%license LICENSE
%doc ChangeLog README.rst
%{python_sitelib}/*
%python_alternative %{_bindir}/pifpaf
%changelog