File python-pyserial.spec of Package python-pyserial
#
# spec file for package python-pyserial
#
# Copyright (c) 2017 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name: python-pyserial
Version: 3.4
Release: 0
Url: https://github.com/pyserial/pyserial
Summary: Python Serial Port Extension
License: Python-2.0
Group: Development/Languages/Python
Source: https://files.pythonhosted.org/packages/source/p/pyserial/pyserial-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: fdupes
BuildRequires: python-rpm-macros
BuildRequires: %{python_module devel}
BuildRequires: %{python_module setuptools}
BuildRequires: python3-Sphinx
BuildArch: noarch
Provides: python-serial = %{version}
Obsoletes: python-serial < %{version}
Requires(post): update-alternatives
Requires(preun): update-alternatives
%python_subpackages
%description
Python Serial Port Extension for Win32, Linux, BSD, Jython, IronPython
%package -n %{name}-doc
Summary: Documentation for %{name}
Group: Documentation/Other
Provides: python2-pyserial-doc = %{version}
Provides: python3-pyserial-doc = %{version}
%description -n %{name}-doc
Documentation, examples, and help files for %{name}.
%prep
%setup -q -n pyserial-%{version}
sed -i "s|^#\!\/usr\/bin\/env python$||" serial/{serialposix,__init__}.py # Fix non-executable scripts
sed -i "s/\r//" examples/port_publisher.py # Fix EOL encoding
find examples -name '*.py' -exec sed -i "s|^#!/usr/bin/env python$|#!%{__python3}|" {} \;
find examples -name '*.py' -exec sed -i "s|^#! /usr/bin/env python$|#!%{__python3}|" {} \;
find examples -name '*.py' -exec sed -i "s|^#! python$|#!%{__python3}|" {} \;
%build
%python_build
make -C documentation html && rm documentation/_build/html/.buildinfo # Build HTML documentation
%install
%python_install
mv %{buildroot}%{_bindir}/miniterm.py %{buildroot}%{_bindir}/miniterm
%python_clone -a %{buildroot}%{_bindir}/miniterm
rm documentation/_build/doctrees/environment.pickle
%{python_expand pushd %{buildroot}%{$python_sitelib}
# Fix wrong-script-interpreter
sed -i "s|^#!/usr/bin/env python$|#!%{__$python}|" serial/tools/*.py
sed -i "s|^#!/usr/bin/env python3$|#!%{__$python}|" serial/threaded/__init__.py
sed -i "s|^#!/usr/bin/env python$|#!%{__$python}|" serial/rs485.py
sed -i "s|^#! python$||#!%{__$python}|" serial/tools/*.py
chmod a+x serial/tools/*.py
chmod a-x serial/tools/__init__.py
chmod a-x serial/tools/list_ports_windows.py
chmod a-x serial/tools/hexlify_codec.py
chmod a+x serial/threaded/__init__.py
chmod a+x serial/rs485.py
# Deduplicating files can generate a RPMLINT warning for pyc mtime
$python -m compileall -d %{$python_sitelib} serial/
$python -O -m compileall -d %{$python_sitelib} serial/
%fdupes .
popd
}
%post
%python_install_alternative miniterm
%preun
%python_uninstall_alternative miniterm
%files %{python_files}
%defattr(-,root,root,-)
%doc CHANGES.rst LICENSE.txt README.rst
%python_alternative miniterm
%{python_sitelib}/serial/
%{python_sitelib}/pyserial-%{version}-py*.egg-info
%files -n %{name}-doc
%defattr(-,root,root,-)
%doc examples/
%doc documentation/_build/*
%changelog