File python-testrepository.spec of Package python-testrepository
#
# spec file for package python-testrepository
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name: python-testrepository
Version: 0.0.20
Release: 0
Summary: A repository of test results
License: BSD-3-Clause or Apache-2.0
Group: Development/Languages/Python
Url: https://launchpad.net/testrepository
Source: https://pypi.io/packages/source/t/testrepository/testrepository-%{version}.tar.gz
BuildRequires: %{python_module devel}
BuildRequires: %{python_module extras}
BuildRequires: %{python_module fixtures}
BuildRequires: %{python_module pbr}
BuildRequires: %{python_module python-mimeparse}
BuildRequires: %{python_module python-subunit}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module testresources}
BuildRequires: %{python_module testscenarios}
BuildRequires: %{python_module testtools}
BuildRequires: python-rpm-macros
Requires: python-extras
Requires: python-fixtures
Requires: python-python-subunit >= 0.0.10
Requires: python-testscenarios
Requires: python-testtools >= 0.9.30
%ifpython3
Requires: python3-dbm
%endif
Requires(post): update-alternatives
Requires(postun): update-alternatives
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildArch: noarch
%python_subpackages
%description
This project provides a database of test results which can be used as part of
developer workflow to ensure/check things like:
* No commits without having had a test failure, test fixed cycle.
* No commits without new tests being added.
* What tests have failed since the last commit (to run just a subset).
* What tests are currently failing and need work.
Test results are inserted using subunit (and thus anything that can output
subunit or be converted into a subunit stream can be accepted).
%prep
%setup -q -n testrepository-%{version}
%build
%python_build
%install
%python_install
%python_clone -a %{buildroot}%{_bindir}/testr
%post
%python_install_alternative testr
%preun
%python_uninstall_alternative testr
%files %{python_files}
%defattr(-,root,root,-)
%doc Apache-2.0 COPYING NEWS README.txt BSD
%python_alternative %{_bindir}/testr
%{python_sitelib}/*
%changelog