File openstack-murano.spec of Package openstack-murano
#
# spec file for package openstack-murano
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global with_doc 1
%if 0%{?rhel} || 0%{?fedora}
%global rdo 1
%endif
Name: openstack-murano
Epoch: 0
Version: 10.0.1~dev3
Release: 0
Summary: OpenStack Application Catalog (murano)
License: Apache-2.0
Group: System/Management
URL: https://launchpad.net/murano
Source0: murano-stable-victoria.tar.gz
Source1: openstack-murano.logrotate
Source2: openstack-murano.tmpfiles
Source3: openstack-murano.defaultconf
Source4: openstack-murano.README.config
# systemd service files
Source5: openstack-murano-api.service
Source6: openstack-murano-engine.service
BuildRequires: openstack-macros
BuildRequires: python3-Babel
BuildRequires: python3-WebOb
BuildRequires: python3-castellan
BuildRequires: python3-congressclient
BuildRequires: python3-fixtures
BuildRequires: python3-heatclient
BuildRequires: python3-jsonschema
BuildRequires: python3-keystonemiddleware
BuildRequires: python3-mistralclient
BuildRequires: python3-mock
BuildRequires: python3-muranoclient
BuildRequires: python3-neutronclient
BuildRequires: python3-oslo.concurrency
BuildRequires: python3-oslo.config
BuildRequires: python3-oslo.db
BuildRequires: python3-oslo.i18n
BuildRequires: python3-oslo.log
BuildRequires: python3-oslo.messaging
BuildRequires: python3-oslo.policy
BuildRequires: python3-oslo.upgradecheck
BuildRequires: python3-oslo.utils
BuildRequires: python3-oslotest
BuildRequires: python3-pbr
BuildRequires: python3-psutil
BuildRequires: python3-requests
BuildRequires: python3-semantic_version
BuildRequires: python3-six
BuildRequires: python3-stestr
BuildRequires: python3-tenacity
BuildRequires: python3-yaql
Requires: logrotate
Requires: python3-murano = %{epoch}:%{version}-%{release}
BuildArch: noarch
%if 0%{?suse_version}
BuildRequires: systemd-rpm-macros
Requires: pwdutils
%{?systemd_requires}
%else
BuildRequires: systemd
Requires(post): systemd
Requires(postun):systemd
Requires(pre): shadow-utils
Requires(preun):systemd
%endif
%description
OpenStack Application Catalog.
%package -n python3-murano
Summary: OpenStack Application Catalog (murano) - Python module
Group: Development/Languages/Python
Requires: python3-Babel
Requires: python3-Paste
Requires: python3-PasteDeploy
Requires: python3-PyYAML
Requires: python3-Routes
Requires: python3-SQLAlchemy
Requires: python3-WebOb
Requires: python3-alembic
Requires: python3-castellan
Requires: python3-congressclient
Requires: python3-debtcollector
Requires: python3-eventlet
Requires: python3-heatclient
Requires: python3-jsonpatch
Requires: python3-jsonschema
Requires: python3-keystoneauth1
Requires: python3-keystoneclient
Requires: python3-keystonemiddleware
Requires: python3-kombu
Requires: python3-mistralclient
Requires: python3-muranoclient
Requires: python3-netaddr
Requires: python3-neutronclient
Requires: python3-oslo.concurrency
Requires: python3-oslo.config
Requires: python3-oslo.context
Requires: python3-oslo.db
Requires: python3-oslo.i18n
Requires: python3-oslo.log
Requires: python3-oslo.messaging
Requires: python3-oslo.middleware
Requires: python3-oslo.policy
Requires: python3-oslo.serialization
Requires: python3-oslo.service
Requires: python3-oslo.utils
Requires: python3-pbr
Requires: python3-psutil
Requires: python3-semantic_version
Requires: python3-six
Requires: python3-stevedore
Requires: python3-tenacity
Requires: python3-testtools
Requires: python3-yaql
%description -n python3-murano
OpenStack Application Catalog.
This package contains the core Python module of OpenStack murano.
%package api
Summary: OpenStack Application Catalog (murano) - API
Group: Development/Languages/Python
Requires: %{name} = %{epoch}:%{version}-%{release}
%description api
OpenStack Application Catalog.
This package contains the OpenStack murano API.
%package engine
Summary: OpenStack Application Catalog (murano) - API
Group: Development/Languages/Python
Requires: %{name} = %{epoch}:%{version}-%{release}
%description engine
OpenStack Application Catalog.
This package contains the OpenStack murano Engine.
%if 0%{?with_doc}
%package doc
Summary: Openstack Application Catalog (murano) - Documentation
Group: Documentation/HTML
BuildRequires: python3-Sphinx
BuildRequires: python3-openstackdocstheme
BuildRequires: python3-reno
BuildRequires: python3-sphinxcontrib-httpdomain
%description doc
This package contains the documentation for OpenStack Murano.
%endif
%prep
%autosetup -p1 -n murano-10.0.1.dev3
%py_req_cleanup
%build
%{py3_build}
# documentation
%if 0%{?with_doc}
PYTHONPATH=. PBR_VERSION=10.0.1.dev3 %sphinx_build -b html doc/source doc/build/html
PYTHONPATH=. PBR_VERSION=10.0.1.dev3 %sphinx_build -b man doc/source doc/build/man
# remove the Sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
rm -rf doc/build/man/.{doctrees,buildinfo}
%endif
%install
%{py3_install}
### directories
install -d -m 750 %{buildroot}%{_localstatedir}/{lib,log,cache}/murano
install -D -m 644 %{SOURCE2} %{buildroot}/%{_tmpfilesdir}/%name.conf
install -d -m 755 %{buildroot}%{_sysconfdir}/murano
install -d -m 755 %{buildroot}%{_sysconfdir}/murano/murano.conf.d/
# sample config files
PYTHONPATH=. oslo-config-generator --config-file etc/oslo-config-generator/murano.conf --output-file %{buildroot}%{_sysconfdir}/murano/murano.conf
PYTHONPATH=. oslo-config-generator --config-file etc/oslo-config-generator/murano-cfapi.conf --output-file %{buildroot}%{_sysconfdir}/murano/murano-cfapi.conf
### configuration files
install -p -D -m 640 %{SOURCE4} %{buildroot}%{_sysconfdir}/murano/README.config
install -p -D -m 640 %{SOURCE3} %{buildroot}%{_sysconfdir}/murano/murano.conf.d/010-murano.conf
mv %{buildroot}%{_prefix}%{_sysconfdir}/murano/* %{buildroot}%{_sysconfdir}/murano/
# bash-completion/logrotate/etc.
install -p -D -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
### systemd service files
install -p -D -m 444 %{SOURCE5} %{buildroot}%{_unitdir}/%{name}-api.service
install -p -D -m 444 %{SOURCE6} %{buildroot}%{_unitdir}/%{name}-engine.service
# install symlinks on SUSE systems
%if 0%{?suse_version}
mkdir -p %{buildroot}%{_sbindir} %{buildroot}%{_unitdir}
ln -s %{_sbindir}/service %{buildroot}%{_sbindir}/rc%{name}-api
ln -s %{_sbindir}/service %{buildroot}%{_sbindir}/rc%{name}-engine
%endif
# man pages
%if 0%{?with_doc}
mkdir -p %{buildroot}%{_mandir}/man1
install -p -D -m 644 doc/build/man/*.1 %{buildroot}%{_mandir}/man1/
%endif
%check
# don't want to depend on hacking for package building
rm murano/tests/unit/test_hacking.py
%{__python3} -m stestr.cli run
%pre
%openstack_pre_user_group_create murano murano /sbin/nologin
%post
%tmpfiles_create %{_tmpfilesdir}/murano.conf
%post api
%systemd_post %{name}-api.service
%preun api
%systemd_preun %{name}-api.service
%postun api
%systemd_postun_with_restart %{name}-api.service
%post engine
%systemd_post %{name}-engine.service
%preun engine
%systemd_preun %{name}-engine.service
%postun engine
%systemd_postun_with_restart %{name}-engine.service
%files
%doc README.rst
%license LICENSE
%dir %attr(0750, murano, murano) %{_localstatedir}/lib/murano
%dir %attr(0750, murano, murano) %{_localstatedir}/cache/murano
%dir %attr(0750, murano, murano) %{_localstatedir}/log/murano
%{_tmpfilesdir}/%{name}.conf
%dir %{_sysconfdir}/murano
%dir %{_sysconfdir}/murano/murano.conf.d/
%{_sysconfdir}/murano/README.config
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
%config(noreplace) %attr(0640, root, murano) %{_sysconfdir}/murano/murano.conf
%config(noreplace) %attr(0640, root, murano) %{_sysconfdir}/murano/murano.conf.d/010-murano.conf
%config(noreplace) %attr(0640, root, murano) %{_sysconfdir}/murano/murano-cfapi.conf
%config %{_sysconfdir}/murano/murano-paste.ini
%config %{_sysconfdir}/murano/murano-cfapi-paste.ini
%{_bindir}/murano-manage
%{_bindir}/murano-db-manage
%{_bindir}/murano-status
%{_bindir}/murano-test-runner
%if 0%{?with_doc}
%{_mandir}/man1/murano.1.gz
%endif
%files -n python3-murano
%license LICENSE
%{python3_sitelib}/murano/
%{python3_sitelib}/murano-*.egg-info
%if 0%{?with_doc}
%files doc
%license LICENSE
%doc doc/build/html
%endif
%files api
%license LICENSE
%{_unitdir}/%{name}-api.service
%if 0%{?suse_version}
%{_sbindir}/rc%{name}-api
%endif
%{_bindir}/murano-api
%{_bindir}/murano-cfapi
%{_bindir}/murano-cfapi-db-manage
%{_bindir}/murano-wsgi-api
%files engine
%license LICENSE
%{_unitdir}/%{name}-engine.service
%if 0%{?suse_version}
%{_sbindir}/rc%{name}-engine
%endif
%{_bindir}/murano-engine
%changelog