File python-neutron-lib.spec of Package python-neutron-lib
#
# spec file for package python-neutron-lib
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-neutron-lib
Version: 2.6.2
Release: 0
Summary: OpenStack Neutron library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/developer/neutron-lib/
Source0: https://files.pythonhosted.org/packages/source/n/neutron-lib/neutron-lib-2.6.2.tar.gz
BuildRequires: openstack-macros
BuildRequires: python3-SQLAlchemy
BuildRequires: python3-WebOb
BuildRequires: python3-debtcollector
BuildRequires: python3-fixtures
BuildRequires: python3-keystoneauth1
BuildRequires: python3-os-api-ref
BuildRequires: python3-os-ken
BuildRequires: python3-os-traits
BuildRequires: python3-oslo.concurrency
BuildRequires: python3-oslo.config
BuildRequires: python3-oslo.context
BuildRequires: python3-oslo.db
BuildRequires: python3-oslo.i18n
BuildRequires: python3-oslo.log
BuildRequires: python3-oslo.messaging
BuildRequires: python3-oslo.policy
BuildRequires: python3-oslo.service
BuildRequires: python3-oslo.utils
BuildRequires: python3-oslo.versionedobjects
BuildRequires: python3-oslotest
BuildRequires: python3-osprofiler
BuildRequires: python3-pbr
BuildRequires: python3-pecan
BuildRequires: python3-python-subunit
BuildRequires: python3-setproctitle
BuildRequires: python3-stestr
BuildRequires: python3-testresources
BuildRequires: python3-testscenarios
BuildRequires: python3-testtools
BuildArch: noarch
%description
OpenStack Neutron library shared by all Neutron sub-projects.
%package -n python3-neutron-lib
Summary: OpenStack Neutron library
Requires: python3-SQLAlchemy
Requires: python3-WebOb
Requires: python3-keystoneauth1
Requires: python3-os-ken
Requires: python3-os-traits
Requires: python3-oslo.concurrency
Requires: python3-oslo.config
Requires: python3-oslo.context
Requires: python3-oslo.db
Requires: python3-oslo.i18n
Requires: python3-oslo.log
Requires: python3-oslo.messaging
Requires: python3-oslo.policy
Requires: python3-oslo.serialization
Requires: python3-oslo.service
Requires: python3-oslo.utils
Requires: python3-oslo.versionedobjects
Requires: python3-osprofiler
Requires: python3-pecan
Requires: python3-setproctitle
Requires: python3-six
Requires: python3-stevedore
%description -n python3-neutron-lib
OpenStack Neutron library shared by all Neutron sub-projects.
This package contains the Python 3.x module.
%package -n python-neutron-lib-doc
Summary: OpenStack Neutron library documentation
Group: Documentation/HTML
BuildRequires: python3-Sphinx
BuildRequires: python3-openstackdocstheme
BuildRequires: python3-reno
%description -n python-neutron-lib-doc
OpenStack Neutron library shared by all Neutron sub-projects.
%prep
%autosetup -n neutron-lib-%{version}
%py_req_cleanup
%build
%{py3_build}
%install
%{py3_install}
# Build HTML docs and man page
PBR_VERSION=%{version} %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%check
# we don't want to depend on hacking
rm -rf neutron_lib/tests/unit/hacking
python3 -m stestr.cli run
%files -n python3-neutron-lib
%license LICENSE
%doc README.rst
%{python3_sitelib}/neutron_lib
%{python3_sitelib}/neutron_lib*egg-info
%files -n python-neutron-lib-doc
%doc doc/build/html
%license LICENSE
%changelog