File python-monasca-common.spec of Package python-monasca-common
#
# spec file for package python-monasca-common
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global sname monasca-common
Name: python-monasca-common
Version: 3.3.1~dev5
Release: 0
Summary: Reusable code for building monitoring related services.
License: Apache-2.0
Group: Development/Languages/Python
URL: https://wiki.openstack.org/wiki/Monasca
Source0: monasca-common-stable-wallaby.tar.gz
BuildRequires: openstack-macros
BuildRequires: python3-PyMySQL
BuildRequires: python3-confluent-kafka
BuildRequires: python3-kazoo
BuildRequires: python3-mock
BuildRequires: python3-oslo.config
BuildRequires: python3-oslo.context
BuildRequires: python3-oslo.policy
BuildRequires: python3-oslotest
BuildRequires: python3-pbr
BuildRequires: python3-pyparsing
BuildRequires: python3-requests-mock
BuildRequires: python3-simplejson
BuildRequires: python3-six
BuildRequires: python3-stestr
BuildArch: noarch
%description
Collection of sub-projects containing reusable application and
platform code for building monitoring related services.
%package -n python3-monasca-common
Summary: Reusable code for building monitoring related services.
Requires: python3-PyMySQL
Requires: python3-confluent-kafka
Requires: python3-kazoo
Requires: python3-oslo.config
Requires: python3-oslo.policy
Requires: python3-pyparsing
Requires: python3-simplejson
Requires: python3-six
%description -n python3-monasca-common
Collection of sub-projects containing reusable application and
platform code for building monitoring related services.
This package contains the Python 3.x module.
%prep
%autosetup -n %{sname}-3.3.1.dev5
%py_req_cleanup
%build
export LC_ALL=en_US.utf-8
%{py3_build}
%install
export LC_ALL=en_US.utf-8
%{py3_install}
#%if 0%{?suse_version}
%check
export LC_ALL=en_US.utf-8
python3 -m stestr.cli run
#%endif
%files -n python3-monasca-common
%license LICENSE
%doc README.rst ChangeLog
%{python3_sitelib}/monasca_common
%{python3_sitelib}/*.egg-info
%changelog