File python-openstacksdk.spec of Package python-openstacksdk

#
# spec file for package python-openstacksdk
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define with_tests 0
Name:           python-openstacksdk
Version:        0.61.0
Release:        0
Summary:        An SDK for building applications to work with OpenStack
License:        Apache-2.0
Group:          Development/Languages/Python
URL:            https://docs.openstack.org/openstacksdk
Source0:        https://files.pythonhosted.org/packages/source/o/openstacksdk/openstacksdk-0.61.0.tar.gz
BuildRequires:  openstack-macros
BuildRequires:  python39-PyYAML
BuildRequires:  python39-appdirs
BuildRequires:  python39-beautifulsoup4
BuildRequires:  python39-ddt
BuildRequires:  python39-decorator
BuildRequires:  python39-deprecation
BuildRequires:  python39-dogpile.cache
BuildRequires:  python39-extras
BuildRequires:  python39-fixtures
BuildRequires:  python39-jmespath
BuildRequires:  python39-jsonpatch
BuildRequires:  python39-jsonschema
BuildRequires:  python39-keystoneauth1
BuildRequires:  python39-mock
BuildRequires:  python39-munch
BuildRequires:  python39-netifaces
BuildRequires:  python39-os-service-types
BuildRequires:  python39-oslo.config
BuildRequires:  python39-oslotest
BuildRequires:  python39-pbr
BuildRequires:  python39-python-subunit
BuildRequires:  python39-requests-mock
BuildRequires:  python39-requestsexceptions
BuildRequires:  python39-statsd
BuildRequires:  python39-stestr
BuildRequires:  python39-stevedore
BuildRequires:  python39-testscenarios
BuildRequires:  python39-testtools
BuildArch:      noarch
%if 0%{?suse_version}
# RDO does not package prometheus_client
BuildRequires:  python39-prometheus_client
%endif

%description
The openstacksdk is a library for building applications to work
with OpenStack clouds.
The project aims to provide a consistent and complete set of
interactions with OpenStack's many services, along with complete
documentation, examples, and tools.

%package -n python39-openstacksdk
Summary:        An SDK for building applications to work with OpenStack
Requires:       python39-PyYAML
Requires:       python39-appdirs
Requires:       python39-cryptography
Requires:       python39-decorator
Requires:       python39-dogpile.cache
Requires:       python39-iso8601
Requires:       python39-jmespath
Requires:       python39-jsonpatch
Requires:       python39-keystoneauth1
Requires:       python39-munch
Requires:       python39-netifaces
Requires:       python39-os-service-types
Requires:       python39-requestsexceptions
%if 0%{?suse_version}
Obsoletes:      python2-openstacksdk < 1.0.0
%endif
%if 0%{?suse_version}
%if 0%{?sle_version} >= 150000 || 0%{?suse_version} > 1500
Requires:       mkisofs
%else
Requires:       genisoimage
%endif
%else
Requires:       genisoimage
%endif

%description -n python39-openstacksdk
The openstacksdk is a library for building applications to work
with OpenStack clouds.
The project aims to provide a consistent and complete set of
interactions with OpenStack's many services, along with complete
documentation, examples, and tools.

This package contains the Python 3.x module

%package -n python-openstacksdk-doc
Summary:        %{summary} - Documentation
Group:          Documentation/HTML
BuildRequires:  python39-Sphinx
BuildRequires:  python39-openstackdocstheme
BuildRequires:  python39-sphinxcontrib-svg2pdfconverter

%description -n python-openstacksdk-doc
The openstacksdk is a library for building applications to work
with OpenStack clouds.
The project aims to provide a consistent and complete set of
interactions with OpenStack's many services, along with complete
documentation, examples, and tools.

The openstacksdk is a collection of libraries for building
applications to work with OpenStack clouds.

%prep
%autosetup -p1 -n openstacksdk-0.61.0
%py_req_cleanup
sed -i -e 's,coverage.*,,' test-requirements.txt || true
sed -i -e "s,'sphinx.ext.intersphinx'\,,," doc/source/conf.py
%if !0%{?suse_version}
# RDO does not package prometheus_client
rm openstack/tests/unit/test_stats.py
%endif

%build
%py3_build
PBR_VERSION=0.61.0 %sphinx_build -b html doc/source doc/build/html
rm -rf doc/build/html/.{doctrees,buildinfo}

%install
%py3_install

%if 0%{?with_tests}
%check
export OS_LOG_CAPTURE=true
export OS_TEST_TIMEOUT=30
python3 -m stestr.cli run
%endif

%files -n python39-openstacksdk
%license LICENSE
%doc ChangeLog README.rst
%{_bindir}/openstack-inventory
%{python3_sitelib}/openstack
%{python3_sitelib}/*.egg-info

%files -n python-openstacksdk-doc
%license LICENSE
%doc doc/build/html

%changelog
openSUSE Build Service is sponsored by