File python-oslo.db.spec of Package python-oslo.db

#
# spec file for package python-oslo.db
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


Name:           python-oslo.db
Version:        11.3.0
Release:        0
Summary:        OpenStack oslo.db library
License:        Apache-2.0
Group:          Development/Languages/Python
URL:            https://docs.openstack.org/oslo.db
Source0:        https://files.pythonhosted.org/packages/source/o/oslo.db/oslo.db-11.3.0.tar.gz
BuildRequires:  openstack-macros
BuildRequires:  python39-PyMySQL
BuildRequires:  python39-alembic
BuildRequires:  python39-debtcollector
BuildRequires:  python39-eventlet
BuildRequires:  python39-fixtures
BuildRequires:  python39-mock
BuildRequires:  python39-oslo.config
BuildRequires:  python39-oslo.context
BuildRequires:  python39-oslo.i18n
BuildRequires:  python39-oslo.utils
BuildRequires:  python39-oslotest
BuildRequires:  python39-pbr
BuildRequires:  python39-psycopg2
BuildRequires:  python39-python-subunit
BuildRequires:  python39-reno
BuildRequires:  python39-six
BuildRequires:  python39-sqlalchemy-migrate
BuildRequires:  python39-stestr
BuildRequires:  python39-testresources
BuildRequires:  python39-testscenarios
BuildRequires:  python39-testtools
BuildArch:      noarch

%description
The OpenStack Oslo database handling library. Provides database connectivity
to the different backends and helper utils.
* Documentation: https://docs.openstack.org/oslo.db/latest/
* Source: https://opendev.org/openstack/oslo.db/
* Bugs: https://bugs.launchpad.net/oslo.db

%package -n python39-oslo.db
Summary:        OpenStack oslo.db library
Requires:       python39-PyMySQL
Requires:       python39-SQLAlchemy
Requires:       python39-alembic
Requires:       python39-debtcollector
Requires:       python39-oslo.config
Requires:       python39-oslo.context
Requires:       python39-oslo.i18n
Requires:       python39-oslo.utils
Requires:       python39-psycopg2
Requires:       python39-six
Requires:       python39-sqlalchemy-migrate
Requires:       python39-stevedore
Requires:       python39-testresources
Requires:       python39-testscenarios

%description -n python39-oslo.db
The OpenStack Oslo database handling library. Provides database connectivity
to the different backends and helper utils.
* Documentation: https://docs.openstack.org/oslo.db/latest/
* Source: https://opendev.org/openstack/oslo.db/
* Bugs: https://bugs.launchpad.net/oslo.db

This package contains the Python 3.x module.

%package -n python-oslo.db-doc
Summary:        Documentation for the Oslo database handling library
Group:          Documentation/HTML
BuildRequires:  python39-Sphinx
BuildRequires:  python39-openstackdocstheme
BuildRequires:  python39-sphinxcontrib-apidoc

%description -n python-oslo.db-doc
Documentation for the Oslo database handling library.

%prep
%autosetup -p1 -n oslo.db-11.3.0
%py_req_cleanup

%build
%{py3_build}

# generate html docs
PBR_VERSION=%{version} %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}

%install
%{py3_install}

%check
python3 -m stestr.cli run

%files -n python39-oslo.db
%license LICENSE
%doc README.rst ChangeLog
%{python3_sitelib}/oslo_db
%{python3_sitelib}/*.egg-info

%files -n python-oslo.db-doc
%license LICENSE
%doc doc/build/html

%changelog
openSUSE Build Service is sponsored by