File python-oslo.policy.spec of Package python-oslo.policy
#
# spec file for package python-oslo.policy
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-oslo.policy
Version: 3.12.1
Release: 0
Summary: OpenStack Oslo Policy library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/oslo.policy
Source0: https://files.pythonhosted.org/packages/source/o/oslo.policy/oslo.policy-3.12.1.tar.gz
BuildRequires: openstack-macros
BuildRequires: python39-PyYAML
BuildRequires: python39-oslo.config
BuildRequires: python39-oslo.context
BuildRequires: python39-oslo.i18n
BuildRequires: python39-oslo.serialization
BuildRequires: python39-oslo.utils
BuildRequires: python39-oslotest
BuildRequires: python39-pbr
BuildRequires: python39-requests
BuildRequires: python39-requests-mock
BuildRequires: python39-stestr
BuildArch: noarch
%description
The OpenStack Oslo Policy library.
RBAC policy enforcement library for OpenStack.
%package -n python39-oslo.policy
Summary: OpenStack Oslo Policy library
Requires: python39-PyYAML
Requires: python39-oslo.config
Requires: python39-oslo.context
Requires: python39-oslo.i18n
Requires: python39-oslo.serialization
Requires: python39-oslo.utils
Requires: python39-requests
Requires: python39-stevedore
%if 0%{?suse_version}
Obsoletes: python2-oslo.policy < 2.4.1
%endif
%description -n python39-oslo.policy
The OpenStack Oslo Policy library.
RBAC policy enforcement library for OpenStack.
This package contains the Python 3.x module.
%package -n python-oslo.policy-doc
Summary: Documentation for the Oslo Policy library
Group: Documentation/HTML
BuildRequires: python39-Sphinx
BuildRequires: python39-openstackdocstheme
BuildRequires: python39-sphinxcontrib-apidoc
%description -n python-oslo.policy-doc
Documentation for the Oslo Policy library.
%prep
%autosetup -p1 -n oslo.policy-3.12.1
%py_req_cleanup
%build
%{py3_build}
# generate html docs
PBR_VERSION=%{version} %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{py3_install}
%check
python3 -m stestr.cli run
%files -n python39-oslo.policy
%license LICENSE
%doc README.rst
%{_bindir}/oslopolicy-checker
%{_bindir}/oslopolicy-convert-json-to-yaml
%{_bindir}/oslopolicy-list-redundant
%{_bindir}/oslopolicy-policy-generator
%{_bindir}/oslopolicy-sample-generator
%{_bindir}/oslopolicy-policy-upgrade
%{_bindir}/oslopolicy-validator
%{python3_sitelib}/oslo_policy
%{python3_sitelib}/*.egg-info
%files -n python-oslo.policy-doc
%license LICENSE
%doc doc/build/html
%changelog