File python-oslo.service.spec of Package python-oslo.service
#
# spec file for package python-oslo.service
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%if 0%{?rhel} || 0%{?fedora}
%global rdo 1
%endif
Name: python-oslo.service
Version: 2.8.0
Release: 0
Summary: OpenStack oslo.service library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/oslo.service
Source0: https://files.pythonhosted.org/packages/source/o/oslo.service/oslo.service-2.8.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: procps
BuildRequires: python39-Paste
BuildRequires: python39-PasteDeploy
BuildRequires: python39-Routes
BuildRequires: python39-WebOb
BuildRequires: python39-eventlet
BuildRequires: python39-fixtures
BuildRequires: python39-greenlet
BuildRequires: python39-mock
BuildRequires: python39-oslo.concurrency
BuildRequires: python39-oslo.config
BuildRequires: python39-oslo.i18n
BuildRequires: python39-oslo.log
BuildRequires: python39-oslo.utils
BuildRequires: python39-oslotest
BuildRequires: python39-pbr
BuildRequires: python39-requests
BuildRequires: python39-six
BuildRequires: python39-stestr
BuildRequires: python39-yappi
BuildArch: noarch
%description
oslo.service provides a framework for defining new long-running services using
the patterns established by other OpenStack applications. It also includes
utilities long-running applications might need for working with SSL or WSGI,
performing periodic operations, interacting with systemd, etc.
%package -n python39-oslo.service
Summary: OpenStack oslo.service library
Requires: python39-Paste
Requires: python39-PasteDeploy
Requires: python39-Routes
Requires: python39-WebOb
Requires: python39-debtcollector
Requires: python39-eventlet
Requires: python39-fixtures
Requires: python39-greenlet
Requires: python39-oslo.concurrency
Requires: python39-oslo.config
Requires: python39-oslo.i18n
Requires: python39-oslo.log
Requires: python39-oslo.utils
Requires: python39-six
Requires: python39-yappi
%description -n python39-oslo.service
oslo.service provides a framework for defining new long-running services using
the patterns established by other OpenStack applications. It also includes
utilities long-running applications might need for working with SSL or WSGI,
performing periodic operations, interacting with systemd, etc.
%package -n python-oslo.service-doc
Summary: Documentation for OpenStack service library
BuildRequires: python39-Sphinx
BuildRequires: python39-openstackdocstheme
%description -n python-oslo.service-doc
oslo.service provides a framework for defining new long-running services using
the patterns established by other OpenStack applications. It also includes
utilities long-running applications might need for working with SSL or WSGI,
performing periodic operations, interacting with systemd, etc.
This package contains the documentation.
%prep
%autosetup -p1 -n oslo.service-2.8.0
%py_req_cleanup
%build
%{py3_build}
# generate html docs
PYTHONPATH=. PBR_VERSION=%{version} %sphinx_build -b html doc/source doc/build/html
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{py3_install}
%check
python3 -m stestr.cli run
%files -n python39-oslo.service
%license LICENSE
%doc README.rst ChangeLog
%{python3_sitelib}/oslo_service
%{python3_sitelib}/*.egg-info
%files -n python-oslo.service-doc
%license LICENSE
%doc doc/build/html
%changelog