File python-solumclient.spec of Package python-solumclient

#
# spec file for package python-solumclient
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


Name:           python-solumclient
Version:        3.4.0
Release:        0
Summary:        Python API and CLI for OpenStack Solum
License:        Apache-2.0
Group:          Development/Languages/Python
URL:            https://docs.openstack.org/python-solumclient
Source0:        https://files.pythonhosted.org/packages/source/p/python-solumclient/python-solumclient-3.4.0.tar.gz
BuildRequires:  openstack-macros
BuildRequires:  python3-keystoneclient
BuildRequires:  python39-PrettyTable
BuildRequires:  python39-PyYAML
BuildRequires:  python39-fixtures
BuildRequires:  python39-httplib2
BuildRequires:  python39-jsonschema
BuildRequires:  python39-mock
BuildRequires:  python39-oslo.config
BuildRequires:  python39-oslo.i18n
BuildRequires:  python39-oslo.log
BuildRequires:  python39-oslo.utils
BuildRequires:  python39-oslotest
BuildRequires:  python39-pbr
BuildRequires:  python39-python-subunit
BuildRequires:  python39-stestr
BuildRequires:  python39-testscenarios
BuildRequires:  python39-testtools
BuildArch:      noarch

%description
Client library for Solum built on the Solum API. It provides a Python API
(the solumclient module) and a command-line tool (solum).

%package -n python3-solumclient
Summary:        Python API and CLI for OpenStack Solum
Requires:       python3-keystoneclient
Requires:       python39-Babel
Requires:       python39-PrettyTable
Requires:       python39-PyYAML
Requires:       python39-httplib2
Requires:       python39-iso8601
Requires:       python39-jsonschema
Requires:       python39-oslo.config
Requires:       python39-oslo.i18n
Requires:       python39-oslo.log
Requires:       python39-oslo.utils
Requires:       python39-pbr
Requires:       python39-requests
Requires:       python39-six
Requires:       python39-stevedore

%description -n python3-solumclient
Client library for Solum built on the Solum API. It provides a Python API
(the solumclient module) and a command-line tool (solum).

This package contains the Python 3.x module.

%package doc
Summary:        Documentation for OpenStack Solum API client libary
Group:          Documentation/HTML
BuildRequires:  python39-Sphinx
BuildRequires:  python39-openstackdocstheme
BuildRequires:  python39-sphinxcontrib-apidoc

%description doc
Client library for Solum built on the Solum API. It provides a Python API
(the solumclient module) and a command-line tool (solum).
This package contains the documentation.

%prep
%autosetup -n %{name}-%{version}
%py_req_cleanup

%build
%py3_build

# Build HTML docs and man page
PBR_VERSION=%{version} %sphinx_build -b html doc/source doc/build/html
PBR_VERSION=%{version} %sphinx_build -b man doc/source doc/build/man
rm -r doc/build/html/.{doctrees,buildinfo}

%install
%py3_install

%check
%{__python3} -m stestr.cli run

%files -n python3-solumclient
%doc README.rst
%license LICENSE
%{python3_sitelib}/solumclient
%{python3_sitelib}/*.egg-info
%{_bindir}/solum
%{_bindir}/solum-app-setup.py

%files doc
%doc doc/build/html
%license LICENSE

%changelog
openSUSE Build Service is sponsored by