File python-neutronclient.spec of Package python-neutronclient
#
# spec file for package python-neutronclient
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-neutronclient
Version: 7.8.0
Release: 0
Summary: Python API and CLI for OpenStack Neutron
License: Apache-2.0
Group: Development/Languages/Python
URL: https://docs.openstack.org/python-neutronclient
Source0: https://files.pythonhosted.org/packages/source/p/python-neutronclient/python-neutronclient-7.8.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: python3-keystoneclient
BuildRequires: python39-cliff
BuildRequires: python39-fixtures
BuildRequires: python39-keystoneauth1
BuildRequires: python39-netaddr
BuildRequires: python39-os-client-config
BuildRequires: python39-osc-lib
BuildRequires: python39-oslo.i18n
BuildRequires: python39-oslo.log
BuildRequires: python39-oslo.serialization
BuildRequires: python39-oslo.utils
BuildRequires: python39-oslotest
BuildRequires: python39-osprofiler
BuildRequires: python39-pbr
BuildRequires: python39-requests-mock
BuildRequires: python39-stestr
BuildRequires: python39-testscenarios
BuildRequires: python39-testtools
BuildArch: noarch
%description
Client library and command line utility for interacting with OpenStack
Neutron's API.
%package -n python3-neutronclient
Summary: Python API and CLI for OpenStack Neutron
Requires: python3-keystoneclient
Requires: python39-Babel
Requires: python39-cliff
Requires: python39-debtcollector
Requires: python39-iso8601
Requires: python39-keystoneauth1
Requires: python39-netaddr
Requires: python39-os-client-config
Requires: python39-osc-lib
Requires: python39-oslo.i18n
Requires: python39-oslo.serialization
Requires: python39-oslo.utils
Requires: python39-pbr
Requires: python39-requests
Requires: python39-simplejson
Requires: python39-six
%if 0%{?suse_version}
Obsoletes: python2-neutronclient < 7.1.0
%endif
%description -n python3-neutronclient
Client library and command line utility for interacting with OpenStack
Neutron's API.
This package contains the Python 3.x module.
%package -n python-neutronclient-doc
Summary: Documentation for OpenStack Neutron API Client
Group: Documentation/HTML
BuildRequires: python39-Sphinx
BuildRequires: python39-openstackdocstheme
BuildRequires: python39-reno
%description -n python-neutronclient-doc
Client library and command line utility for interacting with OpenStack
Neutron's API.
%prep
%autosetup -p1 -n %{name}-%{version}
%py_req_cleanup
%build
%{py3_build}
# Build HTML docs and man page
PBR_VERSION=7.8.0 %sphinx_build -b html doc/source doc/build/html
PBR_VERSION=7.8.0 %sphinx_build -b man doc/source doc/build/man
rm -r doc/build/html/.{doctrees,buildinfo}
%install
%{py3_install}
%check
%{openstack_stestr_run}
%files -n python3-neutronclient
%license LICENSE
%{python3_sitelib}/neutronclient
%{python3_sitelib}/*.egg-info
%{_bindir}/neutron
%files -n python-neutronclient-doc
%doc doc/build/html README.rst
%license LICENSE
%changelog