File cheese.spec of Package cheese
#
# spec file for package cheese (Version 2.24.1)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
Name: cheese
BuildRequires: cairo-devel
BuildRequires: dbus-1-devel
BuildRequires: evolution-data-server-devel
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: glib2-devel
BuildRequires: gnome-doc-utils-devel
BuildRequires: gnome-vfs2-devel
BuildRequires: gstreamer-0_10-devel
BuildRequires: gstreamer-0_10-plugins-base-devel
BuildRequires: gtk2-devel
BuildRequires: intltool
BuildRequires: libglade2-devel
BuildRequires: libgnomeui-devel
BuildRequires: librsvg-devel
BuildRequires: perl-XML-Parser
BuildRequires: pkg-config
BuildRequires: python-gobject2
BuildRequires: update-desktop-files
%if %suse_version <= 1020
%define _prefix /opt/gnome
%define _sysconfdir /etc/%_prefix
BuildRequires: extra-rpm-macros gconf2-rpm-macros
%endif
Summary: Cheese is a Photobooth-inspired application for taking pictures and videos
Version: 2.24.1
Release: 1
License: GPL v2 or later
Group: Productivity/Graphics/Other
Source0: %{name}-%{version}.tar.bz2
# Patch0: cheese-declaration.patch
Url: http://www.gnome.org/projects/cheese
BuildRoot: %{_tmppath}/%{name}-%{version}-build
AutoReqProv: on
Requires: %{name}-lang = %{version}
# won't start without that one:
Requires: gstreamer-0_10-plugins-good
Requires: yelp
%gconf_schemas_prereq
%description
Cheese is a Photobooth-inspired GNOME application for taking pictures
and videos from a webcam. It also includes fancy graphical effects
based on the gstreamer-backend.
Authors:
--------
daniel g. siegel <dgsiegel@gmail.com>
Jaap Haitsma <jaap@haitsma.org>
%lang_package
%prep
%setup -n %{name}-%{version}
#%patch0 -p0
%build
%configure \
--disable-scrollkeeper
make
%install
%makeinstall
%find_gconf_schemas
%find_lang %{name}
%suse_update_desktop_file -r -C "Webcam application" -G "Webcam application" -N "Cheese" cheese Graphics Photography GNOME GTK
%fdupes -s $RPM_BUILD_ROOT
%pre -f %{name}.schemas_pre
%preun -f %{name}.schemas_preun
%posttrans -f %{name}.schemas_posttrans
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%clean
rm -rf $RPM_BUILD_ROOT
%files -f %{name}.schemas_list
%defattr(-, root, root)
%doc AUTHORS README COPYING ChangeLog
%{_bindir}/cheese
%{_libdir}/cheese
%{_datadir}/applications/cheese.desktop
%{_datadir}/cheese
%{_datadir}/icons/hicolor/16x16/apps/cheese.png
%{_datadir}/icons/hicolor/22x22/apps/cheese.png
%{_datadir}/icons/hicolor/24x24/apps/cheese.png
%{_datadir}/icons/hicolor/32x32/apps/cheese.png
%{_datadir}/icons/hicolor/48x48/apps/cheese.png
%{_datadir}/icons/hicolor/scalable/apps/cheese.svg
%{_datadir}/omf/cheese
%{_datadir}/dbus-1/services/org.gnome.Cheese.service
%files lang -f %{name}.lang
%changelog
* Tue Oct 21 2008 mboman@suse.de
- Update to version 2.24.1:
+ Exit correctly with unknown command line arguments, fixes bgo#556084
+ Translation updates
* Mon Oct 20 2008 maw@suse.de
- Require yelp (bnc#436942).
* Mon Oct 20 2008 meissner@suse.de
- require gstreamer-plugins-good for basic video sources
* Tue Sep 30 2008 mboman@suse.de
- Update to version 2.24.0:
+ correct an error in the help file, which prevented the document to be
valid
+ update the cheese dependencies, fixes bgo#547203
+ use the correct translated plural form when deleting more than one item
from the thumbnail bar, fixes bgo#552290, courtesy of Yuriy Penkin
+ do not add a new item to the thumbnail bar, if its already there,
fixes bgo#549804
+ update documentation, courtesy of Joshua Henderson
+ include gio header in cheese.c
+ Translation updates
* Wed Sep 10 2008 maw@suse.de
- Update to version 2.23.92:
+ Documentation update (not yet finished)
+ Old photos and videos (created before 2.24) are now available
bgo#547290
+ Don't save duplicated videoformats; rather only keep the one
with the maximum framerate if it provides the same resolution
(bgo#547144 and bgo#547140)
+ Send eos event only if the pipeline was playing; otherwise
force shutdown; start a timeout to force unclean shutdown if
eos takes too long to propagate or doesnt propagate at all
(work on bgo#547422)
+ Set take_picture sensitiveness before
webcam_stop_video_recording since this emits a signal that
would lead to another sensitiveness change (bgo#547422)
+ Set the utility hint for the fullscreen toolbar (bgo#548546,
partial)
+ Fix crash when no device is set in gconf (bgo#546868, partial)
+ Display toolbar when entering into fullscreen mode
(bgo#548546)
+ Updated translations.
* Tue Sep 02 2008 mboman@novell.com
- Update to version 2.23.91:
+ Bugs fixed: bgo#527736, bgo#547405, bgo#547403, bgo#511916,
bgo#547313, bgo#522009, bgo#547168, bgo#513776, bgo#522009,
bgo#543976, bgo#481405, bgo#522009, bgo#546390, bgo#546918
- call gdk_x11_window_set_user_time to raise the cheese window if its
called twice
- remove gtk_init and gst_init, according to the docs these are not
needed if we use gtk_get_option_group and gst_init_get_option_group
- align the buttons with the thumbnail bar
- select the last thumbnail item, if the last one was deleted
- remove a thumbnail item immidiately from the thumbnail row if it was
deleted
- add people who contributed to cheese to the cheese about window
- connect button_photo and button_video as proxy widgets for relative
RadioActions
- don't try to find highest framerate if format is NULL
- added a delete action to immediately delete files and a gconf key to
show/hide it
- add several g_free functions to prevent memory leaks
- use g_random_int instead of g_rand_int
- add the multiplex thumbnail generator algorithm
- disable "Start recording" button until the recording pipeline properly
shuts down
- save generated thumbnails, it seems to have vanished some time ago
- added/updated translations
* Tue Aug 05 2008 captain.magnus@opensuse.org
- Update to version 2.23.6:
+ add a fullscreen mode for kiosks, fixes bgo#478852, courtesy of Felix Kaser
+ wait until the video has been recorded, to add it to the thumbnail bar, partially fixes bgo#545212
+ move thumbnail generation to its own thread, displaying a loading icon while
generating thumbnail and a fallback icon if thumbnail fails, fixes bug bgo#545151, courtesy of Filippo Argiolas
+ toggle effects button if effects is enabled using menu, fixes bug bgo#539195, courtesy of Filippo Argiolas
+ make cheese have a fullscreen mode for kiosks, fixes bug bgo#478852
+ resolve sluggish video and out-of-sync audio, fixes bug bgo#542014, courtesy of Filippo Argiolas
+ do not crash on preferences with no camera attached, fixes bug bgo#544062, courtesy of Filippo Argiolas
+ cheese should ask to delete files if moving to trash fails, fixes bug bgo#545950, courtesy of Filippo Argiolas
+ cheese crashed with move all to trash if no trash can be accessed, fixes bug bgo#545997, courtesy of Filippo Argiolas
+ make recording of videos work again, fixes bug bgo#523475, courtesy of Filippo Argiolas
+ bump gstreamer requirements to 0.10.16
+ fixes cheese_print_handler, which resulted in empty cheese logs, courtesy of Filippo Argiolas
+ allow to choose the webcam using the preference dialog, fixes bug bgo#522200, courtesy of Ryan Zeigler
+ remove some gcc warnings, fixes bug bgo#537490, courtesy of Cosimo Cecchi
+ fixed typo, which prevented hildon mode to compile cleanly
+ removed included <X11/extensions/xf86vmode.h>, fixes bug bgo#539631, courtesy of Marc-Andre Lureau
+ make hal-device-id command line option work, fixes bug bgo#498023, courtesy of Ryan Zeigler
+ use ogv as default video extension, fixes bug bgo#524021
+ added/updated translations
* Fri Jun 20 2008 maw@suse.de
- Update to version 2.23.4:
+ Bugs fixed: bgo#535582 and bgo#522009
+ Updated translations.
* Wed Jun 18 2008 maw@suse.de
- Update to version 2.23.3:
+ Add support to set the video and photo path in gconf
+ Bugs fixed: bgo#526214, bgo#534480, bgo#511369, bgo#509475,
bgo#527870, bgo#528249, bgo#525739, bgo#522200 (partially),
bgo#529467, bgo#529789, bgo#529276, bgo#519846, bgo#519548,
bgo#511160, bgo#511945, bgo#524021, bgo#522197, bgo#524814,
bgo#522152, bgo#522198, bgo#523121, bgo#522143, bgo#526398,
bgo#520394, bgo#511369, and bgo#512091
+ Updated translations.
* Thu Apr 10 2008 maw@suse.de
- Update to version 2.22.1:
+ Cheese crashed while initializing webcam on some devices,
fixes bug bgo#522143
+ Cheese did not list its gnome-vfs dependency, fixes bgo#522152
+ Cheese did not open the webcam device set in gconf, fixes
bgo#522198
+ Cheese crashed if getting information from a webcam fails,
fixes bgo#522197
+ Set the max waiting time for detecting a camera to 10 seconds,
fixes bgo#520394
+ Do not allow to take pictures, while the webcam is initialising,
fixes bgo#523121
+ Show our fancy countdown widget by default
+ Updated translations.
* Thu Mar 13 2008 maw@suse.de
- Update to version to 2.22.0:
+ typo in the documentaton: ximageskink instead of ximagesink
+ menu entries for take a photo and recording never switched,
(bgo#516745)
+ select a thumb near the deleted item (bgo#505442)
+ make sure we have the right prototype definition (bgo#519030)
+ Rephrased hard-to-understand sentence in docs (bgo#518838)
+ Updated translations
- Drop cheese-declaration.patch.
* Tue Mar 04 2008 maw@suse.de
- Update to version 2.21.92:
+ Use GtkBuilder instead of libglade
+ Put gtk calls in critical section of threads (bgo#516697)
+ Make use of the gconf countdown setting
+ Updated translations.
* Tue Feb 19 2008 maw@suse.de
- Update to version 2.21.91:
+ Replace gnome-vfs with gio
+ Pressing esc cancels countdown/stop video recording
+ Updated translations, including effect names.
* Fri Feb 01 2008 maw@suse.de
- Import into autobuild (thanks, Andrew!)
- Update to version 2.21.90.1:
+ Many bug fixes
+ New effects
+ Updated translations.
* Fri Nov 30 2007 andrew@forcev.net
- Cleanup of spec file to comply with openSUSE GNOME packaging guidelines
* Wed Sep 26 2007 andrew@forcev.net
- Initial build for openSUSE 10.3