File gtk-vnc.spec of Package gtk-vnc

#
# spec file for package gtk-vnc (Version 0.3.7)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           gtk-vnc
BuildRequires:  gnome-common
BuildRequires:  gnutls-devel
BuildRequires:  gtk2-devel
BuildRequires:  gtkglext-devel
BuildRequires:  perl-XML-Parser
BuildRequires:  python-devel
%if %suse_version <= 1010
BuildRequires:  python-gtk
%else
BuildRequires:  python-gtk-devel
%endif
Summary:        A GTK widget for VNC clients
Version:        0.3.7
Release:        5
License:        LGPL v2.1 only; LGPL v2.1 or later
Group:          Development/Libraries/X11
Source:         http://downloads2.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
Patch:          gtk-vnc-0.3.3-pkgconfig.patch
Patch01:        gtk-vnc-0.3.7-ungrab.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Url:            http://gtk-vnc.sf.net/
AutoReqProv:    on
%py_requires

%description
gtk-vnc is a VNC viewer widget for GTK+. It is built using coroutines
allowing it to be completely asynchronous while remaining single
threaded.



%package -n libgtk-vnc-1_0-0
License:        LGPL v2.1 only; LGPL v2.1 or later
Summary:        A GTK widget for VNC clients
Group:          Development/Libraries/X11

%description  -n libgtk-vnc-1_0-0
gtk-vnc is a VNC viewer widget for GTK+. It is built using coroutines
allowing it to be completely asynchronous while remaining single
threaded.



%package devel
License:        LGPL v2.1 or later
Summary:        Libraries, includes, etc. to compile with the gtk-vnc library
Group:          Development/Libraries/X11
Requires:       libgtk-vnc-1_0-0 = %{version} gtk2-devel

%description devel
Development files for using the gtk-vnc library



%package -n python-gtk-vnc
License:        LGPL v2.1 or later
Summary:        Python bindings for the gtk-vnc library
Group:          Development/Libraries/X11
Provides:       gtk-vnc-python = %{version}
Obsoletes:      gtk-vnc-python < %{version}

%description -n python-gtk-vnc
A module allowing use of the GTK-VNC widget from python



%prep
%setup -q
%patch
%patch01 -p1

%build
%configure --disable-static --with-pic
%{__make} %{?jobs:-j%jobs}

%install
%makeinstall
%{__rm} -rf $RPM_BUILD_ROOT/%{py_sitedir}/gtkvnc.*a
%{__rm} -f %{buildroot}%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%postun  -n libgtk-vnc-1_0-0 -p /sbin/ldconfig

%post  -n libgtk-vnc-1_0-0 -p /sbin/ldconfig

%files
%defattr(-, root, root)
%doc AUTHORS COPYING.LIB ChangeLog NEWS README

%files -n libgtk-vnc-1_0-0
%defattr(-, root, root)
%{_libdir}/*.so.0*

%files -n python-gtk-vnc
%defattr(-, root, root)
%{py_sitedir}/gtkvnc*

%files devel
%defattr(-, root, root)
%{_includedir}/gtk-vnc-1.0
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc

%changelog
* Tue Nov 25 2008 anschneider@suse.de
- Fix for inability to ungrab mouse when in absolute pointer mode
* Mon Sep 15 2008 jpr@novell.com
- Enable scaling support
* Fri Sep 12 2008 maw@suse.de
- Update to version 0.3.7:
  + Ungrab pointer if widget loses focus
  + Set a pixmap format if server does not default to true colour
  mode
  + Misc fixes to prevent crash
  + Register internal signal handlers against class instead
  of per object
  + New feature: Add API to allow down-scaling to be enabled.
* Thu Aug 14 2008 crrodriguez@suse.de
- pkgconfig has an odd behaviour with "Requires.private"
* Mon Jun 23 2008 maw@suse.de
- Update to version 0.3.6:
  + Focus widget on mouse click
  + WMVi support
  + OpenGL based scaling
  + VNC scancode extension
  + Use glib for debugging and always enable it
  + GObject properties
  + Accessor to determine if we're in absolute mode
  + Provide interface to control shared flag
  + Support preferred authentication types
  + Many bug fixes; see the package's NEWS file for a fuller
  account.
* Fri Jun 13 2008 crrodriguez@suse.de
- disable unusable static libraries
* Tue Feb 19 2008 maw@suse.de
- Update to version 0.3.3:
  + Bug fixes:
  * Track keystates to reset keyboard state on focus out
  * Fix SEGV in vnc_display_close
  * Compiler fixes for suncc
  * More UltraVNC compatibility
  * Big endian fixes
  * Hide password characters in gvncviewer
  * More debug on protocol error
  * Fix SEGV on coroutine free
  * Fix ZRLE encoding
  + New features:
  * Support got Tight encoding
  * Mozilla browser plugin
  * Output configure summary.
* Thu Jan 17 2008 jpr@suse.de
- Update to 0.3.2
  * fix a bug in the python bindings whereas send_keys() was not
  always returning a value.
  * fix a bug in how mouse events get propagated and ensures that
  the right number of encodings are sent to the server.
  * fix RichCursor encoding when the server is using a depth of
  less than 24.
  * fix solaris build issues
  * fix cursor grabbing
  * fix race during connect()
  * fix SELinux error
  * fix race in coroutine library
  * new interface was added (vnc_display_send_keys_ex) for passing
  key press and key release sequences directly and for sending
  pointer events directly (vnc_display_send_pointer).
  * new interface was added (vnc_display_set_read_only) to prevent
  the user from being able to send any input at all to the server.
  * support for the RRE encoding was added along with a GThread-based
  coroutine implementation to improve portability.
  * ZRLE support added
  * Interfaces for bell messages and the clipboard are now
  supported.
  * RFB 3.4 is now supported for increased compatibility with
  UltraVNC.
- Adhere to shlib policy
- Remove gtk-vnc-0.2.0-coroutine-caller.patch,
  gtk-vnc-0.2.0-execmem.patch and
  gtk-vnc-0.2.0-coroutine-cleanup.patch, they are now included
  upstream
* Tue Oct 23 2007 bk@suse.de
- packaged for virt-manager, based on gtk-vnc-0.2.0-4.fc8.src.rpm
openSUSE Build Service is sponsored by