File limal.spec of Package limal

#
# spec file for package limal (Version 1.5.1)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

Url:            http://forge.novell.com/modules/xfmod/project/?limal

Name:           limal
Version:        1.5.1
Release:        1
License:        GPL v2 or later
Group:          Development/Languages/C and C++
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source0:        limal-1.5.1.tar.bz2
Prefix:         /usr
%define		swiglibdir /usr/share/limal/typemaps 
#!BuildIgnore: limal limal-devel limal-perl
BuildRequires:  curl gcc-c++ libblocxx-devel limal-devtools openssl-devel perl-gettext sgml-skel
Summary:        LiMaL--Core Library
%if 0%{?fedora_version} >= 7
BuildRequires:  perl-ExtUtils-Embed
%endif

%description
LiMaL is an C++ framework enhancement for BloCXX. This package contains
the LiMaL core library which include some basic functionality like
logging and file handling.



%package devel
License:        GPL v2 or later
Requires:       limal = %version
Requires:       limal-devel
Group:          Development/Languages/C and C++
Requires:       libblocxx-devel libstdc++-devel pcre-devel limal-devtools
Summary:        LiMaL - Core Library Development Files

%description devel
LiMaL - Core Library Development Files



%package perl
License:        GPL v2 or later
Requires:       limal-perl
%if 0%{?fedora_version} >= 7
Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%else
Requires:       perl = %{perl_version}
%endif
Group:          Development/Languages/Perl
Summary:        LiMaL - Core Library Perl Bindings

%description perl
LiMaL - Core Library Perl Bindings



%prep
%setup -n limal-1.5.1

%build
%{prefix}/bin/limaltool limalautoconf
%{prefix}/bin/limaltool limalautomake
autoreconf --force --install --verbose
export CFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
export CXXFLAGS="$RPM_OPT_FLAGS -DNDEBUG"
%{?suse_update_config:%{suse_update_config -f}}
# workaround for fedora gettext check on x86_64
sed -i -e 's/return (int) gettext/return (long) gettext/g' ./configure
./configure --libdir=%{_libdir} --prefix=%{prefix} --mandir=%{_mandir} \
            --sysconfdir=/etc --localstatedir=/var
make %{?jobs:-j%jobs}

%install
make install DESTDIR="$RPM_BUILD_ROOT"
[ -e "%{prefix}/share/limal/devtools/NO_MAKE_CHECK" ] || \
           LIMALDATADIR="$RPM_BUILD_ROOT/usr/share/limal"  \
# required for perl test cases
export LD_LIBRARY_PATH="$RPM_BUILD_ROOT/usr/lib/limal"
make check DESTDIR="$RPM_BUILD_ROOT"
%find_lang %name 

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%clean
rm -rf "$RPM_BUILD_ROOT"

%files -f %name.lang
%defattr(-,root,root)
%dir %{_libdir}/limal
%{_libdir}/limal/lib*.so.*

%files devel
%defattr(-,root,root)
%dir %{_libdir}/limal
%{_libdir}/limal/lib*.so
%{_libdir}/limal/lib*.la
%dir %{_includedir}/limal
%{_includedir}/limal/*.h
%{_includedir}/limal/*.hpp
%{_libdir}/pkgconfig/limal.pc
%dir %{swiglibdir}
%{swiglibdir}/limal*.i
%{swiglibdir}/_blocxx_*.i
%{swiglibdir}/blocxx_*.i
%dir %{swiglibdir}/perl5
%{swiglibdir}/perl5/blocxx_*.i
%{swiglibdir}/perl5/_limal*.i
%doc %{_prefix}/share/doc/packages/limal

%files perl
%defattr(-,root,root)
%dir %{perl_vendorarch}/auto/LIMAL
%{perl_vendorarch}/auto/LIMAL/*
%dir %{perl_vendorarch}/LIMAL
%{perl_vendorarch}/LIMAL/*
%{perl_vendorarch}/*.pm
%changelog
* Wed Nov 05 2008 mc@suse.de
- version 1.5.1
- update translations
* Wed Sep 03 2008 mc@suse.de
- version 1.5.0
- update i18n files
* Fri Jun 06 2008 mc@suse.de
- version 1.4.7
- update i18n files
* Thu May 15 2008 mc@suse.de
- version 1.4.6
- fix prototype of limal_lib_version
* Fri May 09 2008 mc@suse.de
- version 1.4.5
- update i18n files
* Mon Apr 14 2008 mc@suse.de
- version 1.4.4
- update i18n files
* Thu Apr 03 2008 mc@suse.de
- version 1.4.3
- use $limaldatadir/typemaps for own swig typemaps (bnc#373586)
- update translation files
* Wed Feb 13 2008 mc@suse.de
- version 1.4.2
- better fix for the testsuite
- modified blocxx exception typemap
- gcc fixes
- update localization files
* Sun Jan 13 2008 coolo@suse.de
- make the perl fix cross platform
- use %%find_lang
* Sun Jan 13 2008 ro@suse.de
- fix build: add debug output from new perl version
* Fri Nov 09 2007 mc@suse.de
- version 1.4.1
- build with new libblocxx-devel
- change SONAME because of new blocxx6
* Fri Oct 12 2007 mc@suse.de
- PathUtils: remove a non existing file is not an error
* Thu Oct 11 2007 mc@suse.de
- version 1.4.0
- update translation files
* Mon Sep 10 2007 mc@suse.de
- version 1.3.2
- updated translation files
* Mon Aug 20 2007 mc@suse.de
- version 1.3.1
- updated translation files
* Wed Jul 18 2007 mt@suse.de
- version 1.3.0
- updated translation files
* Fri Apr 27 2007 mc@suse.de
- update translation files
* Fri Jan 19 2007 mc@suse.de
- add openssl-devel to BuildRequires
* Tue Jan 16 2007 mt@suse.de
- Updated testcase outputs and regenerated po files
  to match new proofreaded mesage texts in the source
- Fix to use blocxx portable_strerror_r in PathUtils.
* Mon Jan 15 2007 mc@suse.de
- merge proofreaded texts
* Mon Nov 13 2006 mc@suse.de
- version 1.2.9
- update translations
- fix PathInfo userMay methods
* Mon Nov 06 2006 mc@suse.de
- version 1.2.8
- update translations
* Thu Nov 02 2006 mc@suse.de
- version 1.2.7
- update translations (de, fi)
* Mon Oct 23 2006 mc@suse.de
- version 1.2.6
- add translations (pl, fi)
* Mon Oct 16 2006 mc@suse.de
- add first set of translated texts (da cs id hu nb nl)
* Thu Sep 28 2006 mt@suse.de
- version 1.2.5
- Adopted to build with blocxx-1.x as well as upcoming blocxx-2.x
- Docummented missed %%P (PID) Log-Format specifier.
* Tue Aug 08 2006 mc@suse.de
- version 1.2.4
- add --verbose to autoreconf
* Mon Jul 31 2006 mt@suse.de
- Fixed a possibility of uninitialized subroutine value in the
  log message location info in LogHelper.pm when logMessage()
  was called in global scope (outside any subroutine).
- Fixed callback testcase output which contained the unitialized
  string value message caused by LogHelper, to avoid testsuite
  failures because of a different path in the message.
* Tue Jul 25 2006 mc@suse.de
- version 1.2.3
  * fix perl exception handling
  should now build and work with old and new versions of swig
* Mon Jul 24 2006 mc@suse.de
- version 1.2.2
- do not use exception.i in case of perl
  LIMAL has its own exception handling
* Fri Jul 21 2006 mc@suse.de
- version 1.2.1
* Wed Jul 19 2006 sschober@suse.de
- Fixed callback testcase library build dependencies
* Fri Jul 07 2006 mt@suse.de
- Added implementation of Url classes (port from zypp)
- Implemented perl and c++ callback testcases / samples
* Wed Jul 05 2006 mc@suse.de
- version 1.2.0
- using gettext translation mechanism
- removing old mechanism
- removing trans-XXxx template
* Tue Mar 28 2006 mc@suse.de
- version 1.1.6
- Fixed PathName::PathName( const PathName::List &list ); and
  PathName::List toList() const; to implement a consistent behaviour
  concerning a drive prefix.[#161329]
- Documentation added.
- Test case and out file adapted.
* Thu Mar 02 2006 mc@suse.de
- version 1.1.5
- move INIParser to limal-ca-mgm (privat)
- add documentation
* Wed Feb 15 2006 mc@suse.de
- version 1.1.4
- limal-devel requires limal-devtools
  [fix Bug #151145]
* Mon Feb 13 2006 mc@suse.de
- version 1.1.3
- install all *.css and *.gif autodoc files
  fix #150393
* Wed Feb 08 2006 mc@suse.de
- version 1.1.2
- add more common types to swig interface
  (part of a fix for [#149073])
* Fri Jan 27 2006 mc@suse.de
- update documentation
* Fri Jan 27 2006 mc@suse.de
- version 1.1.1
- add limal_ByteBuffer.i for %%import in other modules
  [#145378]
- fix BuildRequires
* Wed Oct 19 2005 mt@suse.de
- merged library version handling fixes from 10.0 branch allowing
  to break the binary compatibily using minor version if required
- merged createLogger functions improvements from 10.0 branch
- merged several documentation improvements from 10.0 branch
- changed swig/perl5/Makefile.am to avoid recursive directory links
- added a first pathutils port from yast2 (needs fixes)
- improved ini parser integration (needs fixes)
- added new ByteBuffer class (may go to blocxx)
- increased version to 1.1.0
* Tue Aug 09 2005 mt@suse.de
- Increased version to 1.0.6
* Thu Jul 28 2005 mt@suse.de
- Temporary spec file fix to get "make check" work for perl
  tests with a liblimal.so in $RPM_BUILD_ROOT/usr/lib/limal
* Mon Jul 25 2005 mt@suse.de
- Removed large file support consistence check
  from limal/config.h, since it breaks builds
- Replaced obsolete AX_CHECK_DOCBOOK and AX_CHECK_SWIG
  macro calls in configure.in.in with current variants
* Thu Jul 21 2005 mt@suse.de
- Added blocxx large file support consistence
  check to the limal/config.h header file
* Tue Jul 12 2005 mt@suse.de
- Changed to use blocxx pkg-config detection
- Added missed requires to limal-devel package
* Wed Jun 29 2005 mt@suse.de
- added CallbackBase template class
* Tue Jun 21 2005 mt@suse.de
- Updated to use new Perl/Posix RegEx classes
  as provided by blocxx snapshot 0.9.20050621
* Thu Jun 09 2005 schubi@suse.de
- added more blocxx features
* Tue Apr 26 2005 mt@suse.de
- initial checkin, version 1.0.0
openSUSE Build Service is sponsored by