File seahorse.spec of Package seahorse
#
# spec file for package seahorse (Version 2.24.1)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
Name: seahorse
BuildRequires: fdupes gnome-doc-utils-devel
BuildRequires: gconf2-devel gnome-keyring-devel gpg2 gpgme-devel
BuildRequires: intltool libavahi-glib-devel libglade2-devel
BuildRequires: libgpg-error-devel libsoup-devel
BuildRequires: libxml2-devel openldap2-devel
BuildRequires: openssh update-desktop-files
BuildRequires: gcc-c++ libnotify-devel
License: GPL v2 or later
Group: Productivity/Security
AutoReqProv: on
PreReq: gconf2
Version: 2.24.1
Release: 2
Requires: %{name}-lang = %{version}
Summary: GNOME2 interface for gnupg
Source: ftp://ftp.gnome.org/pub/gnome/sources/seahorse/%{name}-%{version}.tar.bz2
# PATCH-FIX-OPENSUSE seahorse-xsltproc-nonet.patch
Patch1: seahorse-xsltproc-nonet.patch
Url: http://seahorse.sourceforge.net/
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%gconf_schemas_prereq
%description
Seahorse is a gnome2 interface for gnupg. It uses gpgme as the backend.
Authors:
--------
Jacob Perkins <jap1@users.sourceforge.net>
Jose Carlos Garcia Sogo <jsogo@users.sourceforge.net>
Jean Schurger <jk24@users.sourceforge.net>
Nate Nielsen <nielsen@memberwebs.com>
Adam Schreiber <sadam@clemson.edu>
%package devel
License: GPL v2 or later
Summary: GNOME2 interface for gnupg
Group: System/GUI/GNOME
Requires: %{name} = %{version}-%{release}
Requires: gconf2-devel
%description devel
Seahorse is a gnome2 interface for gnupg. It uses gpgme as the backend.
Authors:
--------
Jacob Perkins <jap1@users.sourceforge.net>
Jose Carlos Garcia Sogo <jsogo@users.sourceforge.net>
Jean Schurger <jk24@users.sourceforge.net>
Nate Nielsen <nielsen@memberwebs.com>
Adam Schreiber <sadam@clemson.edu>
%lang_package
%prep
%setup
%patch1 -p1
%build
%{?suse_update_config:%{suse_update_config -f}}
autoreconf -f -i
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -DLDAP_DEPRECATED -DWITH_SSH"
%configure
make %{?jobs:-j%jobs}
%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
# remove the stuff we don't want...
rm -rf $RPM_BUILD_ROOT/var/%_lib/scrollkeeper
# ...everywhere.
rm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
rm -rf $RPM_BUILD_ROOT/%{_libdir}/lib*.*a
( cd ${RPM_BUILD_ROOT}/%{_datadir}/mime/ && rm -rf XMLnamespaces globs mime application magic )
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
%suse_update_desktop_file %{name} Security -G "Passwords and Encryption Keys" -N "Seahorse"
%find_lang %{name}
## %find_lang %{name}-applet %{name}.lang
%find_gconf_schemas
cat %{name}.schemas_list >%{name}.lst
%fdupes $RPM_BUILD_ROOT
%pre -f %{name}.schemas_pre
%posttrans -f %{name}.schemas_posttrans
%preun -f %{name}.schemas_preun
%post
/sbin/ldconfig
if test -x usr/bin/update-mime-database ; then
usr/bin/update-mime-database %{_prefix}/share/mime > /dev/null
fi
%postun
/sbin/ldconfig
if test -x usr/bin/update-mime-database ; then
usr/bin/update-mime-database %{_prefix}/share/mime > /dev/null
fi
%clean
rm -rf $RPM_BUILD_ROOT
%files -f %{name}.lst
%defattr(-,root,root)
%doc AUTHORS ChangeLog NEWS README
%defattr (-, root, root)
%{_prefix}/bin/*
%{_libdir}/seahorse
%{_libdir}/*.so.*
%{_datadir}/applications/*.desktop
%{_datadir}/dbus-1/services/org.gnome.seahorse.service
%{_datadir}/icons/hicolor/*/*/*.png
%{_datadir}/man/man1/*.1.gz
%dir %{_datadir}/omf/seahorse
%{_datadir}/omf/seahorse/*.omf
%{_datadir}/pixmaps/seahorse
%{_datadir}/seahorse
%files lang -f %{name}.lang
%files devel
%defattr(-,root,root)
%{_libdir}/pkgconfig/*.pc
%dir %{_includedir}/libcryptui
%{_includedir}/libcryptui/*.h
%{_libdir}/*.so
%changelog
* Tue Nov 04 2008 vuntz@novell.com
- Update BuildRequires since upstream split the packages with
seahorse-plugins.
- Move .so to devel package.
* Mon Oct 20 2008 mboman@suse.de
- Update to version 2.24.1:
+ Fix problems with seahorse crashing when searching for
remote keys.
+ Build fixes on Solaris
+ Fix selection of keys in libcryptui.
+ I18n fixes.
* Tue Oct 07 2008 meissner@suse.de
- removed xulrunner requires (since plugin is gone too)
* Wed Sep 24 2008 maw@suse.de
- Update to version 2.24.0:
+ Some tweaks to the password prompt window, including allowing
minimizing to release the keyboard grab
+ Return a 'cancelled' error when from the daemon crypto dbus
methods when a user cancels out of a password prompt
+ Show revoked subkeys properly in details view of PGP keys
+ Fix problem deleting SSH keys
+ Fix dialog prompt column widths, and elipsize long text in
key listing
+ Fix problem with 'no keys available' when trying to sign a
PGP key from within the key manager
+ Add 'exportable' flag to objects/keys and don't enable export
UI if selected objects are not exportable
+ Misc. other fixes.
* Wed Sep 24 2008 wr@opensuse.org
- removed traces of unused subpackages (part of bnc#420641)
- added libnotify support
- removed obsolete configure options
* Tue Sep 09 2008 mboman@novell.com
- Update to version 2.23.92:
+ Fix crash when changing a stored Gnome Keyring password.
+ Fix certain crashes on syncing, searching and other operations.
+ Fix dumb 'Couldn't import keys' error message when success.
* Thu Sep 04 2008 mboman@novell.com
- Updated to 2.23.91:
+ Fix copying keys to the clipboard.
+ Fix double free crash when importing keys.
+ Fix crasher when deleting a key.
+ Don't add extra null bytes to SSH authorized_keys and
similar files.
+ Documentation fixes.
+ Don't repeatedly load gnome-keyring items.
+ Make help button in 'First Time Options' work proprely.
+ Better wording for options in PGP key dialogs.
* Sat Aug 30 2008 mboman@novell.com
- Updated to 2.23.90:
+ Icon makeover
* Tue Aug 05 2008 captain.magnus@opensuse.org
- Updated to 2.23.6
+ Initial PKCS#11 certificate listing implementation.
+ Internal code refactoring.
+ Fix problems with reference counting on operations.
+ Use base64 functions in glib, rather than rolling our own.
+ Don't use deprecated LDAP functions. [Adam Schreiber]
+ String operation fixes. [Adam Schreiber]
+ Build fixes [Jeff Cai]
- Removed seahorse-strncat.patch
* Sat Aug 02 2008 captain.magnus@opensuse.org
- Removed seahorse-configure.patch
- Removed seahorse-ephy-2.22.patch (Plugins are gone)
- Removed seahorse-mozilla-xulrunner19.patch (gecko.m4 is no more)
- Updated to 2.23.5
+ Fix importing keys from key servers [Mackenzie Morgan]
+ Factor out seahorse-plugins to a different module.
+ Add XDS drag and drop support.
+ Remove gnome-vfs dependency and use gio instead.
+ Return key id of signer from DBus service even when key
is not found locally [Adam Schreiber]
+ Refactor UI code internally into modules.
+ Remove hard GPG and GPGME dependency.
+ Replace signer drop down in key chooser with just a check
button when only one secret key exists. [Adam Schreiber]
+ Set sync button insensitive when no server is selected.
[Adam Schreiber]
+ Test for secure memory before using it. [Coleman Kane]
+ Change trust model used to match GPG's. [Adam Schreiber]
+ Remove libgnome and libgnomeui dependencies. [Saleem Abdulrasool]
+ Grab keyboard focus when prompting for password.
[Josselin Mouette]
+ Use the vala programming language for some code.
+ Add initial infrastructure for PKCS#11 key/certificate support.
+ Save and load window sizes from gconf. [Adam Schreiber]
* Build fixes [Brian Cameron, Saleem Abdulrasool, Alexis Ballier,
Christian Persch, Rodrigo Moya]
* Fri Jul 18 2008 rodrigo@suse.de
- Tag and upstream patches
* Mon Jun 30 2008 maw@suse.de
- Remove the .desktop file icon copying hack.
* Mon Jun 23 2008 maw@suse.de
- Update to version 2.22.2:
+ Fix importing keys from hkp keyservers.
* Fri Jun 20 2008 schwab@suse.de
- Fix configure script.
* Tue May 13 2008 maw@suse.de
- Create new subpackages (bnc#387472):
+ -gedit-plugin
+ -epiphany-plugin, which needs seahorse-ephy-2.22.patch.
* Wed May 07 2008 hpj@suse.de
- Require gnome-panel-devel for building, so panel applet gets
installed.
- Add a category to one of the desktop files, so the keyring/encryption
preferences applet appears in the control center.
* Fri Apr 11 2008 maw@suse.de
- Update to version 2.22.1:
+ Remove code related to secure memory that was made unnecessary
due to its functionality being provided by gnome-keyring.
* Fri Mar 14 2008 maw@suse.de
- Update to version 2.22.0:
+ Cosmetic version bump.
* Wed Mar 05 2008 maw@suse.de
- Update to version 2.21.92:
+ Documentation updates
+ Translation fixes.
* Fri Feb 01 2008 maw@suse.de
- Update to version 2.21.91:
+ Adapt to new Epiphany API.
* Tue Jan 29 2008 maw@suse.de
- Update to version 2.21.90:
+ Remove options that screw with gpg.conf on seahorse-agent
startup, since this was unsafe and naive
+ Update libsoup optional dependency to depend on 2.4.x
+ Add icon for the gedit plugin
+ Don't add extra dot to encrypted or compressed files
+ Fix build problems with nautilus 2.21.x and later
+ Install nautilus extension to correct directory
+ Support better dropping of text keys onto main window.
* Wed Jan 09 2008 maw@suse.de
- Update to 2.21.4:
+ Remove ssh proxy since gnome-keyring now has a proper ssh agent
+ Don't hardcode epiphany extensions directories
+ Improved gnome-keyring integration
+ UI and HIG improvements
+ Disable automatic key uploading/retrieval by default
+ Minor fixes
- Remove seahorse-desktop.patch because it has been upstreamed
- Actually remove seahorse-gpgme-version.patch
- Add seahorse-strncat.patch and seahorse-xsltproc-nonet.patch.
* Fri Dec 14 2007 jpr@suse.de
- Update to 2.20.1
* Fix selection of archive names when encrypting.
* Now works with Gedit 2.20
* Other UI and code fixes
- Remove upstreamed patch seahourse-abuild-warnings.patch
- Annotate seahourse-desktop.patch
* Wed Dec 05 2007 maw@suse.de
- Don't require openldap2 to build.
* Wed Nov 21 2007 maw@suse.de
- Rename abuild.patch to seahorse-abuild-warnings.patch
- That patch now fixes more questionable code.
* Thu Oct 11 2007 sbrabec@suse.cz
- Use correct binding specific avahi package instead of
mDNSResponder.
* Wed Sep 19 2007 maw@suse.de
- Respin abuild.patch based on feedback from a seahorse maintainer
(thanks, Adam)
- Run %%suse_update_desktop_file against more .desktop files.
* Tue Sep 18 2007 maw@suse.de
- Update to version 2.20.0:
+ The large version bump is due to the seahorse project
synchronizing its version numbers with those of much of the
rest of the GNOME project
+ Hide the agent tray icon by default
+ Can now change gnome keyring master password
+ Added option to disable auto-retrieval of keys from key
servers
+ Give more detail for imported keys
+ Display gnome-keyring items properly
+ Progress windows show up in the window list now
+ Wrap text in the encryption applet properly
+ Now builds with GPG 2.0
+ Can now select archive extensions properly when encrypting
files
+ Fix problem with internationalized expiration dates on PGP
keys
+ Select a proper key size for SSH DSA keys
+ Allow SSH keys to be uploaded to machines listening on
non-standard ports
+ Can now import SSH keys that were generated elsewhere
+ Dialog and HIG fixes
+ Fix build problems
+ Fix crashers and problematic assertions
+ Updated translations
- Respin abuild.patch
- Remove seahorse-gpg-version.patch, which has been upstreamed.
* Wed Sep 05 2007 maw@suse.de
- Correct a .desktop file (#272535).
* Tue Aug 07 2007 maw@suse.de
- Use %%fdupes
- Split off a -lang subpackage
- s#%%run_ldconfig#/sbin/ldconfig# in %%post and %%postun.
* Fri Jun 22 2007 maw@suse.de
- s/gpg/gpg2/ in the buildreq
- Add seahorse-gpg-version.patch to allow builds when only gpg2
is installed.
* Wed Jun 06 2007 ro@suse.de
- added gpg to buildreq
* Mon Apr 16 2007 maw@suse.de
- Create a -devel subpackage (#262572).
* Wed Apr 11 2007 maw@suse.de
- Update to version 1.0.1
- Many fixes:
* Fix a crash when deleting keys.
* Require GTK+ 2.10 without which 1.0 didn't build
* Use /tmp directory for agent sockets, so that seahorse
works for people with home directories on NFS/AFS
* Fixed importing of private keys from ssh-keygen
* Fixed checks for memory locking
* Epiphany plugin now builds with Epiphany 2.18 [Adam Schreiber]
* Set a default icon for all seahorse windows.
* Now able to use ports other than 22 when sending an SSH
key to another computer.
* Internationalization fixes [Bjoern Voigt]
* Handle openssh's authorized_keys file more cleanly
* Handle spaces in a search text when searching an LDAP server
* Help now works in 'Search Results' window [Adam Schreiber]
* Other minor fixes
- Updated translations for the ar, bg, ca, da, dz, el, es, et, fi,
fr, it, gu, ja, lt, mk, nb, pt, pt_BR, sv, and th locales.
* Tue Apr 10 2007 maw@suse.de
- Add abuild.patch, to silence some warnings.
* Tue Apr 10 2007 maw@suse.de
- Add openssh as an additional build requirement.
* Mon Apr 09 2007 maw@suse.de
- Update to version 1.0
- Remove seahorse-uninited.patch which no longer appears to apply
- Many fixes for bugzilla.gnome.org incl. #415808, #408774, #414078,
[#411834], #408786, #410193, #408774, #406337, #408335, #375062,
[#404386], #402856, #391666, #396009, #393218, #393366, #391699,
[#391700], #363350, #387402, #357323, #349286, #336146, #354432,
[#388318], #338730, #387293, #376729, #384781, #324674, #354245,
[#358697], #362711, #382330, #374257, #377938, #376098, #376707,
[#376098], #369536, #369616, #371636, #371666, #372099, #369874,
[#363282], #351969, #368748, #366749, #355378, #364081, #361897,
[#356794], #355380, #356302, #357317, #356550, #355386, #355378,
[#355833], #355420, #355305, #353494, #354332, #354251, #354245,
[#351935], #353595, #352808, #351836, #352868, #352364, #352332,
[#345990], #352087, #351862, #351862, #351874, #351980, #351859,
[#351850], #351833, #350206, #338287, #347872, #156306, #347869,
[#349080], #348770, #347868, #339237, #339237, #341987, #347459,
[#346418], #346038, #346040, #341986, #341986, #341986, #338743,
and #342005
- No longer try to rename certain localizations
- Buildrequire gnome-doc-utils-devel
* Mon Apr 02 2007 ro@suse.de
- updated gconf scriptlets
* Mon Feb 05 2007 ro@suse.de
- GNOME moved to /usr
* Thu Dec 07 2006 sbrabec@suse.cz
- Fixed MIME database path in scriptlets (#225666).
- Use correct PreReq.
- Do not touch obsolete run-scrollkeeper-update.
* Mon Dec 04 2006 jhargadon@suse.de
- removed ownership of /opt/gnome/share/mime (#225667)
* Mon Sep 04 2006 ro@suse.de
- fix build (find icon file)
* Tue Jul 18 2006 nadvornik@suse.cz
- fixed check for minimal gpgme version
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Sat Jan 14 2006 kukuk@suse.de
- Add gpgme-devel to nfb
* Fri Jan 06 2006 gekker@suse.de
- Initial import into autobuild, version 0.8 (#131375)