File kernel-kdump.spec of Package kernel-source

#
# spec file for package kernel-kdump (Version 2.6.27.56)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

%if 0%{?opensuse_bs}
# Strip off the build number ("y") from the "x.y" release number
%define source_rel %(release=%release; echo ${release%.*})
%else
# We don't have build numbers internally
%define source_rel %release
%endif

# Don't use shell commands in build macros, this won't work outside of rpm
%define build_flavor kdump
%define build_kdump 0
%define build_xen 0
%define build_vanilla 0
%define build_ps3 0

%if %{build_flavor} == "kdump"
%define build_kdump 1
%endif
%if %{build_flavor} == "xen" || %{build_flavor} == "ec2"
%define build_xen 1
%endif
%if %{build_flavor} == "vanilla"
%define build_vanilla 1
%endif
%if %{build_flavor} == "ps3"
%define build_ps3 1
%endif

%(chmod +x %_sourcedir/{arch-symbols,guards,config-subst,check-for-config-changes,check-supported-list,built-in-where,modversions,symsets.pl})

%define symbols %(set -- kernel-kdump kernel-kdump $(case kdump in (rt|rt_*) echo RT ;; esac) $(%_sourcedir/arch-symbols %_target_cpu) $([ -e %_sourcedir/extra-symbols ] && cat %_sourcedir/extra-symbols) ; echo $*)
%define cpu_arch_flavor %(%_sourcedir/guards %symbols < %_sourcedir/config.conf | grep '/kdump$')

# Define some CONFIG variables as rpm macros as well. (rpm cannot handle
# defining them all at once.)
%define config_vars CONFIG_MODULES CONFIG_KMSG_IDS
%{expand:%(eval "$(test -n "%cpu_arch_flavor" && tar xfj %_sourcedir/config.tar.bz2 --to-stdout config/%cpu_arch_flavor)"; for config in %config_vars; do echo "%%global $config ${!config:-n}"; done)}

%ifarch %ix86 x86_64
%define install_vdso 1
%else
%define install_vdso 0
%endif
%if %build_vanilla || %build_kdump || %CONFIG_MODULES != "y"
%define split_packages 0
%else
%define split_packages 1
%endif

Name:           kernel-kdump
Summary:        kernel for kdump
Version:        2.6.27.56
Release:        0.<RELEASE1>
License:        GPL v2 only
Group:          System/Kernel
Url:            http://www.kernel.org/
AutoReqProv:    on
BuildRequires:  coreutils module-init-tools sparse
BuildRequires:  fdupes
Provides:       kernel-kdump_%_target_cpu = %version-%release
%if %split_packages
Requires:       kernel-kdump-base_%_target_cpu = %version-%release
%endif
Requires(pre):  coreutils awk
Requires(post): module-init-tools
# require a m-i-t package that fixes bnc#480524
Requires(post): module-init-tools_fix_bnc480524
#!BuildIgnore:  module-init-tools_fix_bnc480524
# This Requires is wrong, because the post/postun scripts have a
# test -x update-bootloader, having perl-Bootloader is not a hard requirement.
# But, there is no way to tell rpm or yast to schedule the installation
# of perl-Bootloader before kernel-binary.rpm if both are in the list of
# packages to install/update. Likewise, this is true for mkinitrd.
# A specific version of perl-Bootloader is not required, because the post/postun
# scripts handle the two API versions of 10.1/SLES10 GA and 10.2/SLES10 SP1
Requires(post): perl-Bootloader >= 0.4.81.1
Requires(post): mkinitrd
#!BuildIgnore:  perl-Bootloader mkinitrd

%if ! 0%{?opensuse_bs}
BuildRequires:  kernel-dummy
%endif
%ifarch ia64
# arch/ia64/scripts/unwcheck.py
BuildRequires:  python
%endif
%if %build_xen && %build_flavor != "ec2"
%ifarch %ix86
Provides:       kernel-xenpae = 2.6.27.56
Obsoletes:      kernel-xenpae <= 2.6.27.56
%endif
#!BuildIgnore:  xen
%endif

Provides:       kernel-kdump-nongpl
Obsoletes:      kernel-kdump-nongpl
%if %build_vanilla
# force bzip2 instead of lzma compression to allow install on older dist versions
%define _binary_payload w9.bzdio
%endif
# dead network if installed on SLES10, otherwise it will work (mostly)
Conflicts:      sysfsutils < 2.0
%if ! %build_vanilla
Conflicts:      apparmor-profiles <= 2.1
Conflicts:      apparmor-parser < 2.3
# root-lvm only works with newer udevs
Conflicts:      udev < 118
Conflicts:      lvm2 < 2.02.33
%endif
%ifarch %ix86
Conflicts:      libc.so.6()(64bit)
%endif
Provides:       kernel = 2.6.27.56-%source_rel
%ifarch ppc
%else
%ifarch ppc64
%endif
%endif

Source0:        http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.27.tar.bz2
Source10:       preun.sh
Source11:       postun.sh
Source12:       pre.sh
Source13:       post.sh
Source20:       series.conf
Source21:       config.conf
Source22:       supported.conf
Source30:       arch-symbols
Source31:       guards
Source32:       config-subst
Source33:       check-for-config-changes
Source34:       check-supported-list
Source40:       build-source-timestamp
Source41:       built-in-where
Source44:       find-provides
Source45:       module-renames
Source46:       modversions
Source47:       symsets.pl
Source48:       generic_serial-blacklist
Source100:      config.tar.bz2
Source101:      patches.arch.tar.bz2
Source102:      patches.drivers.tar.bz2
Source103:      patches.fixes.tar.bz2
Source104:      patches.rpmify.tar.bz2
Source105:      patches.suse.tar.bz2
Source107:      patches.xen.tar.bz2
Source108:      patches.addon.tar.bz2
Source109:      patches.kernel.org.tar.bz2
Source110:      patches.apparmor.tar.bz2
Source111:      patches.rt.tar.bz2
Source112:      patches.trace.tar.bz2
Source113:      patches.kabi.tar.bz2
Source120:      kabi.tar.bz2
%define my_builddir %_builddir/%{name}-%{version}
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
ExclusiveArch:  ppc ppc64

# These files are found in the kernel-source package:
NoSource:       0
NoSource:       100
NoSource:       101
NoSource:       102
NoSource:       103
NoSource:       104
NoSource:       105
NoSource:       107
NoSource:       108
NoSource:       109
NoSource:       110
NoSource:       111
NoSource:       120

# The following KMPs have been integrated into the kernel package.
Obsoletes:      iwlwifi-kmp-%build_flavor
Obsoletes:      ipw3945-kmp-%build_flavor
Obsoletes:      adm8211-kmp-%build_flavor
Obsoletes:      rt2x00-kmp-%build_flavor
Obsoletes:      rfswitch-kmp-%build_flavor
Obsoletes:      uvcvideo-kmp-%build_flavor
Obsoletes:      atl2-kmp-%build_flavor
Obsoletes:      wlan-ng-kmp-%build_flavor
Obsoletes:      et131x-kmp-%build_flavor
Obsoletes:      ivtv-kmp-%build_flavor
Obsoletes:      at76_usb-kmp-%build_flavor
Obsoletes:      pcc-acpi-kmp-%build_flavor
Obsoletes:      uvcvideo-kmp-%build_flavor
Obsoletes:      ralink-rt2860-kmp-%build_flavor
Obsoletes:      btusb-kmp-%build_flavor

# Build with bash instead of sh as the shell: this turns on bash
# extensions like <(...).
%define _buildshell /bin/bash

# Provide the exported symbols as "ksym(symbol) = hash"
%define __find_provides %my_builddir/find-provides %name

# Will modules not listed in supported.conf abort the kernel build (0/1)?
%define supported_modules_check 0

%define tolerate_unknown_new_config_options 0

# kABI change tolerance (default in maintenance should be 4, 6, 8 or 15,
# 31 is the maximum; see scripts/kabi-checks)
%define tolerate_kabi_changes 6

%description
This kernel is intended for kdump. It can not be booted with a normal
bootloader, the kexec tool has to be used to load it. Once the system
crashes, the loaded kernel will be started to grab debug info from the
crashed kernel.



Source Timestamp: 2010-12-01 16:57:58 +0100
GIT Revision: 1b5f62cf35ce9157f69781339df846ab7661e31d
GIT Branch: SLE11_BRANCH

%prep
if ! [ -e %_sourcedir/linux-2.6.27.tar.bz2 ]; then
    echo "The kernel-kdump-2.6.27.56.nosrc.rpm package does not contain the" \
	 "complete sources. Please install kernel-source-2.6.27.56.src.rpm."
    exit 1
fi

echo "Architecture symbol(s):" %symbols

# Unpack all sources and patches
%setup -q -c -T -a 0 -a 100 -a 101 -a 102 -a 103 -a 104 -a 105 -a 107 -a 108 -a 109 -a 110 -a 111 -a 112 -a 113 -a 120

supported_conf() {
	%_sourcedir/guards %symbols $* < %_sourcedir/supported.conf | sort -u
}

# Generate the list of modules to be marked as supported
{   supported_conf base
    for how in external; do
	comm -2 -3 <(supported_conf base $how) <(supported_conf base) \
	    | sed -e 's:$: '"$how"':'
    done
} | sed -e 's,.*/,,' -e 's,\.ko$,,' > linux-2.6.27/Module.supported

# Create grep pattern file for the modules to end up in the base package
comm -2 -3 <(supported_conf base) <(supported_conf) \
    | sed -e 's:.*/::' -e 's:^:\\/:' -e 's:$:\.ko$:' \
    > %my_builddir/grep-for-base-modules

cd linux-2.6.27

# Apply the patches needed for this architecture.
%if ! %build_vanilla
for patch in $(%_sourcedir/guards %symbols < %_sourcedir/series.conf); do
    if ! patch -s -F0 -E -p1 --no-backup-if-mismatch -i ../$patch; then
	echo "*** Patch $patch failed ***"
	exit 1
    fi
done
%else
for patch in $(%_sourcedir/guards %symbols < %_sourcedir/series.conf | egrep kernel.org\|rpmify); do
    if ! patch -s -F0 -E -p1 --no-backup-if-mismatch -i ../$patch; then
	echo "*** Patch $patch failed ***"
	exit 1
    fi
done
%endif

# Release number without the EXTRAVERSION
RELEASE=%source_rel
while [ "$RELEASE" != "${RELEASE#[^0-9]*.}" ]; do
    RELEASE=${RELEASE#[^0-9]*.}
done

if [ -f %_sourcedir/localversion ] ; then
    cat %_sourcedir/localversion > localversion
fi

cat ../config/%cpu_arch_flavor \
| %_sourcedir/config-subst CONFIG_LOCALVERSION '"'-$RELEASE-kdump'"' \
| %_sourcedir/config-subst CONFIG_SUSE_KERNEL y \
%if 0%{?__debug_package:1}
    | %_sourcedir/config-subst CONFIG_DEBUG_INFO y \
%endif
    > .config

cpu_arch_flavor="%cpu_arch_flavor"
cat >> ../.rpm-defs <<EOF
cpu_arch=${cpu_arch_flavor%/*}
KERNELRELEASE=2.6.27.56-$RELEASE-kdump
EOF

%if 0%{?__debug_package:1}
cat >> ../.rpm-defs <<EOF
MAKE_ARGS="\$MAKE_ARGS CONFIG_DEBUG_INFO=y"
EOF
%endif

echo CONFIG_MODULES=%CONFIG_MODULES >> ../.rpm-defs

sed 's|^sourcedir=.*|sourcedir="%_sourcedir"|;
     s|^builddir=.*|builddir="%my_builddir"|' \
     %_sourcedir/find-provides >%my_builddir/find-provides
chmod +x %my_builddir/find-provides

%build
source .rpm-defs

cd linux-2.6.27
cp .config .config.orig
%if %{tolerate_unknown_new_config_options}
MAKE_ARGS="$MAKE_ARGS -k"
yes '' | make oldconfig $MAKE_ARGS
%else
make silentoldconfig $MAKE_ARGS < /dev/null
%_sourcedir/check-for-config-changes .config.orig .config
rm .config.orig
%endif

# create *.symref files in the tree
if [ -e ../kabi/$cpu_arch/symtypes-kdump ]; then
    %_sourcedir/modversions --unpack . <../kabi/$cpu_arch/symtypes-kdump
fi

make prepare $MAKE_ARGS
krel=$(make -s kernelrelease $MAKE_ARGS)

if [ "$krel" != "$KERNELRELEASE" ]; then
    echo "Kernel release mismatch: $krel != $KERNELRELEASE" >&2
    exit 1
fi

cat > .kernel-binary.spec.buildenv <<EOF
# Override the timestamp 'uname -v' reports with the build
# timestamp.
export KBUILD_BUILD_VERSION="$(grep SHA1_ID %_sourcedir/build-source-timestamp | awk '{ print $2 }')"
export KBUILD_BUILD_TIMESTAMP="$(head -n 1 %_sourcedir/build-source-timestamp)"

# The following branch/timestamp will end up in Oopses.
export OOPS_TIMESTAMP="$(
    echo -n $(sed -ne 's/^GIT Branch: \(.*\)/\1-/p' \
		  %_sourcedir/build-source-timestamp)
    head -n 1 %_sourcedir/build-source-timestamp \
	| tr -dc 0-9)"

export KBUILD_VERBOSE=0
export KBUILD_SYMTYPES=1
export KBUILD_OVERRIDE=1
EOF
source .kernel-binary.spec.buildenv

# If the %jobs macro is defined to a number, make will spawn that many jobs.
# There are several ways how to define it:
# If you are using the build script:
#     build --jobs=N kernel-$flavor.spec
# With plain rpmbuild:
#     rpmbuild -ba --define 'jobs N' kernel-$flavor.spec
# To spawn as many jobs as there are cpu cores:
#     rpmbuild -ba --define "jobs 0$(grep -c ^processor /proc/cpuinfo)" \
#         kernel-$flavor.spec
# You can also set this permanently in ~/.rpmmacros:
#     %jobs 0%(grep -c ^processor /proc/cpuinfo)
%if %CONFIG_KMSG_IDS == "y"
    chmod +x scripts/kmsg-doc
    make %{?jobs:-j%jobs} all $MAKE_ARGS CONFIG_DEBUG_SECTION_MISMATCH=y D=2
%ifarch s390 s390x
%if ! %build_vanilla
    make arch/s390/boot/kerntypes.o
%endif
%endif
%else
    make %{?jobs:-j%jobs} all $MAKE_ARGS CONFIG_DEBUG_SECTION_MISMATCH=y
%endif

%install
source .rpm-defs

# get rid of /usr/lib/rpm/brp-strip-debug
# strip removes too much from the vmlinux ELF binary
export NO_BRP_STRIP_DEBUG=true

# /lib/modules/$KERNELRELEASE/build will be a stale symlink until the
# kernel-source package is installed. Don't check for stale symlinks
# in the brp-symlink check:
export NO_BRP_STALE_LINK_ERROR=yes

cd linux-2.6.27

mkdir %buildroot/boot
# (Could strip out non-public symbols.)
cp -p System.map %buildroot/boot/System.map-$KERNELRELEASE

add_vmlinux()
{
    local vmlinux=boot/vmlinux-$KERNELRELEASE
%if 0%{?__debug_package:1}
    local vmlinux_debug=usr/lib/debug/$vmlinux.debug
    mkdir -p $(dirname %buildroot/$vmlinux_debug)
    cp vmlinux %buildroot/$vmlinux
    /usr/lib/rpm/debugedit -b $RPM_BUILD_DIR -d /usr/src/debug \
			   -l vmlinux.sourcefiles %buildroot/$vmlinux
    objcopy --only-keep-debug \
	    %buildroot/$vmlinux \
	    %buildroot/$vmlinux_debug || :
    objcopy --add-gnu-debuglink=%buildroot/$vmlinux_debug \
	    --strip-debug \
	    %buildroot/$vmlinux || :
    mkdir -p %buildroot/usr/src/debug
    LANG=C sort -z -u vmlinux.sourcefiles | grep -z -v "<built-in>" \
	| ( cd %_builddir && cpio -pd0m %buildroot/usr/src/debug )
    find %buildroot/usr/src/debug -type d -print0 | xargs -0 -r chmod 0755
    find %buildroot/usr/src/debug -type f -print0 | xargs -0 -r chmod 0644
%else
    cp vmlinux %buildroot/$vmlinux
%endif
    if [ "$1" = --compressed ]; then
	gzip -9 %buildroot/$vmlinux
        chmod a-x %buildroot/$vmlinux.gz
    fi
}

%if %build_kdump
    add_vmlinux
    chmod 644 %buildroot/boot/vmlinux-$KERNELRELEASE
    image=vmlinux
%else

# architecture specifics
%ifarch %ix86 x86_64
    add_vmlinux --compressed
%if %build_xen
    image=vmlinuz
%else
    image=bzImage
%endif
    cp -p arch/x86/boot/$image %buildroot/boot/vmlinuz-$KERNELRELEASE
    image=vmlinuz
%endif
%ifarch alpha
    add_vmlinux --compressed
    cp -p arch/alpha/boot/vmlinux.gz %buildroot/boot/vmlinuz-$KERNELRELEASE
    image=vmlinuz
%endif
%ifarch ppc ppc64
    add_vmlinux
    chmod 644 %buildroot/boot/vmlinux-$KERNELRELEASE
    image=vmlinux
%endif
%ifarch ia64
    add_vmlinux --compressed
    mv %buildroot/boot/vmlinux-$KERNELRELEASE.gz \
       %buildroot/boot/vmlinuz-$KERNELRELEASE
    image=vmlinuz
%endif
%ifarch s390 s390x
    add_vmlinux --compressed
    cp -p arch/s390/boot/image %buildroot/boot/image-$KERNELRELEASE
    image=image
%ifarch s390 s390x
%if ! %build_vanilla
    cp -p arch/s390/boot/kerntypes.o %buildroot/boot/Kerntypes-$KERNELRELEASE
%endif
%endif
%if %CONFIG_KMSG_IDS == "y"
    mkdir -p %buildroot/usr/share/man/man9
    find man -name '*.9' -exec install -m 644 -D '{}' %buildroot/usr/share/man/man9/ ';'
%endif
%endif
    if [ -e init/kerntypes.o ]; then
	cp init/kerntypes.o %buildroot/boot/Kerntypes-$KERNELRELEASE
    fi

# end of build_kdump
%endif

for sub in '-base' '' '-extra'; do
%if %split_packages
    if [ "x$sub" = "x-base" ]; then
        base_package=1
    else
        base_package=0
    fi
%else
    base_package=1
%endif
    for script in preun postun pre post; do
        sed -e "s:@KERNELRELEASE@:$KERNELRELEASE:g" \
            -e "s:@IMAGE@:$image:g" \
            -e "s:@FLAVOR""@:kdump:g" \
            -e "s:@SUBPACKAGE@:kernel-kdump$sub:g" \
            -e "s:@BASE_PACKAGE@:$base_package:g" \
            -e "s:@RPM_VERSION_RELEASE@:%version-%release:g" \
            -e "s:@RPM_TARGET_CPU@:%_target_cpu:g" \
            %_sourcedir/$script.sh > ../$script$sub.sh
    done
done

%if %build_kdump || %build_xen || %build_vanilla || %build_ps3
# keep this -suffix list in sync with post.sh and postun.sh
suffix=-kdump
%endif
ln -s $image$suffix %buildroot/boot/$image$suffix
ln -s initrd$suffix %buildroot/boot/initrd$suffix

cp .config %buildroot/boot/config-$KERNELRELEASE

%if %install_vdso
# Install the unstripped vdso's that are linked in the kernel image
make vdso_install $MAKE_ARGS INSTALL_MOD_PATH=%buildroot
%endif

# Create a dummy initrd with roughly the size the real one will have.
# That way, YaST will know that this package requires some additional
# space in /boot.
dd if=/dev/zero of=%buildroot/boot/initrd-$KERNELRELEASE \
	bs=1024 seek=2047 count=1

if [ $CONFIG_MODULES = y ]; then
    # Figure out where the symbols that vmlinux exports are defined.
    # (We need this information below as well as in find-provides; we "annotate"
    #  the original Module.symvers here to make sure that we are consistent in
    #  both places.)
    %_sourcedir/built-in-where < Module.symvers > Module.symvers.split
    mv Module.symvers.split Module.symvers

    gzip -c9 < Module.symvers > %buildroot/boot/symvers-$KERNELRELEASE.gz

    make modules_install $MAKE_ARGS INSTALL_MOD_PATH=%buildroot

    if ! %_sourcedir/check-supported-list \
	    %_sourcedir %buildroot/lib/modules/$KERNELRELEASE; then
%if %supported_modules_check
	exit 1
%endif
	echo "Consistency check error: please update supported.conf."
    fi

    # Also put the resulting file in $obj_dir/$cpu_arch/kdump
    # so that kernel-source + kernel-kdump is sufficient for building
    # modules that have modversions as well.
    obj_dir=usr/src/linux-${KERNELRELEASE%%-kdump}-obj
    mkdir -p %buildroot/$obj_dir/$cpu_arch/kdump
    cp Module.symvers %buildroot/$obj_dir/$cpu_arch/kdump

    # Table of types used in exported symbols (for modversion debugging).
    %_sourcedir/modversions --pack . > %buildroot/boot/symtypes-$KERNELRELEASE
    if [ -s %buildroot/boot/symtypes-$KERNELRELEASE ]; then
	gzip -9 %buildroot/boot/symtypes-$KERNELRELEASE
    else
	rm -f %buildroot/boot/symtypes-$KERNELRELEASE
    fi

    # Some architecture's $(uname -m) output is different from the ARCH
    # parameter that needs to be passed to kbuild. Create symlinks from
    # $(uname -m) to the ARCH directory.
    [ -e %buildroot/$obj_dir/%_target_cpu ] \
	|| ln -sf $cpu_arch %buildroot/$obj_dir/%_target_cpu

    # We were building in %my_builddir/linux-2.6.27, but the sources will
    # later be installed in /usr/src/linux-2.6.27-%source_rel. Fix up the
    # build symlink.
    rm -f %buildroot/lib/modules/$KERNELRELEASE/{source,build}
    ln -s /usr/src/linux-${KERNELRELEASE%%-kdump} \
	%buildroot/lib/modules/$KERNELRELEASE/source
    ln -s /$obj_dir/$cpu_arch/kdump \
	%buildroot/lib/modules/$KERNELRELEASE/build

    # Abort if there are any undefined symbols
    msg="$(/sbin/depmod -F %buildroot/boot/System.map-$KERNELRELEASE \
			-b %buildroot -ae $KERNELRELEASE 2>&1)"
    if [ $? -ne 0 ] || echo "$msg" | grep  'needs unknown symbol'; then
	exit 1
    fi

%if %split_packages
    # Generate the lists of supported and unsupported modules.
    (   cd %buildroot
	: > %my_builddir/supported-modules
	: > %my_builddir/unsupported-modules
	for module in $(find lib/modules/$KERNELRELEASE -type f -name '*.ko'); do
	    case "$(/sbin/modinfo -F supported $module)" in
	    (yes|external)
		modname=$(basename $module .ko)
		deps=$(/sbin/modinfo -F depends $module|tr ',' ' ')
		echo "$modname: $deps" >> %my_builddir/Makefile.supported
		echo "/$module" >> %my_builddir/supported-modules
		;;
	    (*)
		echo "/$module" >> %my_builddir/unsupported-modules
		;;
	    esac
	done
    )

    add_dependent_modules() {
	local modules_dep=$1

	xargs make -rRs -f <(echo -e '%:\n\t@echo $@' ; cat $modules_dep)
    }

    modules_dep=%buildroot/lib/modules/$KERNELRELEASE/modules.dep

    # Make sure that no supported modules depend on any unsupported modules.
    dependent_unsupported_modules=$(
	OUT=$(mktemp)
	sed -e 's/:.*//g' < %my_builddir/Makefile.supported | \
		    xargs make -rRsk -f %my_builddir/Makefile.supported > $OUT
	sed -ne '/No rule/s/^.*No rule to make target//p' < $OUT | tr -d "\`'"
    )
    if [ -n "$dependent_unsupported_modules" ]; then
	echo "The following unsupported modules are used by supported modules:"
	echo "$dependent_unsupported_modules"
	echo "Please fix supported.conf."
	if [ ! -e %_sourcedir/IGNORE-UNSUPPORTED-DEPS ]; then
		exit 1
	fi
    fi

    # Compute the list of base modules: modules that core modules depend on
    # implicitly are also core modules.
    grep -f %my_builddir/grep-for-base-modules %my_builddir/supported-modules \
    | add_dependent_modules $modules_dep > %my_builddir/base-modules

    # All supported modules which are not core modules belong in kernel-kdump.
    comm -3 <(sort %my_builddir/supported-modules) \
	    <(sort %my_builddir/base-modules) \
	> %my_builddir/main-modules
%else
    (   cd %buildroot
	find lib/modules/$KERNELRELEASE -type f -name '*.ko' -printf '/%%p\n'
    ) > %my_builddir/base-modules
%endif

    # generate symsets
    mkdir -p %my_builddir/{base,main,extra}-symsets
    for f in %my_builddir/{base,main,unsupported}-modules; do
        if [ -f "$f" ]; then
            sed 's:^/:%buildroot/:' "$f"
        fi > "$f-br"
    done
    reference=
    if test -e %my_builddir/kabi/$cpu_arch/symsets-kdump.tar.gz; then
        tar xzf %my_builddir/kabi/$cpu_arch/symsets-kdump.tar.gz -C \
	    %my_builddir/kabi/$cpu_arch
        reference="--reference %my_builddir/kabi/$cpu_arch/symsets-*-kdump/"
        if test -e %my_builddir/kabi/$cpu_arch/symvers-kdump.fake; then
            reference="$reference --fake $_"
        fi
    fi
    %_sourcedir/symsets.pl --generate-symsets \
        $reference \
        --symvers=Module.symvers \
        --modules=%my_builddir/base-modules-br \
        --output-dir=%my_builddir/base-symsets
%if %split_packages
    %_sourcedir/symsets.pl --generate-symsets \
        $reference \
        --modules=%my_builddir/main-modules-br \
        --required-modules=%my_builddir/base-modules-br \
        --output-dir=%my_builddir/main-symsets
    %_sourcedir/symsets.pl --generate-symsets \
        $reference \
        --modules=%my_builddir/unsupported-modules-br \
        --required-modules=%my_builddir/base-modules-br \
        --required-modules=%my_builddir/main-modules-br \
        --output-dir=%my_builddir/extra-symsets
%endif
    # check for kabi changes
    KABI=0
    if [ -n "$reference" ]; then
        %_sourcedir/symsets.pl --check-kabi \
            $reference \
            --symvers=Module.symvers \
            --modules=%my_builddir/base-modules-br \
            --modules=%my_builddir/main-modules-br \
            --modules=%my_builddir/unsupported-modules-br \
            --commonsyms=%my_builddir/kabi/commonsyms \
            --usedsyms=%my_builddir/kabi/usedsyms \
            --severities=%my_builddir/kabi/severities \
            --max-badness=%tolerate_kabi_changes || KABI=$?
    fi
    if [ $KABI -ne 0 ]; then
	if [ ! -e %my_builddir/kabi/$cpu_arch/ignore-kdump -a \
	     ! -e %_sourcedir/IGNORE-KABI-BADNESS ]; then
	    echo "Create a file IGNORE-KABI-BADNESS in the kernel-source" \
		 "directory to build this kernel even though its badness is" \
		 "higher than allowed for an official kernel."
	   exit 1
	fi

	# Indicate the ABI badness in build result emails.
	echo "KABI BADNESS $KABI" > %_rpmdir/%_arch/mbuild_subject.tag
    fi

    symsets=%my_builddir/symsets-$KERNELRELEASE
    mkdir -p $symsets
    find %my_builddir/{base,main,extra}-symsets -type f \
	| xargs --replace='{}' cp '{}' $symsets/
    tar c -C ${symsets%/*} ${symsets##*/} \
	| gzip -9 \
	> %buildroot/boot/symsets-$KERNELRELEASE.tar.gz

    # Set up some module aliases
    install -d -m 755 %buildroot/etc/modprobe.d/
    install -m 644 %_sourcedir/module-renames %buildroot/etc/modprobe.d/
    install -m 644 %_sourcedir/generic_serial-blacklist %buildroot/etc/modprobe.d/
fi

add_dirs_to_filelist() {
    local filelist

    filelist=$(cat "$@")
    echo "$filelist"

    # Below, we do this:
    # - remove filelist macros
    # - remove last pathname component
    # - generate all parents and make the list unique
    # - skip directories owned be other packages
    # - add the %dir prefix (double-escaped for find and rpm)

    echo "$filelist" \
    | sed -re 's:%%%%[a-z]+(\([^)]+\))? ?::g' \
    | sed -re 's:/[^/]+$::' \
    | sed -nre ':a; p; s:/[^/]+$::; ta' \
    | sort -u \
    | sed -r -e '\:^(|/boot|/etc|/lib(/modules|/firmware)?|/usr(/src)?)$:d' \
    | sed -e 's:^:%%%%dir :'
}

# Collect the file lists.
{   cd %buildroot
    find boot \
	\( -type l -o -name 'initrd-*' \) -printf '%%%%%%%%ghost /%%p\n' -o \
	-type f -printf '/%%p\n'

    # Add the auto-generated (by mkdumprd) kdump initrd to %ghost so that
    # the file gets removed when uninstalling the kernel.
    echo '%%%%ghost /boot/initrd-'${KERNELRELEASE}'-kdump'
    touch $RPM_BUILD_ROOT/boot/initrd-${KERNELRELEASE}-kdump

    if [ $CONFIG_MODULES = y ]; then
	find lib/modules/$KERNELRELEASE \
	    -type d -o \
	    \( -path '*/modules.*' ! -path '*/modules.order' \) \
		-printf '%%%%%%%%ghost /%%p\n' -o \
	    -name '*.ko' -prune -o \
	    -printf '/%%p\n'
	cat %my_builddir/base-modules
	echo '%%%%config /etc/modprobe.d/module-renames'
	echo '%%%%config /etc/modprobe.d/generic_serial-blacklist'
	find $obj_dir \
	    -type d -o \
	    -printf '/%%p\n'
    fi
    test -d lib/firmware/$KERNELRELEASE && \
    find lib/firmware/$KERNELRELEASE \
	-type d -o \
	-printf '/%%p\n'
    if [ -e .%_docdir/%name ]; then
	echo "%%%%doc %_docdir/%name"
    fi
} | add_dirs_to_filelist > %my_builddir/kernel-base.files

%if %split_packages
    add_dirs_to_filelist %my_builddir/main-modules > %my_builddir/kernel-main.files
    add_dirs_to_filelist %my_builddir/unsupported-modules > %my_builddir/kernel-extra.files
%endif

# Hardlink duplicate files automatically (from package fdupes): It doesn't save
# much, but it keeps rpmlint from breaking the package build.
%fdupes $RPM_BUILD_ROOT

%preun -f preun.sh

%postun -f postun.sh

%pre -f pre.sh

%post -f post.sh

%if %split_packages

%files -f kernel-main.files
%else

%files -f kernel-base.files
%endif
%defattr(-, root, root)

%package -n kernel-kdump-base
Summary:        kernel for kdump - base modules
License:        GPL v2 only
Group:          System/Kernel
Url:            http://www.kernel.org/
AutoReqProv:    on
Provides:       kernel-kdump-base_%_target_cpu = %version-%release
Provides:       kernel-base = %version-%source_rel
Requires(pre):  coreutils awk
Requires(post): module-init-tools >= 3.4-56.9
Requires(post): perl-Bootloader >= 0.4.81.1
Requires(post): mkinitrd
%ifarch %ix86
Conflicts:      libc.so.6()(64bit)
%endif

%description -n kernel-kdump-base
This kernel is intended for kdump. It can not be booted with a normal
bootloader, the kexec tool has to be used to load it. Once the system
crashes, the loaded kernel will be started to grab debug info from the
crashed kernel.

This package contains only the base modules, required in all installs.



Source Timestamp: 2010-12-01 16:57:58 +0100
GIT Revision: 1b5f62cf35ce9157f69781339df846ab7661e31d
GIT Branch: SLE11_BRANCH

%preun base -f preun-base.sh

%postun base -f postun-base.sh

%pre base -f pre-base.sh

%post base -f post-base.sh

%if %split_packages

%files -n kernel-kdump-base -f kernel-base.files
%defattr(-, root, root)
%endif

%package -n kernel-kdump-extra
Summary:        kernel for kdump - extra modules
License:        GPL v2 only
Group:          System/Kernel
Url:            http://www.kernel.org/
AutoReqProv:    on
Provides:       kernel-kdump-extra_%_target_cpu = %version-%release
Requires:       kernel-kdump_%_target_cpu = %version-%release
Provides:       kernel-extra = %version-%source_rel
Requires(pre):  coreutils awk
Requires(post): module-init-tools >= 3.4-56.9
Requires(post): perl-Bootloader >= 0.4.81.1
Requires(post): mkinitrd
Supplements:    packageand(product(SUSE_SLED):kernel-kdump_%_target_cpu)
Supplements:    packageand(product(openSUSE):kernel-kdump_%_target_cpu)
%ifarch %ix86
Conflicts:      libc.so.6()(64bit)
%endif

%description -n kernel-kdump-extra
This kernel is intended for kdump. It can not be booted with a normal
bootloader, the kexec tool has to be used to load it. Once the system
crashes, the loaded kernel will be started to grab debug info from the
crashed kernel.

This package contains additional modules not supported by Novell.



Source Timestamp: 2010-12-01 16:57:58 +0100
GIT Revision: 1b5f62cf35ce9157f69781339df846ab7661e31d
GIT Branch: SLE11_BRANCH

%preun extra -f preun-extra.sh

%postun extra -f postun-extra.sh

%pre extra -f pre-extra.sh

%post extra -f post-extra.sh

%if %split_packages

%files -n kernel-kdump-extra -f kernel-extra.files
%defattr(-, root, root)
%endif

%if %CONFIG_KMSG_IDS == "y"

%package -n kernel-kdump-man
License:        GPL v2 only
Summary:        kernel for kdump
Group:          System/Kernel

%description -n kernel-kdump-man
This kernel is intended for kdump. It can not be booted with a normal
bootloader, the kexec tool has to be used to load it. Once the system
crashes, the loaded kernel will be started to grab debug info from the
crashed kernel.



Source Timestamp: 2010-12-01 16:57:58 +0100
GIT Revision: 1b5f62cf35ce9157f69781339df846ab7661e31d
GIT Branch: SLE11_BRANCH

%files -n kernel-kdump-man
%defattr(-,root,root)
/usr/share/man/man9/*
%endif

%changelog
openSUSE Build Service is sponsored by