File WindowMaker.spec of Package WindowMaker

#
# spec file for package WindowMaker (Version 0.92.0)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           WindowMaker
BuildRequires:  freetype2-devel gcc-c++ giflib-devel libpng-devel libtiff-devel update-desktop-files xorg-x11-devel
License:        GPL v2 or later; LGPL v2.1 or later; Public Domain, Freeware
Group:          System/GUI/Other
Url:            http://www.windowmaker.info/
Obsoletes:      wmaker 
Provides:       wmaker windowmanager
Requires:       xdg-menu
AutoReqProv:    on
Summary:        A Colorful and Flexible Window Manager
Version:        0.92.0
Release:        206
Source:         WindowMaker-%{version}.tar.bz2
Source1:        WindowMaker-extra-0.1.tar.bz2
Source2:        SuSE-theme.tar.bz2
Source4:        README.SuSE
Source5:        %name.desktop
Source6:        windowmaker
Source7:        WindowMaker-rpmlintrc
Patch1:         WindowMaker-config.dif
Patch2:         WindowMaker-menu.patch
Patch22:        WindowMaker-warnings.patch
Patch24:        WindowMaker-nb-locale.patch
Patch25:        WindowMaker-wmspec.c.patch
Patch26:        WindowMaker-null.patch
Patch27:        WindowMaker-de_translation.patch
Patch28:        WindowMaker-wmspec.c-icon.patch
Patch29:        WindowMaker-asm.patch
Patch30:        WindowMaker-fullscreen.patch
Patch31:        WindowMaker-MAX_WORKSPACENAME_WIDTH.patch
Patch32:        WindowMaker-0.92.0-printf.diff
Patch33:        WindowMaker-refcount.patch
Patch34:        WindowMaker-crash.patch
Patch35:        WindowMaker-fonts.patch
Patch36:        WindowMaker-exec.patch
Patch37:        WindowMaker-event.patch
Patch38:        WindowMaker-wmspec.c-findBestIcon.patch
Patch39:        WindowMaker-dir-specification.patch
Patch40:        WindowMaker-composite.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%package devel
License:        GPL v2 or later
Requires:       %{name} = %{version} libtiff-devel libjpeg-devel xorg-x11-devel libpng-devel zlib-devel giflib-devel
Summary:        Includes and static libraries for Window Maker
Group:          Development/Libraries/X11

%description
Window Maker is a colorful and flexible window manager and
thedesignnated successor of AfterStep. nFor more details, check
http://www.windowmaker.org.



Authors:
--------
    Alfredo K. Kojima <kojima@windowmaker.org>

%description devel
Includes and static libraries for Window Maker



Authors:
--------
    Alfredo K. Kojima <kojima@windowmaker.org>

%prep
%setup -q -n WindowMaker-%{version} -a 1
mkdir menu.orig
cp WindowMaker/{menu.*,plmenu.*} menu.orig
%patch1
%patch2
%patch22
%patch24
%patch25
%patch26 -p1
%patch27
%patch28
%patch29
%patch30
%patch31
%patch32
%patch33 -p1
%patch34
%patch35
%patch36
%patch37
%patch38
%patch39
%patch40
cp %{S:4} .
cp %{S:6} .
rename no nb po/no.*
(cd WindowMaker; rm -f *.orig; ./mkMakefile )
# ---------------------------------------------------------------------------

%build
autoreconf --force --install
export LINGUAS="be bg ca cs da de el es et fi fr gl hr hu it ja ko ms nl nb pl pt ro ru sk sv tr zh_CN zh_TW"
export CFLAGS="$RPM_OPT_FLAGS $(freetype-config --cflags)"
%configure --disable-static --with-pic\
            --sysconfdir=/etc/X11 \
            --enable-sound \
	    --enable-gnome \
	    --enable-kde \
	    --enable-xinerama \
            --with-nlsdir=/usr/share/locale \
            --with-pixmapdir=/usr/share/WindowMaker/Pixmaps \
	    --with-gnustepdir=/usr/lib/GNUstep
(cd WindowMaker/Defaults; make clean; make)
make 
(cd WindowMaker-extra-0.1
%configure --disable-static --with-pic\
            --with-pixmapdir=/usr/share/WindowMaker/Pixmaps \
make
)
# ---------------------------------------------------------------------------

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -m 755 dockit $RPM_BUILD_ROOT/usr/bin/dockit
install -m 755 windowmaker $RPM_BUILD_ROOT/usr/bin/windowmaker
cd WindowMaker-extra-0.1
make DESTDIR=$RPM_BUILD_ROOT install
tar xfvj %SOURCE2 -C $RPM_BUILD_ROOT/usr/share/WindowMaker/Themes/
find $RPM_BUILD_ROOT/usr/share/WindowMaker/Themes -type f -exec chmod 644 {} \;
find $RPM_BUILD_ROOT/usr/share/WindowMaker/Themes -type d -exec chmod 755 {} \;
#----------------------------------------------------------------------
# not packaged
rm -f $RPM_BUILD_ROOT/%{_mandir}/sk/man1/*
# install kdm/gdm entry
install -m 0755 -d $RPM_BUILD_ROOT/usr/share/xsessions/
install -m 0644 %SOURCE5 $RPM_BUILD_ROOT/usr/share/xsessions/
%suse_update_desktop_file $RPM_BUILD_ROOT/usr/share/xsessions/%name.desktop
cd ..
%find_lang %{name}
%find_lang WINGs %{name}.lang
%find_lang WPrefs %{name}.lang
%{__rm} -fv %{buildroot}%{_libdir}/*.la

%clean
rm -rf "$RPM_BUILD_ROOT"

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files -f %{name}.lang
%defattr(-,root,root)
%dir /etc/X11/WindowMaker
%config /etc/X11/WindowMaker/*
/usr/lib/GNUstep
/usr/bin/*
%{_libdir}/*.so.*
%{_mandir}/man1/*
/usr/share/WINGs
/usr/share/WindowMaker
/usr/share/xsessions/*
%doc AUTHORS BUGFORM BUGS COPYING COPYING.WTFPL ChangeLog FAQ FAQ.I18N
%doc MIRRORS NEWS README TODO README.SuSE
%doc menu.orig
#/usr/X11R6/share/WindowMaker
#/usr/X11R6/GNUstep

%files devel
%defattr(-,root,root)
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/*.a

%changelog
* Mon Mar 30 2009 crrodriguez@suse.de
- remove static libwraster
- remove la files
* Wed Feb 11 2009 coolo@suse.de
- ignore error about menu.orig - it's left for documentation
* Mon Oct 13 2008 nadvornik@suse.cz
- fixed composite extension usage [bnc#433808]
* Thu May 22 2008 pgajdos@suse.cz
- fixed "local variable used before set" [bnc#353376]
* Mon Apr 28 2008 ro@suse.de
- remove hermes-devel from buildreq
* Tue Mar 18 2008 nadvornik@suse.cz
- fixed a bug in findBestIcon [bnc#371974]
* Sun Mar 16 2008 crrodriguez@suse.de
- fix file-not-in-lang errors
* Wed Jan 23 2008 nadvornik@suse.cz
- fixed declaration of functions in event.c [#355254]
* Sat Mar 03 2007 aj@suse.de
- /usr/share/xsessions is now part of filesystem.
* Mon Oct 23 2006 nadvornik@suse.cz
- reverted previous change [#213889]
- added an offer to update the config files to start script
- documented the possibility of compatibility symlinks
  in README.SuSE
* Mon Oct 16 2006 lnussel@suse.de
- add compatibility symlinks /usr/X11R6/GNUstep and
  /usr/X11R6/share/WindowMaker as those directories are still
  referenced in old config files
* Thu Aug 17 2006 nadvornik@suse.cz
- changed prefix /usr/X11R6 -> /usr
* Tue Mar 14 2006 nadvornik@suse.cz
- fixed the previous change
* Thu Mar 09 2006 anicka@suse.cz
- close file descriptors before exec [#155502]
* Wed Mar 08 2006 anicka@suse.cz
- change default fonts to work with all languages [#154758]
* Tue Jan 31 2006 nadvornik@suse.cz
- fixed invalid usage of snprintf [#117663]
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Mon Nov 28 2005 nadvornik@suse.cz
- fixed color reference counting [#119439]
* Fri Oct 14 2005 nadvornik@suse.cz
- fixed another missing return value warning
* Fri Oct 07 2005 mmj@suse.de
- fix wrong printf calls
* Mon Sep 12 2005 nadvornik@suse.cz
- increased MAX_WORKSPACENAME_WIDTH because ru.po
  contains longer strings [#116475]
* Fri Jul 22 2005 nadvornik@suse.cz
- fixed fullscreen in OpenOffice.org presentations [#74375]
- fixed char comparison [#95091]
* Thu Jul 14 2005 nadvornik@suse.cz
- updated to 0.92.0:
  * added support for X Input Methods
  * improved hiding/unhiding animations to be quicker and do
  less icon shuffling
* Thu May 12 2005 nadvornik@suse.cz
- fixed bug in WINGs that caused wmaker crash [#82768]
* Wed Apr 06 2005 nadvornik@suse.cz
- fixed to compile with gcc4
- added gettext-devel to neededforbuild
* Tue Mar 22 2005 nadvornik@suse.cz
- fixed crash with KDE applications on 64bit archs [#74246]
- fixed german translation [#74254]
* Thu Feb 17 2005 nadvornik@suse.cz
- do not strip binaries
* Tue Feb 15 2005 nadvornik@suse.cz
- use the correct exec in desktop file
* Thu Feb 10 2005 adrian@suse.de
- add session desktop file
* Sat Feb 05 2005 meissner@suse.de
- fixed missing getenv prototype, added format attributes
  and fixes found by the attributes.
* Wed Jan 26 2005 nadvornik@suse.cz
- fixed 64bit bug [#50203]
* Mon Jan 17 2005 ro@suse.de
- added c++ to neededforbuild (for libtiff)
* Wed Jan 05 2005 nadvornik@suse.cz
- updated to 0.91.0:
  * NetWM support
  * UTF-8 support included upstream
  * antialiased text support included upstream
* Fri Oct 22 2004 nadvornik@suse.cz
- do not install locale files with codeset [#47262]
* Thu Oct 21 2004 ro@suse.de
- locale rename: no -> nb
* Sat Oct 02 2004 wimer@suse.de
- adding new bgs for 9.2
* Thu Apr 29 2004 nadvornik@suse.cz
- fixed high CPU load on omnipresent windows [#38570]
* Mon Apr 19 2004 nadvornik@suse.cz
- fixed missing return values
* Mon Apr 05 2004 nadvornik@suse.cz
- updated SUSE theme [#30775]
* Tue Mar 30 2004 nadvornik@suse.cz
- more fixed widget sizes in WPrefs [#35915]
* Thu Mar 18 2004 nadvornik@suse.cz
- better handling of utf8 charset
- fixed widget sizes in WPrefs (some localized texts did not fit in) [#35915]
* Thu Mar 11 2004 nadvornik@suse.cz
- better handle invalid multibyte characters [#35247]
- added README.SuSE describing the problem
* Tue Feb 03 2004 nadvornik@suse.cz
- fixed temp file handling [#34078]
- run xdg_menu on startup to cache output
- compile with -fno-strict-aliasing
* Sat Jan 10 2004 adrian@suse.de
- add %%run_ldconfig
* Tue Sep 23 2003 nadvornik@suse.cz
- fixed changing background color with wmsetbg [#31567]
* Mon Sep 22 2003 nadvornik@suse.cz
- update old SUSE theme on startup, because images from the old
  theme are no longer present
* Fri Sep 19 2003 nadvornik@suse.cz
- new SuSE theme [#30775]
* Fri Sep 12 2003 nadvornik@suse.cz
- fixed updating WMRootMenu on startup [#29508]
* Wed Sep 03 2003 nadvornik@suse.cz
- fixed workspace cycling problem [#29720]
- fixed broken exit dialog in de_DE locale [#29728]
* Mon Sep 01 2003 nadvornik@suse.cz
- fix SuSE menu location in WMRootMenu on startup
* Wed Aug 27 2003 nadvornik@suse.cz
- fixed focus bug [#29004]
- suse menu is cached
* Tue Aug 26 2003 ro@suse.de
- make sure iconv_menu_files is executable
* Mon Aug 25 2003 nadvornik@suse.cz
- added fix for focus flickering [#27175]
- moved config files to /etc/X11
- use xdg-menu for SuSE menu
* Mon May 26 2003 ro@suse.de
- add pkgconfig files to devel subpackage
- remove not-packaged sk man-pages from buildroot
* Tue May 06 2003 mfabian@suse.de
- another improvment to wsetfont by Gerd Knorr <kraxel@suse.de>:
  make the font size easily configurable when using Xft by
  adding a "--size" option to wsetfont.
* Tue May 06 2003 mfabian@suse.de
- update to current CVS (0.80.2.20030506)
- improve wsetfont to set AntialiasedText=YES/NO depending on
  whether the font setup is for Xft or X11 core fonts (and remove
  useless "WINGsConfiguration.antialiasedText = True;" from
  WindowMaker-useMultiByte-useXft.patch).
- set size for "LargDisplayFont" to 24 pixel in wsetfont when
  using Xft.
- add configure test to distinguish between Xft1 and Xft2
  and remove check for RENDER extension only when Xft2 is
  available.
* Mon May 05 2003 mfabian@suse.de
- WindowMaker-wsetfont.patch: use "-*-" instead of "-xftdummy-"
  in the foundry because the latest version of fontconfig now
  actually uses the foundry and inserting an dummy value doesn't
  work anymore.
- remove "fontconfig fontconfig-devel" from neededforbuild again
  and replace xf86 by x-devel-packages
* Mon Apr 28 2003 mfabian@suse.de
- update to current CVS (0.80.2.20030428)
- improved wsetfont now included upstream
- add "fontconfig fontconfig-devel" to neededforbuild,
  add config-dist.sh to remove this when building for SuSE 8.2.
- add option "--no-fonts" to setstyle when installing the
  SuSE-theme in /usr/X11R6/bin/windowmaker to avoid overwriting
  the font done by wsetfont.
* Wed Apr 23 2003 mfabian@suse.de
- update to current CVS (0.80.2.20030423)
- improve "wsetfont" to make it work on FreeBSD as well
- remove: WindowMaker-nls.patch,
  WindowMaker-plmenu.zh_TW.Big5.patch (included upstream)
- remove Vladimir's WindowMaker-LocMenu.patch, a similar fix
  is now included upstream
* Thu Apr 17 2003 mfabian@suse.de
- disable use of assembler mmx stuff because it makes WindowMaker
  crash immediately. This assembler code was recently introduced
  in CVS, but apparently it doesn't work yet.
* Wed Apr 16 2003 mfabian@suse.de
- update to current CVS (0.80.2.20030415) and adapt patches
- add "freetype2 freetype2-devel expat" to neededforbuild to enable
  Xft.
- WindowMaker-useMultiByte-useXft.patch: enable Xft always
  even when there is no RENDER extension, improve fallback font
  settings, call "wsetfont --sans" in wmaker.inst to get reasonable
  default font settings for Xft.
- WindowMaker-wsetfont.patch: extend to support useful font
  settings for Xft. Also include  Support for CP1251
  (Bulgarian and Belarussian) and ISO 8859-5 (Macedonian,
  Cyrillic Serbian) by Anton Zinoviev <zinoviev@debian.org>
* Wed Mar 12 2003 nadvornik@suse.cz
- fixed bug in opening localized menu [#25144]
* Mon Mar 03 2003 nadvornik@suse.cz
- use GNUSTEP_USER_ROOT in windowmaker script [#24418]
* Fri Dec 20 2002 mfabian@suse.de
- update to 0.80.2
- remove WindowMaker-overflow.patch (included upstream)
- remove obsolete configure option --enable-kanji
- add WindowMaker-fontmatching.patch to improve fontset guessing
- improve wsetfont:
  add fontsets: latin9, turkish, efontuni, gnuuni, generic
  add LargeDisplayFont to the lists of fontsets changed by wsetfont
  improve behaviour of '--auto and --locale' switch by using
  'locale charmap' to find out which fontset is suitable.
- add iconv_menu_files script to generate UTF-8 encoded menu files
- fix syntax error in plmenu.zh_TW.Big5
- patch plmenu.ja the same way the other plmenu.* files
  are patched
* Tue Nov 12 2002 nadvornik@suse.cz
- fixed overflow in RCreateImage()
* Tue Jul 02 2002 nadvornik@suse.cz
- updated to 0.80.1: bugfix release
* Wed Apr 24 2002 nadvornik@suse.cz
- used macro %%{_lib}
* Fri Feb 22 2002 nadvornik@suse.cz
- fixed file permissions
* Fri Feb 22 2002 nadvornik@suse.cz
- replaced /home/mawa with $HOME in german menu
* Fri Feb 22 2002 adrian@suse.de
- add SuSE default theme by Ken
- change behaviour of LMB on background (menu instead of selection)
* Mon Feb 18 2002 nadvornik@suse.cz
- added bugfixes from CVS:
  - fixed crash when setting "Emulate AppIcon" [bug #13380]
  - fixed problem with saving session when shared appicon is enabled
  - fixed focus related problems
  - fixes for multihead systems
* Thu Feb 14 2002 nadvornik@suse.cz
- set MultiByteText to yes in WMGLOBAL
* Fri Feb 01 2002 ro@suse.de
- changed neededforbuild <libpng> to <libpng-devel-packages>
* Tue Jan 08 2002 nadvornik@suse.cz
- updated to 0.80.0
    - shared appicons between applications of the same class
    - Dock/Clip can steal appicons of applications started by other
  means (main menu, terminal) and attach them
    - many bugs fixed
* Fri Nov 16 2001 nadvornik@suse.cz
- set MultiByteText to yes by default
* Mon Oct 08 2001 nadvornik@suse.cz
- updated to 0.70.0
  libPropList is no longer required
  many bugs fixed
* Sun Sep 16 2001 mfabian@suse.de
- fix wsetfont script for Japanese and Korean
* Thu Jul 26 2001 nadvornik@suse.cz
- update to 0.65.1
* Wed Jun 06 2001 nadvornik@suse.cz
- updated to 0.65.0
- compiled with hermes
* Thu Apr 26 2001 nadvornik@suse.cz
- fixed problems with saving icons
* Tue Apr 24 2001 nadvornik@suse.cz
- fixed segfault in WPrefs
* Thu Apr 19 2001 nadvornik@suse.cz
- fixes for ia64
* Fri Apr 06 2001 nadvornik@suse.cz
- better integration of menus generated by susewm
* Thu Mar 29 2001 nadvornik@suse.cz
- fixed bug in keyboard handling
- used RPM_OPT_FLAGS
* Tue Mar 13 2001 nadvornik@suse.cz
- created devel subpackage
* Mon Feb 26 2001 nadvornik@suse.cz
- update to 0.64.0
* Fri Jan 26 2001 nadvornik@suse.cz
- update to 0.63.1
* Fri Dec 15 2000 nadvornik@suse.cz
- added paths for package icons
* Thu Nov 23 2000 nadvornik@suse.cz
- added Provides: wmaker windowmanager
- removed Requires: wterm
* Wed Nov 15 2000 ro@suse.de
- fixed neededforbuild for libPropList
* Wed Nov 01 2000 egger@suse.de
- Updated specfile to new long packagenames.
- Reworked specfile.
- Probably needs some more work; I'm taking care of that.
* Tue Oct 10 2000 nadvornik@suse.cz
- fixed list of doc files
* Mon Oct 02 2000 nadvornik@suse.cz
- fixed start script
- used bzip2
* Mon Aug 14 2000 nadvornik@suse.cz
- fixed bug in shutdown.c
* Fri Aug 11 2000 nadvornik@suse.cz
- fixed bug in menu.c
* Thu Jul 27 2000 nadvornik@suse.cz
- "EXEC SAVE_WORKSPACE" replaced with "SAVE_SESSION" in menu
  (bug #3640)
* Tue May 09 2000 nadvornik@suse.cz
- update to 0.62.1
* Wed May 03 2000 nadvornik@suse.cz
- build with i18n support
* Fri Apr 21 2000 nadvornik@suse.cz
- added BuildRoot
* Mon Apr 10 2000 bk@suse.de
- added suse update config macro
* Wed Mar 01 2000 choeger@suse.de
- added mandir
* Tue Feb 29 2000 choeger@suse.de
- added wterm to requires
* Mon Oct 25 1999 ro@suse.de
- switched to libungif
* Tue Oct 19 1999 choeger@suse.de
- new version, 0.61.1
* Tue Sep 28 1999 choeger@suse.de
- added KDE-Support
* Thu Sep 23 1999 choeger@suse.de
- new version
* Mon Sep 20 1999 ro@suse.de
- added provides windowmanager
* Tue Sep 14 1999 ro@suse.de
- finally removed libproplist-files from filelist
* Mon Sep 13 1999 bs@suse.de
- ran old prepare_spec on spec file to switch to new prepare_spec.
* Thu Aug 19 1999 choeger@suse.de
- removed proplist from source archives and
  using the already present version of SuSE Dist.
* Fri Jul 16 1999 choeger@suse.de
- add script windowmaker
- changed wmaker.inst not to touch .xinitrc
* Tue Jul 06 1999 choeger@suse.de
- added GNOME-Support (--enable-gnome)
* Wed Apr 28 1999 choeger@suse.de
- new version 0.53.0
* Tue Mar 23 1999 choeger@suse.de
- bugfix for spec-file (make clean in the Default-Config-Dir)
* Thu Mar 11 1999 choeger@suse.de
- new version 0.51.1
* Tue Jan 19 1999 choeger@suse.de
- actual version 0.50.2
* Mon Dec 21 1998 choeger@suse.de
- actual version 0.20.3
* Thu Jul 09 1998 ro@suse.de
- removed doc/libproplist/COPYING.LIB (simply doesn't exist)
* Wed Jul 01 1998 maddin@suse.de
- first S.u.S.E. version 0.15.1
- changed configure so it works right for libPropList
- moved documentation
- /usr/X11R6/lib/X11/WindowMaker used as wm's home
- made wrapper script for wmaker, called windowmaker so user's
  files are updated correctly
openSUSE Build Service is sponsored by