File libdb_java-4_5.spec of Package libdb-4_5

#
# spec file for package libdb_java-4_5 (Version 4.5.20)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           libdb_java-4_5
BuildRequires:  java-sdk >= 1.5 unzip update-alternatives
%define         generic_name db
%define         docdir %{_defaultdocdir}/%{name}
%define         source_dir %{_datadir}/%{name}-source
Version:        4.5.20
Release:        135
%define         major 4
%define         minor 5
Summary:        Java Bindings for the Berkeley DB
Source:         db-%{version}.tar.bz2
Url:            http://www.sleepycat.com/products/xml.shtml
Patch0:         patch.%{version}.1
Patch1:         patch.%{version}.2
Patch2:         db-%{version}.dif
License:        BSD 3-clause (or similar)
Group:          Productivity/Databases/Servers
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Prefix:         %{_prefix}
Requires:       libdb-%{major}_%{minor} = %{version}
Provides:       db-java = %{version}

%description
These are the Java bindings for the Berkeley DB. They are needed for
the Java support of db and dbxml.



Authors:
--------
    Sleepycat

%package        devel
License:        BSD 3-clause (or similar)
Summary:        Java Bindings for the Berkeley DB
Group:          Productivity/Databases/Servers
Prefix:         %{_prefix}
Requires:       glibc-devel
Requires:       %{name} = %{version} 
Provides:       db-java-devel = %{version}

%description    devel
These are the Java bindings for the Berkeley DB. They are needed for
the Java support of db and dbxml.

These are the development files.



Authors:
--------
    Sleepycat

%prep 
%setup -q -n %{generic_name}-%{version}
%patch0
%patch1
%patch2
cd ..
tar -jcf %{generic_name}-%{version}.tar.bz2 %{generic_name}-%{version}

%build
cd dist
./s_config
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
CC=gcc
export CFLAGS CXXFLAGS CC
#
# Build now the NPTL version
#
mkdir ../build_nptl
cd ../build_nptl
../dist/configure  \
        --libdir=%{_libdir} --enable-compat185 --disable-dump185 \
        --enable-java --enable-shared --enable-static --enable-rpc --disable-cxx \
       	--with-mutex="POSIX/pthreads/library" JAVACFLAGS="-source 1.4 -target 1.4"\
        %{_target_cpu}-suse-linux
# Make sure O_DIRECT is really disabled (build host could have old kernel)
perl -pi -e 's/#define HAVE_O_DIRECT 1/#undef HAVE_O_DIRECT/' db_config.h
# Remove libtool predep_objects and postdep_objects wonkiness
perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
perl -pi -e 's/-shared -nostdlib/-shared/' libtool
make LIBSO_LIBS='$(LIBS)' LIBXSO_LIBS='$(LIBS)'" -L%{_libdir} -lstdc++"

%install
mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
#mkdir -p ${RPM_BUILD_ROOT}% {source_dir}/
#
#cp % {_builddir}/% {generic_name}-% {version}.tar.bz2 ${RPM_BUILD_ROOT}% {source_dir}/
#mkdir -p $RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source
#cat >>$RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source/README<<EOF
#The patches in this directory were applied to the sources.
#The sources were installed to:
#% {source_dir}/% {generic_name}-% {version}.tar.bz2
#EOF
CONFIG_ARGS=$(find . -name "config.log" -exec grep "\$ \.\./dist\/configure" {} \; | sed 's/.*configure\( --.*\)/\1/g')
if [ -z "$CONFIG_ARGS" ]
then
  echo "could not find configure arguments ... exiting"
  exit 42
fi
#echo $CONFIG_ARGS >> $RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source/configure_args.txt
#cp % {_sourcedir}/*patch* $RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source || true
#cp % {_sourcedir}/*.dif*  $RPM_BUILD_ROOT/% {_defaultdocdir}/% {name}-source || true
#
mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}
cd build_nptl
make prefix=${RPM_BUILD_ROOT}%{_prefix} libdir=${RPM_BUILD_ROOT}%{_libdir} strip=true install
cd ..
# make ldd happy:
chmod 755 $RPM_BUILD_ROOT%{_libdir}/libdb*.so
# Fix header file installation
mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4
echo "#include <db4/db.h>" > ${RPM_BUILD_ROOT}%{_includedir}/db.h
echo "#include <db4/db_185.h>" > ${RPM_BUILD_ROOT}%{_includedir}/db_185.h
rm -f ${RPM_BUILD_ROOT}%{_includedir}/db4/db_cxx.h
# remove dangling tags symlink from examples.
rm -f examples_cxx/tags
rm -f examples_c/tags
# Move documentation to the right directory
mkdir -p $RPM_BUILD_ROOT%{docdir}
mv $RPM_BUILD_ROOT%{_prefix}/docs/* $RPM_BUILD_ROOT/%{docdir}
cp -a examples_cxx examples_c $RPM_BUILD_ROOT/%{docdir}
cp -a LICENSE README $RPM_BUILD_ROOT/%{docdir}
#
# Remove api documentation for Java and TCL
rm -rf $RPM_BUILD_ROOT/%{docdir}/java
rm -rf $RPM_BUILD_ROOT/%{docdir}/api_java
rm -rf $RPM_BUILD_ROOT/%{docdir}/api_tcl
mv $RPM_BUILD_ROOT/%{docdir}/collections/tutorial $RPM_BUILD_ROOT/%{docdir}/
# Remove crappy *.la files
rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
rm -rf $RPM_BUILD_ROOT%{_libdir}/tls/*.la
pushd $RPM_BUILD_ROOT
for file in `find | grep  -v "\(java\|jar\)"`; 
do 
  rm $file || true; 
done
rm -rf $RPM_BUILD_ROOT/%{_defaultdocdir}
mkdir -p $RPM_BUILD_ROOT/%{_javadir}
mv $RPM_BUILD_ROOT/%{_libdir}/*.jar $RPM_BUILD_ROOT/%{_javadir}/db-%{version}.jar
ln -sf %{_javadir}/db-%{version}.jar $RPM_BUILD_ROOT/%{_javadir}/db.jar
find . -type d -exec rmdir {} \; || true    
find . -type d -exec rmdir {} \; || true
find . -type d -exec rmdir {} \; || true
find . -type d -exec rmdir {} \; || true

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%clean
rm -rf ${RPM_BUILD_ROOT}

%files 
%defattr(-,root,root)
%{_javadir}/*
%{_libdir}/libdb_java-%{major}.%{minor}.so

%files devel
%defattr(-,root,root)
%{_libdir}/*_g.so
%{_libdir}/*-%{major}.so
%{_libdir}/*.a
%{_libdir}/libdb_java.so

%changelog
openSUSE Build Service is sponsored by