File perl-Sub-Name.spec of Package perl-Sub-Name

#
# spec file for package perl-Sub-Name (Version 0.04)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           perl-Sub-Name
%define cpan_name %( echo %{name} | %{__sed} -e 's,perl-,,' )
Summary:        Do (re)name a sub
Version:        0.04
Release:        1
License:        Artistic License ..
Group:          Development/Libraries/Perl
Url:            http://search.cpan.org/dist/Sub-Name
Source:         %{cpan_name}-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
# other not perl || perl-base
#BuildRequires:  perl(Test::Pod) >= 1.14
#BuildRequires:  perl(Test::Pod::Coverage) >= 1.06
Requires:       perl = %{perl_version}

%description
This module has only one function, which is also exported by default:

  subname NAME, CODEREF
    Assigns a new name to referenced sub. If package specification is
    omitted in the name, then the current package is used. The return value
    is the sub.

    The name is only used for informative routines (caller, Carp, etc). You
    won't be able to actually invoke the sub by the given name. To allow
    that, you need to do glob-assignment yourself.

    Note that for anonymous closures (subs that reference lexicals declared
    outside the sub itself) you can name each instance of the closure
    differently, which can be very useful for debugging.

  Author:	Matthijs van Duin <xmath@cpan.org>
%prep
%setup -q -n %{cpan_name}-%{version}

%build
perl Makefile.PL OPTIMIZE="$RPM_OPT_FLAGS -Wall"
%{__make}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean 
%{__rm} -rf $RPM_BUILD_ROOT

%files -f %{name}.files
# normally you only need to check for doc files
%defattr(-,root,root)
%doc Changes README

%changelog
openSUSE Build Service is sponsored by