File pommed.spec of Package pommed

#
# spec file for package pommed (Version 1.27)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           pommed
Summary:        Apple laptops hotkeys event handler
License:        GPL v2 only
Group:          Hardware/Mobile
Version:        1.27
Release:        1
Url:            http://technologeek.org/projects/pommed/
%if 0
# BuildRequires some package containing /usr/include/ofapi/of_api.h
ExclusiveArch:  ppc 
%endif
ExclusiveArch:  %ix86 x86_64
BuildRequires:  alsa-devel audiofile-devel gtk2-devel libglade2-devel pciutils-devel update-desktop-files
BuildRequires:  xorg-x11-libX11-devel xorg-x11-libXext-devel xorg-x11-libXpm-devel xorg-x11-util-devel
BuildRequires:  dbus-1-glib-devel libconfuse-devel xorg-x11
%if 0%{?suse_version} > 1020
BuildRequires:  fdupes
%endif
PreReq:         %insserv_prereq %fillup_prereq 
Requires:       eject xorg-x11
Source0:        %name-%version.tar.bz2
Source1:        pommed.init
Source2:        gpomme.desktop
Source3:        gpommerc
Source4:        pommed-README.SuSE
Source5:        pommed-rpmlintrc
Patch1:         pommed-desktop.patch
Patch2:         pommed-hardcoded_libpci.patch
Patch3:         pommed-optflags.patch
Patch4:         pommed-dbus_policy.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
pommed handles the hotkeys found on the Apple MacBook Pro, MacBook and
PowerBook laptops and adjusts the LCD backlight, sound volume, keyboard
backlight or ejects the CD-ROM drive accordingly.

pommed also monitors the ambient light sensors to automatically light
up the keyboard backlight on the MacBook Pro and PowerBook.

Optional support for the Apple Remote control is available.



Authors:
--------
    Julien BLACHE <jb@jblache.org>

%package -n gpomme
License:        GPL v2 only
Summary:        Graphical client for pommed
Group:          Hardware/Mobile
Requires:       pommed
Requires:       dbus-1

%description -n gpomme
pommed handles the hotkeys found on the Apple MacBook Pro, MacBook and
PowerBook laptops and adjusts the LCD backlight, sound volume, keyboard
backlight or ejects the CD-ROM drive accordingly.

gpomme is a graphical client for pommed. It listens for signals sent by
pommed on DBus and displays the action taken by pommed along with the
current state associated to this action.



Authors:
--------
    Julien BLACHE <jb@jblache.org>

%package -n wmpomme
License:        GPL v2 only
Summary:        WindowMaker dockapp client for pommed
Group:          Hardware/Mobile
Requires:       pommed
Requires:       dbus-1

%description -n wmpomme
pommed handles the hotkeys found on the Apple MacBook Pro, MacBook and
PowerBook laptops and adjusts the LCD backlight, sound volume, keyboard
backlight or ejects the CD-ROM drive accordingly.

wmpomme is a dockapp client for pommed. It displays the current level
of each item controlled by pommed.



Authors:
--------
    Julien BLACHE <jb@jblache.org>

%prep
%setup -q
%patch1
%patch2
%patch3
%patch4

%build
# This package failed when testing with -Wl,-as-needed being default.
# So we disable it here, if you want to retest, just delete this comment and the line below.
export SUSE_ASNEEDED=0
export CFLAGS="$RPM_OPT_FLAGS"
make %{?jobs:-j%jobs}

%install
mkdir -p %buildroot/%_bindir %buildroot/%_sbindir %buildroot/%_sysconfdir/{init.d,dbus-1/system.d} 
mkdir -p %buildroot/%_datadir/{applications,autostart,icons,pixmaps,gpomme,locale} 
mkdir -p %buildroot/%_mandir/man1 %buildroot/%_datadir/kde4/config
install -m 755 pommed/pommed          %buildroot/%_sbindir
install -m644 %{SOURCE4} README.SuSE
%ifarch ppc ppc64
install -m 644 pommed.conf.pmac       %buildroot/%_sysconfdir/pommed.conf
%else
install -m 644 pommed.conf.mactel     %buildroot/%_sysconfdir/pommed.conf
%endif
install -m 644 dbus-policy.conf       %buildroot/%_sysconfdir/dbus-1/system.d/pommed.conf
install -m 755 %{S:1}                 %buildroot/%_sysconfdir/init.d/pommed
ln -sf %_sysconfdir/init.d/pommed %buildroot/%_sbindir/rcpommed
install -m 644 pommed.1               %buildroot/%_mandir/man1
# gpomme
install -m 755 gpomme/gpomme          %buildroot/%_bindir
install -m 644 gpomme/gpomme.1        %buildroot/%_mandir/man1
install -m 644 gpomme/*.desktop       %buildroot/%_datadir/applications
install -m 644 icons/gpomme*          %buildroot/%_datadir/icons
install -m 644 icons/gpomme_32x32.xpm %buildroot/%_datadir/pixmaps/gpomme.xpm
install -m 644 gpomme/gpomme.glade    %buildroot/%_datadir/gpomme
cp -a gpomme/themes                   %buildroot/%_datadir/gpomme
rm -rfv %buildroot/%_datadir/gpomme/themes/src
for mo in gpomme/po/*.mo ; do
    lang=`basename $mo .mo`
    filename="gpomme.mo"
    install -d %buildroot/%_datadir/locale/$lang/LC_MESSAGES
    install -m 644 $mo %buildroot/%_datadir/locale/$lang/LC_MESSAGES/$filename
done
install -m 644 %{S:2} %buildroot/%_datadir/autostart
install -m 644 %{S:3} %buildroot/%_datadir/kde4/config
# wmpomme
install -m 755 wmpomme/wmpomme        %buildroot/%_bindir
install -m 644 wmpomme/wmpomme.1      %buildroot/%_mandir/man1
%suse_update_desktop_file %buildroot/%_datadir/applications/gpomme-c.desktop
%suse_update_desktop_file %buildroot/%_datadir/applications/gpomme.desktop
# enable videoswitch
mkdir -p %buildroot/%_sysconfdir/pommed
%if 0%{?suse_version} > 1020
%fdupes -s %buildroot
%endif
install -m 644 icons/gpomme_32x32.xpm %buildroot/%_datadir/icons/wmpomme.xpm
install -m 644 icons/gpomme_32x32.xpm %buildroot/%_datadir/pixmaps/gpomme.xpm
%find_lang gpomme

%post
%{fillup_and_insserv -n %name %name}

%preun
%stop_on_removal %name

%postun
%restart_on_update %name
%{insserv_cleanup}

%clean
rm -rf %buildroot

%files
%defattr(-,root,root)
%doc AUTHORS README TODO README.SuSE
%config(noreplace) /etc/pommed.conf
%config(noreplace) /etc/dbus-1/system.d/pommed.conf
%_sysconfdir/init.d/pommed
%_sbindir/pommed
%_sbindir/rcpommed
%_mandir/man1/po*

%files -n gpomme -f gpomme.lang
%defattr(-,root,root)
%_bindir/gpomme
%_datadir/applications/*.desktop
%_datadir/icons/gp*
%_datadir/pixmaps/gp*
%_datadir/gpomme
%_datadir/autostart
%dir %_datadir/kde4
%_datadir/kde4/config
%_mandir/man1/gpo*

%files -n wmpomme
%defattr(-,root,root)
%_bindir/wmpomme
%_datadir/icons/wm*
%_mandir/man1/wmpo*

%changelog
openSUSE Build Service is sponsored by