File libsigc++12.spec of Package libsigc++12

#
# spec file for package libsigc++12 (Version 1.2.7)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           libsigc++12
BuildRequires:  gcc-c++
%define _name libsigc++
Version:        1.2.7
Release:        142
Group:          Development/Libraries/C and C++
License:        LGPL v2.1 or later
Summary:        Typesafe Signal Framework for C++
Url:            http://libsigc.sourceforge.net/
Source:         ftp://ftp.gnome.org/pub/GNOME/sources/%{_name}/1.2/%{_name}-%{version}.tar.bz2
Patch1:         configure.in.diff
Patch4:         examples.diff
Patch5:         makefile.diff
# PATCH-FIX-UPSTREAM libsigc++12-automake1.11.patch vuntz@novell.com -- (no bug since not actively maintained upstream) Fix build with automake 1.11
Patch6:         libsigc++12-automake1.11.patch
AutoReqProv:    on
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
This library implements a full callback system for use in widget
libraries, abstract interfaces, and general programming. It is the most
complete library of its kind with the ability to connect an abstract
callback to a class method, function, or function object. It contains
adaptor classes for connection of dissimilar callbacks and has an ease
of use unmatched by other C++ callback libraries.



Authors:
--------
    Karl E. Nelson <kenelson@ece.ucdavis.edu>

%package devel
License:        LGPL v2.1 or later
Group:          Development/Libraries/C and C++
Summary:        Typesafe Signal Framework for C++
Requires:       %{name} = %{version} libstdc++-devel pkgconfig

%description devel
This library implements a full callback system for use in widget
libraries, abstract interfaces, and general programming. It is the most
complete library of its kind with the ability to connect an abstract
callback to a class method, function, or function object. It contains
adaptor classes for connection of dissimilar callbacks and has an ease
of use unmatched by other C++ callback libraries.



Authors:
--------
    Karl E. Nelson <kenelson@ece.ucdavis.edu>

%prep
%setup -q -n %{_name}-%{version}
%patch1
%patch4
%patch5
%patch6 -p1

%build
autoreconf --force --install
%configure --disable-static --with-pic
%{__make} %{?jobs:-j%jobs}

%install
make DESTDIR=$RPM_BUILD_ROOT install
mkdir -p $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}
cp AUTHORS COPYING COPYING.LIB ChangeLog FEATURES IDEAS NEWS README TODO $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}
mkdir -p $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/examples
cp examples/{Makefile,*.cc,*.m4} $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/examples
mkdir -p $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/tests
cp tests/{Makefile,README,*.cc} $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}/tests
%{__rm} -f %{buildroot}%{_libdir}/*.la

%check
%{__make} %{?jobs:-j%jobs} check

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files
%defattr (-, root, root)
%doc %dir %{_defaultdocdir}/%{name}
%doc %{_defaultdocdir}/%{name}/AUTHORS
%doc %{_defaultdocdir}/%{name}/COPYING
%doc %{_defaultdocdir}/%{name}/COPYING.LIB
%doc %{_defaultdocdir}/%{name}/ChangeLog
%doc %{_defaultdocdir}/%{name}/FEATURES
%doc %{_defaultdocdir}/%{name}/IDEAS
%doc %{_defaultdocdir}/%{name}/NEWS
%doc %{_defaultdocdir}/%{name}/README
%doc %{_defaultdocdir}/%{name}/TODO
%{_libdir}/*.so.*

%files devel
%defattr (-, root, root)
%doc %{_defaultdocdir}/%{name}/examples
%doc %{_defaultdocdir}/%{name}/tests
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_libdir}/sigc++-1.2
%{_prefix}/include/*

%changelog
openSUSE Build Service is sponsored by