File valgrind.spec of Package valgrind

#
# spec file for package valgrind (Version 3.5.0)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           valgrind
BuildRequires:  gcc-c++ glibc-devel-32bit xorg-x11-devel
%ifarch x86_64 ppc64
BuildRequires:  gcc-32bit
%endif
Url:            http://valgrind.org/
License:        GPLv2
Group:          Development/Tools/Debuggers
Summary:        Valgrind Suite of Tools for Debugging and Profiling
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Version:        3.5.0
Release:        2.<RELEASE2>
Source0:        %{name}-%{version}.tar.bz2
# svn  di svn://svn.valgrind.org/valgrind/tags/VALGRIND_3_2_1 svn://svn.valgrind.org/valgrind/branches/VALGRIND_3_2_BRANCH > 3_2_BRANCH.diff
# svn  di svn://svn.valgrind.org/vex/tags/VEX_3_2_1 svn://svn.valgrind.org/vex/branches/VEX_3_2_BRANCH > VEX_3_2_BRANCH.diff
Patch1:         jit-register-unregister.diff
Patch2:         deprecated.diff
Patch3:         glibc-211.diff
Patch4:         bnc558964.diff
Patch5:         prefer-cfi.diff
Provides:       callgrind = %version
Obsoletes:      callgrind < %version
ExclusiveArch:  %ix86 x86_64 ppc ppc64

%description
Valgrind checks all memory operations in an application, like read,
write, malloc, new, free, and delete. Valgrind can find uses of
uninitialized memory, access to already freed memory, overflows,
illegal heap operations, memory leaks, and any illegal
new/malloc/free/delete commands. Another program in the package is
"cachegrind," a profiler based on the valgrind engine. It is plugin
based and many different tools are available.

To use valgrind you should launch the application like normal with
debuginfo packages installed, for example:


_memcheck --leak-check_


More valgrind options can be listed via "valgrind --help". There is
also complete documentation in the /usr/share/doc/packages/valgrind/
directory. A debugged application runs slower and needs much more
memory, but is usually still usable.



Authors:
--------
    Julian Seward <jseward@acm.org>
    Cerion Armour-Brown
    Jeremy Fitzhardinge
    Tom Hughes
    Nicholas Nethercote
    Paul Mackerras
    Dirk Mueller
    Robert Walsh

%package devel
License:        GPLv2+
Summary:        Valgrind Suite of Tools for Debugging and Profiling
Group:          Development/Tools/Debuggers
Requires:       %name = %version

%description devel
Valgrind checks all memory operations in an application, like read,
write, malloc, new, free, and delete. Valgrind can find uses of
uninitialized memory, access to already freed memory, overflows,
illegal heap operations, memory leaks, and any illegal
new/malloc/free/delete commands. Another program in the package is
"cachegrind," a profiler based on the valgrind engine. It is plugin
based and many different tools are available.

To use valgrind you should launch the application like normal with
debuginfo packages installed, for example:


_memcheck --leak-check_


More valgrind options can be listed via "valgrind --help". There is
also complete documentation in the /usr/share/doc/packages/valgrind/
directory. A debugged application runs slower and needs much more
memory, but is usually still usable.



Authors:
--------
    Julian Seward <jseward@acm.org>
    Cerion Armour-Brown
    Jeremy Fitzhardinge
    Tom Hughes
    Nicholas Nethercote
    Paul Mackerras
    Dirk Mueller
    Robert Walsh

%prep
%setup -q -n %{name}-%{version}
cd VEX
cd ..
%patch1
%patch2
%patch3
%patch4
%if %suse_version >= 1120
%patch5
%endif

%build
export CFLAGS="$RPM_OPT_FLAGS"
export CXXFLAGS="$RPM_OPT_FLAGS"
autoreconf -fi
export GDB=/usr/bin/gdb
%configure
make %{?jobs:-j%jobs}

%install
make DESTDIR=$RPM_BUILD_ROOT install
mkdir -p $RPM_BUILD_ROOT/usr/share/doc/packages
mv $RPM_BUILD_ROOT/usr/share/doc/valgrind $RPM_BUILD_ROOT/usr/share/doc/packages

%files
%defattr(-,root,root)
%doc README* NEWS AUTHORS COPYING COPYING.DOCS
/usr/bin/*
%_libdir/valgrind
%doc %_mandir/*/*

%files devel
%defattr(-,root,root)
/usr/include/valgrind
/usr/%_lib/pkgconfig/valgrind.pc

%changelog
openSUSE Build Service is sponsored by