File pauker.spec of Package pauker

#
# spec file for package pauker
#
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

# norootforbuild

Name:           pauker
Summary:        Pauker is a generic flashcard program for learning vocabularies
Version:        1.8
Release:        1
License:        GPL
Url:            http://pauker.sourceforge.net/
Group:          Productivity/Other
#BuildRequires:  unzip
#BuildRequires:  ant
#BuildRequires:  java-devel
%if 0%{?suse_version}
BuildRequires:  update-desktop-files 
%endif
Requires:       java >= 1.5.0
Requires:       jpackage-utils >= 1.5
BuildArch:      noarch
Vendor:         openSUSE-Education
#Source0:        %{name}-%{version}.src.jar
Source0:        %{name}-%{version}.jar
Source1:        pauker.png
Source2:        pauker.desktop
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%define         installpath %{_datadir}/java/%{name}

%description
 Pauker is a
    * completely free (OpenSource, GPL)
    * flash card based,
    * learning application
    * written in Java
    * using the leitner cardfile system
    * available in Dutch, English, Esperanto, German, French and Polish
    * works offline without the need of an internet connection
    * and is compatible with MiniPauker, a Pauker version for PDA's and mobile phones.


Authors:
-------
    Ronny Standtke
    Axel Kittenberger - Website and more
    Markus Brosch - Searching for similar cards, MiniPauker
    Kay Patzwald - RPM package


%prep
%setup -q -T -c %name
## %setup -q -T -c %name-%version -a0

%build
##%ant -Dplatforms.JDK_1.5.home=/etc/alternatives/java_sdk jar 

%install
%if 0%{?suse_version}
export NO_BRP_CHECK_BYTECODE_VERSION="true"
%endif
mkdir -p %buildroot/%installpath
mkdir -p %buildroot/%_bindir
install -m644 %SOURCE0 %buildroot/%installpath/
install -D -m644 %SOURCE1 %buildroot/%_datadir/pixmaps/pauker.png
install -D -m644 %SOURCE2 %buildroot/%_datadir/applications/pauker.desktop

# startscript
cat > pauker.sh <<EOF
#! /bin/bash
java -jar %installpath/%{name}-%{version}.jar
EOF
install -m 755 pauker.sh %buildroot/%_bindir/
%if 0%{?suse_version}
%suse_update_desktop_file -i -n -r pauker Education Languages
%endif

%clean
rm -rf %buildroot

%files
%defattr(-,root,root)
%attr(755,root,root)  %{_bindir}/%name.sh
%dir %{installpath}
%{installpath}/%{name}*.jar
%_datadir/applications/%{name}.desktop
%_datadir/pixmaps/pauker.png

%changelog
openSUSE Build Service is sponsored by