File kate.spec of Package kate
#
# spec file for package kate
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_without lang
%define _appstreamkpackage 0%(cat %{_kf5_cmakedir}/KF5Package/KF5PackageMacros.cmake | grep -q 'appstream-metainfo' && echo 1)
Name: kate
Version: 18.04.3
Release: 0
%define kf5_version 5.26.0
# Latest stable Applications (e.g. 17.08 in KA, but 17.11.80 in KUA)
%{!?_kapp_version: %global _kapp_version %(echo %{version}| awk -F. '{print $1"."$2}')}
Summary: Advanced Text Editor
License: GPL-2.0+
Group: Productivity/Text/Editors
Url: http://www.kde.org
Source0: %{name}-%{version}.tar.xz
# PATCH-FIX-OPENSUSE
Patch0: 0001-Defuse-root-block.patch
BuildRequires: kactivities5-devel
BuildRequires: kconfig-devel
BuildRequires: kcrash-devel
BuildRequires: kdbusaddons-devel
BuildRequires: kdoctools-devel
BuildRequires: kguiaddons-devel
BuildRequires: ki18n-devel
BuildRequires: kiconthemes-devel
BuildRequires: kio-devel
BuildRequires: kitemmodels-devel
BuildRequires: kjobwidgets-devel
BuildRequires: knewstuff-devel
BuildRequires: kparts-devel
BuildRequires: kservice-devel
BuildRequires: ktexteditor-devel
BuildRequires: kwallet-framework-devel
BuildRequires: kwindowsystem-devel
BuildRequires: kxmlgui-devel
BuildRequires: libgit2-devel
BuildRequires: pkgconfig
BuildRequires: plasma-framework-devel
BuildRequires: threadweaver-devel
BuildRequires: pkgconfig(Qt5Core) >= 5.4.0
BuildRequires: pkgconfig(Qt5DBus) >= 5.4.0
BuildRequires: pkgconfig(Qt5Script) >= 5.4.0
BuildRequires: pkgconfig(Qt5Sql) >= 5.4.0
BuildRequires: pkgconfig(Qt5Test) >= 5.4.0
BuildRequires: pkgconfig(Qt5Widgets) >= 5.4.0
Requires: %{name}-plugins = %{version}
Obsoletes: %{name}5 < %{version}
Provides: %{name}5 = %{version}
%if %{with lang}
Recommends: %{name}-lang
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Kate is an advanced text editor for KDE.
%package -n kwrite
Summary: KDE Text Editor
Group: Productivity/Text/Editors
Requires: %{name}-plugins = %{version}
Obsoletes: kwrite5 < %{version}
%description -n kwrite
KWrite is the default text editor of the K desktop environment.
%package plugins
Summary: KDE Text Editor plugins
Group: Productivity/Text/Editors
Obsoletes: kate5-plugins < %{version}
Provides: ktexteditorpreviewplugin = %{version}
Obsoletes: ktexteditorpreviewplugin < %{version}
%description plugins
Kate is an advanced text editor for KDE. This package contains
plugins and data files for Kate and KWrite editors.
%if %{with lang}
%package lang
Summary: Translations for package %{name}
Group: System/Localization
Requires: %{name} = %{version}
Provides: %{name}-lang-all = %{version}
Supplements: %{name}
BuildArch: noarch
Provides: ktexteditorpreviewplugin-lang = %{version}
Obsoletes: ktexteditorpreviewplugin-lang < %{version}
%description lang
Provides translations for the "%{name}" package.
%endif
%prep
%setup -q
%autopatch -p1
%build
%cmake_kf5 -d build
%make_jobs
%install
%kf5_makeinstall -C build
%if %{with lang}
%find_lang %{name} --with-man --all-name
%kf5_find_htmldocs
%endif
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc COPYING* README*
%dir %{_kf5_appstreamdir}
%dir %{_kf5_htmldir}
%dir %{_kf5_htmldir}/en
%doc %lang(en) %{_kf5_htmldir}/en/kate/
%doc %lang(en) %{_kf5_htmldir}/en/katepart/
%doc %{_kf5_mandir}/man1/kate.*
%{_kf5_applicationsdir}/org.kde.kate.desktop
%{_kf5_appstreamdir}/org.kde.kate.appdata.xml
%{_kf5_bindir}/kate
%{_kf5_iconsdir}/hicolor/*/apps/kate.*
%files -n kwrite
%defattr(-,root,root)
%doc COPYING* README*
%dir %{_kf5_htmldir}
%dir %{_kf5_htmldir}/en
%doc %lang(en) %{_kf5_htmldir}/en/kwrite/
%{_kf5_applicationsdir}/org.kde.kwrite.desktop
%{_kf5_appstreamdir}/org.kde.kwrite.appdata.xml
%{_kf5_bindir}/kwrite
%{_kf5_iconsdir}/hicolor/*/apps/kwrite.*
%files plugins
%defattr(-,root,root)
%doc COPYING* README*
%if 0%{?_appstreamkpackage}
%{_kf5_appstreamdir}/org.kde.plasma.katesessions.appdata.xml
%endif
%{_kf5_plugindir}/
%{_kf5_servicesdir}/
%{_kf5_sharedir}/kateproject/
%{_kf5_sharedir}/katexmltools/
%{_kf5_sharedir}/plasma/
%if %{with lang}
%files lang -f %{name}.lang
%doc COPYING*
%endif
%changelog