File kde3-gtk-qt-engine.spec of Package kde3-gtk-qt-engine

#
# spec file for package kde3-gtk-qt-engine (Version 0.8svn20071009)
#
# Copyright 2004-2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
# Copyright 2007 dsbhayangkara@gmail.com
# Copyright 2009 Buschmann <buschmann23@opensuse.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild

Name:           kde3-gtk-qt-engine
BuildRequires:  cmake gtk2-devel kdebase3 kdelibs3-devel kdesdk3 libbonoboui-devel
License:        GNU General Public License (GPL)
Group:          System/Libraries
Summary:        GTK-Style Engine for Use with Qt Plug-Ins and Settings
Version:        0.8svn20071009
Release:        1.1
Url:            http://gtk-qt.ecs.soton.ac.uk
Source:         gtk-qt-engine_0.8~svn-rev36.orig.tar.gz
Source1:         gtk-qt-engine-0.7-domino-scrollbar-fix.patch
#Patch:          fix-iconpaths.patch
#Patch1:         gtk-qt-engine-small-pixmaps.patch
Patch2:         mozilla-scrollbars.patch
Patch3:         hide-mozilla-groupbox.diff
#Patch4:         fix-slider.patch
#Patch5:         gtk-qt-engine-kcmgtk.desktop-icon.patch
Patch6:         fix-nspluginviewer-crash.diff
Patch7:         glib2.25-signals-conflict.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Provides:       gtk-qt-engine = 0.8svn20071009
Obsoletes:      gtk-qt-engine <= 0.8svn20071009

%description
This engine is for use by GTK applications running in KDE. It applies
all Qt settings to the GTK application and uses Qt style plug-ins
directly.



Authors:
--------
    David Sansome <me@davidsansome.com>

%define prefix /opt/kde3

%if !0%{?opensuse_bs}
%debug_package
%endif
%prep
%setup -q -n "gtk-qt-engine-%{version}"
#%patch
#%patch1 -p1
%patch2
%patch3
# This code seems to have changed, need to check if the problem reoccurs
#%patch4
#. /etc/opt/kde3/common_options
#update_admin
#%patch5
sed -i 's/Icon=gnome_apps.png/Icon=gnome_apps/g' ./kcm_gtk/kcmgtk.desktop

%patch6
%patch7 -p1
patch %{SOURCE1}

%build
export CFLAGS="$RPM_OPT_FLAGS"
export CXXFLAGS="$CFLAGS"
#mkdir build
#cd build
cmake -DCMAKE_INSTALL_PREFIX=%prefix -DCMAKE_BUILD_TYPE=debugfull .
make %{?jobs:-j %jobs}
#. /etc/opt/kde3/common_options
#./configure $configkde

%install
. /etc/opt/kde3/common_options
#cd build
make install DESTDIR=$RPM_BUILD_ROOT
# WS: what did this do?
#rm -rf $RPM_BUILD_ROOT/usr/lib
# WS: removing older version?
#rm $RPM_BUILD_ROOT/opt/gnome/%{_lib}/gtk-2.0/*/engines/libqtengine.la
# moving wrong default location?
# mkdir -p $RPM_BUILD_ROOT/opt/kde3/share/applications
#cp $RPM_BUILD_ROOT/usr/share/applications/kcmgtk-xdg.desktop $RPM_BUILD_ROOT/opt/kde3/share/applications
kde_post_install
%find_lang gtkqtengine

%clean
rm -rf $RPM_BUILD_ROOT

%files -f gtkqtengine.lang
%defattr(-,root,root)
%doc AUTHORS README NEWS COPYING ChangeLog ChangeLog-0.8
%if %suse_version >= 1030
%_libdir/gtk-*/*/engines/*
/usr/share/themes/Qt
/usr/share/themes/Qt/gtk-*
/usr/share/themes/Qt/gtk-*/gtkrc
%else
/opt/gnome/%_lib/gtk-*/*/engines/*
/opt/gnome/share/themes/Qt
/opt/gnome/share/themes/Qt/gtk-*
/opt/gnome/share/themes/Qt/gtk-*/gtkrc
%endif
/opt/kde3/share/applications/*.desktop
/opt/kde3/%_lib/kde3/kcm_kcmgtk.*

%changelog
* Tue Apr 21 2009 beineri@opensuse.org
- rename to kde3-gtk-qt-engine
* Sat Mar 14 2009 Buschmann <buschmann23@opensuse.org>
- use debug_package macro outside the Build Service
- changing obsolete suse version check
* Tue Jan 29 2008 stbinner@suse.de
- add patch from online updates to not theme/crash nspluginviewer
* Sun Apr 29 2007 dsbhayangkara@gmail.com
- Update to new svn repository:
  Changes since 0.7cvs20061120:
  * GTK apps will now respect KDE's toolbar icon display settings (thanks
  Bastian Venthur)
  * Merge fix-iconpaths.patch from suse.  This fixes icon loading issues with
  inherited icon themes.
  * Highlighted menu items are now always white.
  * Italian translation from Davide Madrisan
  * Fix button appearance in the Motif Plus style
  * Turkish translation by S.Çağlar Onur
  * Patch from Martin Michlmayr to fix compilation on GCC 4.3
  * Bulgarian translation by Zlatko Popov
  * Russian translation by Viktor Ponasenkov
* Mon Jan 08 2007 dmueller@suse.de
- typo fix
* Mon Jan 08 2007 dmueller@suse.de
- adjust paths for changed GNOME install prefix
* Mon Nov 20 2006 wstephenson@suse.de
- Update to new svn repository:
  Changes since 0.7:
  * Switch the buildsystem from autotools to CMake.  CMake 2.4 is now required
  to build the project.
  * Fix scrollbar sliders in the Domino widget style
  * Fix a bug that caused Qt colours not to be applied to GTK applications.
  This fixes several graphical problems when using dark colour schemes.
  * Fix a bug that would disable Bonobo support even when the correct packages
  were installed
  * The control center module will now write a configuration file that will
  only affect applications inside KDE.  Applications running in GNOME can be
  themed separately using the GNOME tools.
  * Add a setting for emacs keyboard shortcuts
  * Fix OpenOffice detection on Fedora Core.
  * Draw default buttons properly.
  * Provide a fallback icon even when one of the right size doesn't exist
  * Fix invalid CSS comments.
  * When the Qt theme can't be found, display a dialog allowing the user to
  modify the search paths.
  * Respect KDE's "Show icons on buttons" setting
  * Fix icon themes in GNOME apps such as evolution on Fedora Core 5 and 6
* Thu Aug 03 2006 stbinner@suse.de
- fix build
* Fri Jun 23 2006 dmueller@suse.de
- add fix for crashes with Baghira (#187765)
* Tue May 09 2006 stbinner@suse.de
- fix Firefox/Thunderbird not starting with ThinKeramik (#172681)
* Tue Mar 21 2006 llunak@suse.cz
- fix icon paths handling (#157455)
* Fri Mar 17 2006 stbinner@suse.de
- hide the obsolete Mozilla scrollbar workaroudn groupbox in kcm
* Tue Mar 14 2006 dmueller@suse.de
- updated patch by Lubos for scrollbars (#143263)
* Wed Mar 01 2006 stbinner@suse.de
- add patch to don't mess with the user's .bashrc / GTK2_RC_FILES
* Fri Feb 10 2006 llunak@suse.cz
- update from CVS
- fix slider size (#118667)
- workaround for Mozilla scrollbars (#143263)
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Mon Jan 16 2006 stbinner@suse.de
- update from CVS for more complete translations
- fix "gtk-qt-engine not in KDE control center" (#121876)
* Mon Oct 03 2005 ltinkl@suse.cz
- fix config file writing for some icon themes (e.g. iKons) (#63853)
* Fri Sep 09 2005 matz@suse.de
- Fix build on lib64 platforms.
* Wed Sep 07 2005 clahey@suse.de
- In all cases where we create a pixmap, bail if either parameter
  is less than 1.  Fixes #113936.
* Thu Aug 11 2005 clahey@suse.de
- Set a colormap on the backing pixbuf we set.
* Wed Apr 27 2005 adrian@suse.de
- fix compile with gcc 4 on 64bit
* Mon Feb 28 2005 adrian@suse.de
- update to current cvs snapshot
  * memory leak fix
* Wed Jan 05 2005 adrian@suse.de
- update to version 0.6
* Tue Nov 30 2004 adrian@suse.de
- complete last fix (#45222)
* Tue Nov 23 2004 adrian@suse.de
- crash fix by matz (#45222)
* Mon Oct 04 2004 matz@suse.de
- Fix inverted sliders and the file box of the file dialog
  (look at inverted flag of ranges and new types of rows) (#45930, #44868).
* Fri Aug 27 2004 adrian@suse.de
- disable kcm modul since it is not translated
* Mon Aug 16 2004 schwab@suse.de
- Fix last change.
* Mon Aug 16 2004 adrian@suse.de
- fix build error
* Fri Aug 13 2004 adrian@suse.de
- update to version 0.5
  * new kcm module
* Wed Feb 11 2004 adrian@suse.de
- initial packaging of version 0.3
openSUSE Build Service is sponsored by