File rubygem-sass.spec of Package rubygem-sass

#
# spec file for package rubygem-sass
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           rubygem-sass
Version:        3.2.12
Release:        0
%define mod_name sass
%define mod_full_name %{mod_name}-%{version}
%define mod_branch -%{version}
%define mod_weight 30212

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  ruby-macros >= 1
Requires:       ruby >= 1.8.7
BuildRequires:  ruby-devel >= 1.8.7
BuildRequires:  update-alternatives
Url:            http://sass-lang.com/
Source:         http://rubygems.org/gems/%{mod_full_name}.gem
Summary:        A powerful but elegant CSS compiler that makes CSS fun again
License:        MIT
Group:          Development/Languages/Ruby
PreReq:         update-alternatives

%description
Sass makes CSS fun again. Sass is an extension of CSS3, adding
nested rules, variables, mixins, selector inheritance, and more.
It's translated to well-formatted, standard CSS using the
command line tool or a web-framework plugin.

%package doc
Summary:        RDoc documentation for %{mod_name}
Group:          Development/Languages/Ruby
Requires:       %{name} = %{version}

%description doc
Documentation generated at gem installation time.
Usually in RDoc and RI formats.

%package testsuite
Summary:        Test suite for %{mod_name}
Group:          Development/Languages/Ruby
Requires:       %{name} = %{version}

%description testsuite
Test::Unit or RSpec files, useful for developers.

%prep
#gem_unpack
#if you need patches, apply them here and replace the # with a % sign in the surrounding lines
#gem_build

%build

%install
%gem_install -f
mkdir -p %{buildroot}%{_sysconfdir}/alternatives
mv %{buildroot}%{_bindir}/sass{,%{mod_branch}}
touch %{buildroot}%{_sysconfdir}/alternatives/sass
ln -s %{_sysconfdir}/alternatives/sass %{buildroot}%{_bindir}/sass

mv %{buildroot}%{_bindir}/sass-convert{,%{mod_branch}}
touch %{buildroot}%{_sysconfdir}/alternatives/sass-convert
ln -s %{_sysconfdir}/alternatives/sass-convert %{buildroot}%{_bindir}/sass-convert

mv %{buildroot}%{_bindir}/scss{,%{mod_branch}}
touch %{buildroot}%{_sysconfdir}/alternatives/scss
ln -s %{_sysconfdir}/alternatives/scss %{buildroot}%{_bindir}/scss

mkdir -p %{buildroot}%{_docdir}/%{name}
ln -s %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/README.md %buildroot/%{_docdir}/%{name}/README.md
ln -s %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/MIT-LICENSE %buildroot/%{_docdir}/%{name}/MIT-LICENSE

%post
/usr/sbin/update-alternatives --install \
    %{_bindir}/sass sass %{_bindir}/sass%{mod_branch} %{mod_weight}
/usr/sbin/update-alternatives --install \
    %{_bindir}/sass-convert sass-convert %{_bindir}/sass-convert%{mod_branch} %{mod_weight}
/usr/sbin/update-alternatives --install \
    %{_bindir}/scss scss %{_bindir}/scss%{mod_branch} %{mod_weight}

%preun
if [ "$1" = 0 ] ; then
    /usr/sbin/update-alternatives --remove sass %{_bindir}/sass%{mod_branch}
fi
if [ "$1" = 0 ] ; then
    /usr/sbin/update-alternatives --remove sass-convert %{_bindir}/sass-convert%{mod_branch}
fi
if [ "$1" = 0 ] ; then
    /usr/sbin/update-alternatives --remove scss %{_bindir}/scss%{mod_branch}
fi

%files
%defattr(-,root,root,-)
%{_docdir}/%{name}
%{_bindir}/sass%{mod_branch}
%{_bindir}/sass
%ghost %{_sysconfdir}/alternatives/sass
%{_bindir}/sass-convert%{mod_branch}
%{_bindir}/sass-convert
%ghost %{_sysconfdir}/alternatives/sass-convert
%{_bindir}/scss%{mod_branch}
%{_bindir}/scss
%ghost %{_sysconfdir}/alternatives/scss
%{_libdir}/ruby/gems/%{rb_ver}/cache/%{mod_full_name}.gem
%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/
%exclude %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/test
%{_libdir}/ruby/gems/%{rb_ver}/specifications/%{mod_full_name}.gemspec

%files doc
%defattr(-,root,root,-)
%doc %{_libdir}/ruby/gems/%{rb_ver}/doc/%{mod_full_name}/

%files testsuite
%defattr(-,root,root,-)
%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/test

%changelog
openSUSE Build Service is sponsored by