File u-boot-highbank.spec of Package u-boot-bananapi

#
# spec file for package u-boot-highbank
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2010 Texas Instruments Inc by Nishanth Menon
# Copyright (c) 2007-2010 by Silvan Calarco <silvan.calarco@mambasoft.it>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define x_loader 0
%define origen_spl 0
%define sunxi_spl 0
%define arndale_spl 0
%define cuboxi_spl 0

Name:           u-boot-highbank
Version:        2015.07
Release:        0
Summary:        The u-boot firmware for the highbank arm platform
License:        GPL-2.0
Group:          System/Boot
Url:            http://www.denx.de/wiki/U-Boot
Source:         ftp://ftp.denx.de/pub/u-boot/u-boot-%{version}.tar.bz2
Source2:        arndale-bl1.img
Source300:      u-boot-rpmlintrc
Patch1:         mx53loco-bootscr.patch
# Marvell boards support is non-free licensed, and we don't need it (bnc#773824)
Patch99:        drop-marvell.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
# Arndale board need DTC >= 1.4
BuildRequires:  bc
BuildRequires:  dtc >= 1.4.0
Provides:       u-boot-loader
Conflicts:      otherproviders(u-boot-loader)
%if %x_loader == 1
Obsoletes:      x-loader-highbank
Provides:       x-loader-highbank
%endif
ExclusiveArch:  armv7l armv7hl

%description
Das U-Boot (or just "U-Boot" for short) is Open Source Firmware for Embedded PowerPC, ARM, MIPS and x86 processors.
This package contains the firmware for the highbank arm platform.

%package doc
Summary:        Documentation for the u-boot Firmware
Group:          Documentation/Other

%description doc
Das U-Boot (or just "U-Boot" for short) is Open Source Firmware for Embedded PowerPC, ARM, MIPS and x86 processors.
This package contains documentation for u-boot firmware

%prep
%setup -q -n u-boot-%{version}
# is non-free licensed, and we don't need it (bnc#773824)
rm -rf board/Marvell
# Any custom patches to be applied on top of mainline u-boot
%patch1 -p1
%patch99 -p1

%build
make %{?jobs:-j %jobs} CFLAGS="$RPM_OPT_FLAGS" highbank_defconfig
make %{?jobs:-j %jobs} CFLAGS="$RPM_OPT_FLAGS" USE_PRIVATE_LIBGG=yes
%if "%{name}" == "u-boot-snow"
# Chromebook ARM (snow) need a uImage format
export TEXT_START=$(awk '$NF == "_start" { printf "0x"$1 }' System.map)
./tools/mkimage -A arm -O linux -T kernel -C none -a $TEXT_START -e $TEXT_START -n uboot -d u-boot-dtb.bin u-boot.img
%endif

%install
# Some times u-boot needs a dtb to configure itself appended to the binary.
# In that case prefer the one with a working dtb already appended.
if [ -f u-boot-dtb-tegra.bin ]; then
    install -D -m 0644 u-boot-dtb-tegra.bin %{buildroot}/boot/u-boot.bin
elif [ -f u-boot-dtb.bin ]; then
    install -D -m 0644 u-boot-dtb.bin %{buildroot}/boot/u-boot.bin
else
    install -D -m 0644 u-boot.bin %{buildroot}/boot/u-boot.bin
fi
%if %x_loader == 1
install -D -m 0755 MLO %{buildroot}/boot/MLO
%endif
%if %origen_spl == 1
install -D -m 0755 spl/origen-spl.bin %{buildroot}/boot/origen-spl.bin
%endif
%if %arndale_spl == 1
install -D -m 0755 spl/arndale-spl.bin %{buildroot}/boot/arndale-spl.bin
install -D -m 0755 %{SOURCE2} %{buildroot}/boot/arndale-bl1.img
%endif
%if %sunxi_spl == 1
install -D -m 0755 spl/sunxi-spl.bin %{buildroot}/boot/sunxi-spl.bin
install -D -m 0755 u-boot-sunxi-with-spl.bin %{buildroot}/boot/u-boot-sunxi-with-spl.bin 
%endif
%if %cuboxi_spl == 1
install -D -m 0755 SPL %{buildroot}/boot/cuboxi-spl.bin
%endif

%files
%defattr(-,root,root)
/boot/*
%doc Licenses/gpl-2.0.txt README

%files doc
%defattr(-,root,root)
# Generic documents
%doc doc/README.JFFS2 doc/README.JFFS2_NAND doc/README.commands
%doc doc/README.autoboot doc/README.commands doc/README.console doc/README.dns
%doc doc/README.hwconfig doc/README.nand doc/README.NetConsole doc/README.serial_multi
%doc doc/README.SNTP doc/README.standalone doc/README.update doc/README.usb
%doc doc/README.video doc/README.VLAN doc/README.silent doc/README.POST doc/README.Modem
# Copy some useful kermit scripts as well
%doc tools/kermit/dot.kermrc tools/kermit/flash_param tools/kermit/send_cmd tools/kermit/send_image
# Now any h/w dependent Documentation
%doc doc/README.ARM-memory-map 

%changelog
openSUSE Build Service is sponsored by