File libdbi.spec of Package libdbi

#
# spec file for package libdbi
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           libdbi
%define lname	libdbi1
Version:        0.9.0
Release:        0
Summary:        Database Independent Abstraction Layer for C
License:        LGPL-2.1+
Group:          Development/Libraries/C and C++
Url:            http://libdbi.sf.net/

Source:         http://downloads.sf.net/libdbi/%name-%version.tar.gz
Source2:        baselibs.conf
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  pkgconfig

%description
libdbi implements a database-independent abstraction layer in C,
similar to the DBI/DBD layer in Perl. Writing one generic set of
code, programmers can leverage the power of multiple databases and
multiple simultaneous database connections by using this framework.

%package -n %{lname}
Summary:        Database Independent Abstraction Layer for C
Group:          System/Libraries

%description -n %{lname}
libdbi implements a database-independent abstraction layer in C,
similar to the DBI/DBD layer in Perl. Writing one generic set of
code, programmers can leverage the power of multiple databases and
multiple simultaneous database connections by using this framework.

%package devel
Summary:        Development files for libdbi (Database Independent Abstraction Layer for C)
Group:          Development/Libraries/C and C++
Requires:       %{lname} = %{version}

%description devel
The libdbi-devel package contains the header files and documentation
needed to develop applications with libdbi.

%prep
%setup -q
sed -i s,\-O20,\-O3,g configure

%build
%configure --disable-docs --disable-static
make %{?_smp_mflags}

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm %buildroot/%{_libdir}/libdbi.la
rm README.win32

%files -n %{lname}
%defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING README*
%{_libdir}/libdbi.so.*

%files devel
%defattr(-,root,root)
%doc TODO doc/programmers-guide.pdf doc/programmers-guide/ doc/driver-guide.pdf doc/driver-guide/
%_includedir/dbi/
%{_libdir}/libdbi.so
%_libdir/pkgconfig/dbi.pc

%post -n %{lname} -p /sbin/ldconfig

%postun -n %{lname} -p /sbin/ldconfig

%changelog
openSUSE Build Service is sponsored by