File golang-packaging.spec of Package golang-packaging.3874

#
# spec file for package golang-packaging
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define version_unconverted 14.9.2

Name:           golang-packaging
Version:        14.9.2
Release:        0
Summary:        A toolchain to help packaging golang
License:        GPL-3.0
Group:          Development/Languages/Golang
Url:            https://github.com/marguerite/%{name}
Source:         %{name}-%{version}.tar.xz
BuildRequires:  rpm
BuildRequires:  ruby
BuildRequires:  xz
Requires:       go
Requires:       ruby
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
A toolchain to help packaging golang, written in ruby.

%prep
%setup -q
GOARCH=`ruby ./golang-macros.rb --arch`
sed -i "s/GOARCH/$GOARCH/" macros.go

%build

%install
mkdir -p %{buildroot}%{_sysconfdir}/rpm/
mkdir -p %{buildroot}%{_prefix}/lib/rpm/
%if 0%{?suse_version} >= 1320
mkdir -p %{buildroot}%{_prefix}/lib/rpm/fileattrs
install -m0644 golang.attr %{buildroot}%{_prefix}/lib/rpm/fileattrs/
%endif
install -m0755 golang.prov %{buildroot}%{_prefix}/lib/rpm/
install -m0755 golang.req %{buildroot}%{_prefix}/lib/rpm/
cp -r golang %{buildroot}%{_prefix}/lib/rpm/
install -m0755 golang-macros.rb %{buildroot}%{_prefix}/lib/rpm/
install -m0644 macros.go %{buildroot}%{_sysconfdir}/rpm/

%files
%defattr(-,root,root)
%doc COPYING README.md ChangeLog
%config %{_sysconfdir}/rpm/macros.go
%if %{?suse_version} >= 1320
%{_prefix}/lib/rpm/fileattrs/golang.attr
%endif
%{_prefix}/lib/rpm/golang
%{_prefix}/lib/rpm/golang.prov
%{_prefix}/lib/rpm/golang.req
%{_prefix}/lib/rpm/golang-macros.rb

%changelog
openSUSE Build Service is sponsored by