File ntfs-3g_ntfsprogs.spec of Package ntfs-3g_ntfsprogs.21057

#
# spec file for package ntfs-3g_ntfsprogs
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define soname 84

Name:           ntfs-3g_ntfsprogs
Summary:        NTFS Support in Userspace
License:        GPL-2.0-or-later
Group:          System/Filesystems
Version:        2021.8.22
Release:        0
Source:         http://tuxera.com/opensource/%{name}-%{version}.tgz
Source1:        buildall.sh
Source2:        21-storage-ntfs-3g.fdi
# PATCH-FIX-SLE ntfs-3g-old-api.patch boo#1189720 mgorse@suse.com -- revert changes that break the API.
Patch0:         ntfs-3g-old-api.patch
# PATCh-FIX-SLE ntfs-3g-old-prognames.patch boo#1189720 mgorse@suse.com -- rename ntfsusermap and ntfssecaudit to their old names.
Patch1:         ntfs-3g-old-prognames.patch
URL:            https://github.com/tuxera/ntfs-3g/
%if 0%{?sles_version}
BuildRequires:  fuse-devel >= 2.6.0
%else
BuildRequires:  pkgconfig(fuse) >= 2.6.0
%endif
BuildRequires:  gnutls-devel
BuildRequires:  hwinfo-devel
BuildRequires:  libgcrypt-devel
BuildRequires:  libtool
BuildRequires:  libuuid-devel
BuildRequires:  pkgconfig
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
NTFS-3G allows for read/write access to NTFS partitions which can be
shared with Windows XP, Windows Server 2003, Windows 2000, Windows
Vista and Windows Seven.

%package -n ntfs-3g
Summary:        NTFS Support in Userspace
License:        GPL-2.0-or-later
Group:          System/Filesystems
Provides:       ntfsprogs-fuse = 1.13.1
Obsoletes:      ntfsprogs-fuse < 1.13.1
%if 0%{?suse_version}
Requires(post): update-alternatives
Requires(postun):update-alternatives
# The build service fails to build the package because it doesn't really
# understand Requires(post), so use PreReq too (see bnc#439232).
PreReq:         update-alternatives
%endif
%if 0%{?suse_version} > 1010
Supplements:    filesystem(ntfs-3g)
%endif

%description -n ntfs-3g
NTFS-3G allows for read/write access to NTFS partitions which can be
shared with Windows XP, Windows Server 2003, Windows 2000, Windows
Vista and Windows Seven.

%package -n libntfs-3g%soname
Summary:        NTFS Support in Userspace -- Library
License:        LGPL-2.1-or-later
Group:          System/Filesystems

%description -n libntfs-3g%soname
NTFS-3G allows for read/write access to NTFS partitions which can be
shared with Windows XP, Windows Server 2003, Windows 2000, Windows
Vista and Windows Seven.

%package -n libntfs-3g-devel
Summary:        NTFS Support in Userspace -- Development Files
License:        LGPL-2.1-or-later
Group:          System/Filesystems
Requires:       glibc-devel
Requires:       libntfs-3g%soname = %{version}
Provides:       ntfs-3g-devel = %{version}
Obsoletes:      ntfs-3g-devel < %{version}

%description -n libntfs-3g-devel
NTFS-3G allows for read/write access to NTFS partitions which can be
shared with Windows XP, Windows Server 2003, Windows 2000, Windows
Vista and Windows Seven.

%package -n ntfsprogs
Summary:        NTFS Utilities
License:        GPL-2.0-or-later
Group:          System/Filesystems

%description -n ntfsprogs
The ntfsprogs includes utilities for doing all required tasks to NTFS
partitions. In general, just run a utility without any command line
options to display the version number and usage syntax.

%prep
%setup -q
%patch0 -p1
%patch1 -p1

%build
#
# regarding -Wno-sign-compare - checked with the Szaka: There is one variable
# which is signed and would possibly ok to be unsigned. Any solution to this
# needs to be carefully reviewed and tested, so we do not change the code now:
#
export CFLAGS="$RPM_OPT_FLAGS -Wformat -Wformat-security -W -Wno-sign-compare"
mv ntfsprogs/ntfsusermap.8.in ntfsprogs/ntfs-3g.usermap.8.in
mv ntfsprogs/ntfssecaudit.8.in ntfsprogs/ntfs-3g.secaudit.8.in
autoreconf -fi
%configure --exec-prefix=/ --disable-static --with-pic --disable-ldconfig \
	--with-fuse=external

make %{?_smp_mflags}

%install
make install DESTDIR="%buildroot"
%{__rm} -v %{buildroot}%{_libdir}/libntfs-3g.la
# Hal stuff for mounting on hotplug.
%{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor/
%{__install} -m 644 %{SOURCE2} %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor/21-storage-ntfs-3g.fdi
# Touch ghost files
touch %{buildroot}/sbin/mount.ntfs %{buildroot}%{_mandir}/man8/mount.ntfs.8

%check
TESTFS=$(mktemp) || exit 1
ntfsprogs/mkntfs -q -F $TESTFS 3000
src/ntfs-3g.probe --readonly  $TESTFS
src/ntfs-3g.probe --readwrite $TESTFS
rm -v $TESTFS

%post -n ntfs-3g
# If the mount.ntfs group is in automatic mode, then this will also switch all
# symlinks automatically
update-alternatives --install /sbin/mount.ntfs mount.ntfs /sbin/mount.ntfs-3g 10 --slave /usr/share/man/man8/mount.ntfs.8.gz mount.ntfs.8.gz /usr/share/man/man8/mount.ntfs-3g.8.gz

%postun -n ntfs-3g
# Note: we don't use "$1 -eq 0", to avoid issues if the package gets renamed
if [ ! -f /sbin/mount.ntfs-3g ]; then
  update-alternatives --remove mount.ntfs /sbin/mount.ntfs-3g
fi

%posttrans -n ntfs-3g
# Workaround old bug in 11.1/11.2 packages that always removed the symlinks in
# %postun. Can be removed during 12.2 development.
if [ ! -f /sbin/mount.ntfs -a -f /sbin/mount.ntfs-3g ]; then
  update-alternatives --install /sbin/mount.ntfs mount.ntfs /sbin/mount.ntfs-3g 10 --slave /usr/share/man/man8/mount.ntfs.8.gz mount.ntfs.8.gz /usr/share/man/man8/mount.ntfs-3g.8.gz
fi

%post -n libntfs-3g%soname -p /sbin/ldconfig

%postun -n libntfs-3g%soname -p /sbin/ldconfig

%files -n ntfs-3g
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING CREDITS NEWS README
%dir %{_datadir}/hal
%dir %{_datadir}/hal/fdi
%dir %{_datadir}/hal/fdi/policy
%dir %{_datadir}/hal/fdi/policy/10osvendor
%{_datadir}/hal/fdi/policy/10osvendor/21-storage-ntfs-3g.fdi
%{_bindir}/ntfs-3g
%{_bindir}/ntfs-3g.probe
%{_bindir}/ntfs-3g.secaudit
%{_bindir}/ntfs-3g.usermap
%{_bindir}/lowntfs-3g
%ghost /sbin/mount.ntfs
/sbin/mount.ntfs-3g
/sbin/mount.lowntfs-3g
%{_mandir}/man8/mount.lowntfs-3g.8%{?ext_man}
%ghost %{_mandir}/man8/mount.ntfs.8%{?ext_man}
%{_mandir}/man8/mount.ntfs-3g.8%{?ext_man}
%{_mandir}/man8/ntfs-3g.8%{?ext_man}
%{_mandir}/man8/ntfs-3g.probe.8%{?ext_man}
%{_mandir}/man8/ntfs-3g.secaudit.8%{?ext_man}
%{_mandir}/man8/ntfs-3g.usermap.8%{?ext_man}
# We already have this, so no need to package it again.
%exclude /usr/share/doc/ntfs-3g/README

%files -n libntfs-3g%soname
%defattr(-,root,root,-)
%doc COPYING.LIB
%{_libdir}/libntfs-3g.so.*

%files -n libntfs-3g-devel
%defattr(-,root,root,-)
%{_includedir}/ntfs-3g/
%{_libdir}/libntfs-3g.so
%{_libdir}/pkgconfig/libntfs-3g.pc

%files -n ntfsprogs
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING CREDITS NEWS README
/sbin/mkfs.ntfs
%{_sbindir}/mkntfs
%{_sbindir}/ntfsclone
%{_sbindir}/ntfscp
%{_sbindir}/ntfslabel
%{_sbindir}/ntfsresize
%{_sbindir}/ntfsundelete
%{_bindir}/ntfscat
%{_bindir}/ntfscluster
%{_bindir}/ntfscmp
%{_bindir}/ntfsfix
%{_bindir}/ntfsinfo
%{_bindir}/ntfsls
%{_mandir}/man8/mkfs.ntfs.8%{?ext_man}
%{_mandir}/man8/mkntfs.8%{?ext_man}
%{_mandir}/man8/ntfscat.8%{?ext_man}
%{_mandir}/man8/ntfsclone.8%{?ext_man}
%{_mandir}/man8/ntfscluster.8%{?ext_man}
%{_mandir}/man8/ntfscmp.8%{?ext_man}
%{_mandir}/man8/ntfscp.8%{?ext_man}
%{_mandir}/man8/ntfsfix.8%{?ext_man}
%{_mandir}/man8/ntfsinfo.8%{?ext_man}
%{_mandir}/man8/ntfslabel.8%{?ext_man}
%{_mandir}/man8/ntfsls.8%{?ext_man}
%{_mandir}/man8/ntfsprogs.8%{?ext_man}
%{_mandir}/man8/ntfsresize.8%{?ext_man}
%{_mandir}/man8/ntfsundelete.8%{?ext_man}

%changelog
openSUSE Build Service is sponsored by