File clamav.spec of Package clamav.8970

#
# spec file for package clamav
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{!?_tmpfilesdir:%global _tmpfilesdir /usr/lib/tmpfiles.d}

Name:           clamav
BuildRequires:  ncurses-devel
BuildRequires:  sed
BuildRequires:  sendmail
BuildRequires:  sendmail-devel
%if 0%{?suse_version} >= 1010
BuildRequires:  bc
BuildRequires:  pkgconfig
BuildRequires:  zlib-devel
%endif
%if 0%{?suse_version} >= 1030
BuildRequires:  check-devel
BuildRequires:  libbz2-devel
BuildRequires:  libopenssl-devel
BuildRequires:  libxml2-devel
BuildRequires:  pcre-devel
BuildRequires:  pwdutils
BuildRequires:  python-devel
%define clamav_check --enable-check
%else
BuildRequires:  bzip2
%define clamav_check --disable-check
%endif
#!BuildIgnore:  clamav-nodb
Summary:        Antivirus Toolkit
License:        GPL-2.0-only
Group:          Productivity/Security
Version:        0.100.2
Release:        0
Url:            http://www.clamav.net
Requires:       latex2html-pngicons
Obsoletes:      clamav-db < 0.88.3
Provides:       clamav-nodb = %{version}
Obsoletes:      clamav-nodb <= 0.98.4
PreReq:         %_sbindir/groupadd %_sbindir/useradd %_sbindir/usermod
PreReq:         /usr/bin/awk /bin/sed /bin/tar
Source0:        http://www.clamav.net/downloads/production/%{name}-%{version}.tar.gz
Source10:       http://www.clamav.net/downloads/production/%{name}-%{version}.tar.gz.sig
Source11:       clamav.keyring
Source4:        clamav-rpmlintrc
Source6:        clamav-tmpfiles.conf
Source7:        service.clamd
Source8:        service.freshclam
Source9:        service.clamav-milter
Patch1:         clamav-conf.patch
Patch2:         clamav-obsolete-config.patch
Patch3:         clamav-disable-yara.patch
Patch4:         clamav-freshclam-exit.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  systemd
BuildRequires:  systemd-rpm-macros
%systemd_requires

%description
ClamAV is an open source (GPL) antivirus engine designed for detecting
Trojans, viruses, malware and other malicious threats. It is the de
facto standard for mail gateway scanning. It provides a high
performance mutli-threaded scanning daemon, command line utilities for
on demand file scanning, and an intelligent tool for automatic
signature updates. The core ClamAV library provides numerous file
format detection mechanisms, file unpacking support, archive support,
and multiple signature languages for detecting threats.

%prep
%setup -q
%patch1
%patch2
%patch3
%patch4

%build
%if 0%{?suse_version} >= 1010
CFLAGS="-fstack-protector"
CXXFLAGS="-fstack-protector"
%endif
export CFLAGS="%optflags $CFLAGS"
export CXXFLAGS="%optflags $CXXFLAGS"
%if 0%{?suse_version} == 0910
# SLES9 needs this macro to enable the quarantine feature in libmilter
CFLAGS="$CFLAGS -D_FFR_QUARANTINE -D_FFR_SMFI_OPENSOCKET"
%endif
%if "%_lib" == "lib64"
# tomsfastmath needs this for correct operation on 64-bit platforms
CFLAGS="$CFLAGS -DFP_64BIT"
%endif
./configure \
	--prefix=%_prefix \
	--libdir=%_libdir \
	--mandir=%_mandir \
	--sysconfdir=%_sysconfdir \
	--disable-clamav \
	--disable-static \
	--with-dbdir=/var/lib/clamav \
	--with-user=vscan \
	--with-group=vscan \
	--enable-milter \
	%clamav_check \
%if 0%{?suse_version} == 0910
	--disable-zlib-vcheck \
%endif
	--enable-clamdtop \
	--disable-timestamps \
	--disable-yara

make V=1 %{?jobs:-j%jobs}

%install
%makeinstall
install -d -m755 %buildroot/var/lib/clamav
install -d -m755 %buildroot/%_tmpfilesdir
install -m644 %SOURCE6 %buildroot%_tmpfilesdir/clamav.conf
mkdir -p %buildroot/var/spool/amavis
mkdir -p -m 0755 %buildroot/run/clamav
%if 0%{?suse_version} > 1020
rm %buildroot/%_libdir/*.la
%endif

# libclammspack is not meant to be linked against by anything but
# libclamav
rm %buildroot%_libdir/pkgconfig/libclammspack.pc
rm %buildroot%_libdir/libclammspack.so

# fix the new config file names
pushd %buildroot/etc
mv clamd.conf.sample clamd.conf
mv clamav-milter.conf.sample clamav-milter.conf
mv freshclam.conf.sample freshclam.conf
popd

# Systemd...
%if 0%{?suse_version} >= 1210
install -d -m 0755 %buildroot/%{_unitdir}
install -m 0644 %{S:7} %buildroot/%{_unitdir}/clamd.service
install -m 0644 %{S:8} %buildroot/%{_unitdir}/freshclam.service
install -m 0644 %{S:9} %buildroot/%{_unitdir}/clamav-milter.service
rm %buildroot/%{_unitdir}/clamav-daemon.service
rm %buildroot/%{_unitdir}/clamav-daemon.socket
rm %buildroot/%{_unitdir}/clamav-freshclam.service
# this is broken if system does not have systemd so don't 
# use it at all on systems without mandatory systemd
%if 0%{?suse_version} >= 1230
for srvname in clamd freshclam clamav-milter;do
        (export PATH=/usr/sbin:/sbin:$PATH ;ln -sf $(which service) %{buildroot}/%{_sbindir}/rc${srvname})
done
%endif
%endif

%check

# regression tests
%if !0%{?qemu_user_space_build:1}
VALGRIND_GENSUP=1 make check
%endif

%files
%defattr(-,root,root,-)
%config(noreplace) %_sysconfdir/*.conf
#systemd...
%if 0%{?suse_version} >= 1210
%{_unitdir}/clamd.service
%{_unitdir}/freshclam.service
%{_unitdir}/clamav-milter.service
%endif
%_tmpfilesdir
%doc COPYING*
%doc docs/*.pdf docs/html
%doc %_mandir/*/*
%_bindir/*
%_sbindir/*
%_includedir/*
%_libdir/lib*
%_libdir/pkgconfig/libclamav.pc
%defattr(-,vscan,vscan)
%dir %attr(750,vscan,vscan) /var/spool/amavis
%dir /var/lib/clamav
%ghost %attr(755,vscan,vscan) /run/clamav

%pre
%_sbindir/groupadd -r vscan 2> /dev/null || :
%_sbindir/useradd -r -o -g vscan -u 65 -s /bin/false -c "Vscan account" -d /var/spool/amavis vscan 2> /dev/null || :
%_sbindir/usermod vscan -g vscan 2> /dev/null || :
%service_add_pre clamd.service freshclam.service clamav-milter.service

%post
/sbin/ldconfig
systemd-tmpfiles --create %_tmpfilesdir/clamav.conf
%service_add_post clamd.service freshclam.service clamav-milter.service

%preun
%service_del_preun clamd.service freshclam.service clamav-milter.service

%postun
/sbin/ldconfig
%service_del_postun clamd.service freshclam.service clamav-milter.service

%changelog
openSUSE Build Service is sponsored by