File python-gtk.spec of Package python-gtk

#
# spec file for package python-gtk
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python-gtk
%define _name pygtk
BuildRequires:  fdupes
BuildRequires:  libglade2-devel
BuildRequires:  python-cairo-devel
BuildRequires:  python-devel
BuildRequires:  python-gobject2-devel
%if %suse_version <= 1130
BuildRequires:  python-gobject2-doc
%endif
BuildRequires:  python-numpy-devel
Requires:       python-numpy
# Only for directory ownership:
BuildRequires:  gtk-doc
Url:            http://www.pygtk.org/
Summary:        Python bindings for the GTK+ widget set
License:        LGPL-2.1+
Group:          Development/Libraries/Python
Version:        2.24.0
Release:        0
Source:         http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.24/%{_name}-%{version}.tar.bz2
# PATCH-FIX-UPSTREAM pygtk-2.22.0-capsule.patch bgo#623965 bnc#669802 jmatejek@novell.com -- Conditionally use the new Capsule API instead of PyCObject
Patch0:         pygtk-2.22.0-capsule.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

# for cross-distro compatibility:
Provides:       pygtk2 = %{version}

%define lparen (
%define rparen )
%define python_gtk_req %(zgrep -a _required_version %{S:0} | sed -n 's/_required_version,[[:space:]]*/ >= /;s/%{rparen}$//;s/1.0.2%{rparen} dnl or 1.1.7/1.1.7/;s/\\%{lparen}glib\\|gtk\\|libglade\\|gobject\\%{rparen}/&2/;s/py\\%{lparen}.*\\%{rparen} /python-\\1 /;/gtk2unixprint/d;s/^m4_define%{lparen}//p' | tr '\\n' ' ')
Requires:       %python_gtk_req
%{py_requires}

%description
PyGTK is an extension module for python that gives you access to the
GTK+ widget set.  Just about anything you can write in C with GTK+ you
can write in python with PyGTK (within reason), but with all of
python's benefits.

%package devel
Summary:        Files needed to build wrappers for GTK+ addon libraries
Group:          Development/Libraries/Python
Requires:       %{name} = %{version}
Requires:       python-cairo-devel
Requires:       python-gobject2-devel

%description devel
This package contains files required to build wrappers for GTK+ addon
libraries so that they interoperate with pygtk.

%package doc
Summary:        Python bindings for the GTK+ widget set
Group:          Development/Libraries/Python
Requires:       %{name} = %{version}
%if 0%{?suse_version} >= 1120
BuildArch:      noarch
%endif

%description doc
PyGTK is an extension module for python that gives you access to the
GTK+ widget set.  Just about anything you can write in C with GTK+ you
can write in python with PyGTK (within reason), but with all of
python's benefits.

%prep
%setup -q -n %{_name}-%{version}
%patch0 -p1

%build
%configure
make %{?jobs:-j%jobs}

%install
%makeinstall
find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -v

# move the docs to FHS-correct directory
mkdir -p $RPM_BUILD_ROOT%{_datadir}/doc
mv $RPM_BUILD_ROOT%{_datadir}/gtk-doc $RPM_BUILD_ROOT%{_datadir}/doc/gtk

rm examples/Makefile*
# demo is already in devel package
rm -rf examples/pygtk-demo
chmod +x $RPM_BUILD_ROOT%{_libdir}/pygtk/2.0/{,*/}*.py
%fdupes $RPM_BUILD_ROOT%{_libdir}
%fdupes $RPM_BUILD_ROOT%{_datadir}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc AUTHORS NEWS README MAPPING ChangeLog THREADS COPYING examples
%{py_sitedir}/gtk-2.0/gtk/
%{py_sitedir}/gtk-2.0/atk.so
%{py_sitedir}/gtk-2.0/gtkunixprint.so
%{py_sitedir}/gtk-2.0/pango*.so

%files devel
%defattr(-,root,root)
%{_includedir}/%{_name}-2.0/%{_name}/
%{_libdir}/pkgconfig/*.pc
## codegen
%{_bindir}/%{_name}-codegen-2.0
# we explicitly list the directories here to be sure we don't include something
# that should live in the main package
%dir %{_datadir}/%{_name}
%dir %{_datadir}/%{_name}/2.0
%{_datadir}/%{_name}/2.0/defs/
## demo
%{_bindir}/%{_name}-demo
# we explicitly list the directories here to be sure we don't include something
# that should live in the main package
%dir %{_libdir}/%{_name}
%dir %{_libdir}/%{_name}/2.0
%{_libdir}/%{_name}/2.0/demos/
%{_libdir}/%{_name}/2.0/pygtk-demo.py*

%files doc
%defattr(-,root,root)
%dir %{_datadir}/doc
%{_datadir}/doc/gtk

%changelog
openSUSE Build Service is sponsored by