File azure-cli-role.spec of Package azure-cli-role.14380
#
# spec file for package azure-cli-role
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: azure-cli-role
Version: 2.1.4
Release: 0
Summary: Microsoft Azure CLI 'role' Command Module for Role-Based Access Control (RBAC)
License: MIT
Group: System/Management
Url: https://github.com/Azure/azure-cli
Source: https://files.pythonhosted.org/packages/source/a/azure-cli-role/azure-cli-role-%{version}.tar.gz
Source1: LICENSE.txt
BuildRequires: azure-cli-command-modules-nspkg
BuildRequires: azure-cli-nspkg
BuildRequires: python3-azure-nspkg
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: unzip
Requires: azure-cli-command-modules-nspkg
Requires: azure-cli-core
Requires: azure-cli-nspkg
Requires: python3-azure-graphrbac >= 0.40.0
Requires: python3-azure-keyvault >= 1.1.0
Requires: python3-azure-mgmt-authorization >= 0.50.0
Requires: python3-azure-mgmt-monitor >= 0.5.2
Requires: python3-azure-nspkg
Requires: python3-pytz
Conflicts: azure-cli < 2.0.0
BuildArch: noarch
%description
Microsoft Azure CLI 'role' Command Module for Role-Based Access Control (RBAC)
This package is for the 'role' module.
i.e. 'az role'
%prep
%setup -q -n azure-cli-role-%{version}
%build
install -m 644 %{SOURCE1} %{_builddir}/azure-cli-role-%{version}
python3 setup.py build
%install
python3 setup.py install --root=%{buildroot} --prefix=%{_prefix} --install-lib=%{python3_sitelib}
rm -rf %{buildroot}%{python3_sitelib}/azure/cli/command_modules/__init__.*
rm -rf %{buildroot}%{python3_sitelib}/azure/cli/command_modules/__pycache__
rm -rf %{buildroot}%{python3_sitelib}/azure/cli/__init__.*
rm -rf %{buildroot}%{python3_sitelib}/azure/cli/__pycache__
rm -rf %{buildroot}%{python3_sitelib}/azure/__init__.*
rm -rf %{buildroot}%{python3_sitelib}/azure/__pycache__
%files
%defattr(-,root,root,-)
%doc HISTORY.rst README.rst
%license LICENSE.txt
%{python3_sitelib}/azure/cli/command_modules/role
%{python3_sitelib}/azure_cli_role-*.egg-info
%changelog