File boost-jam.spec of Package boost-jam

#
# spec file for package boost-jam
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           boost-jam
Version:        201104
Release:        0
Summary:        An Enhanced Make Replacement
License:        BSD-3-Clause
Group:          Development/Tools/Building
Source:         %{name}-%{version}.tar.bz2
# From http://boost.cvs.sourceforge.net/boost/boost/tools/jam/test/:
Source2:        test.tar.gz 
Url:            http://www.boost.org/
Patch1:         boost-jam-cflags_for_build.diff
Patch2:         boost-jam-codecleanup.diff
Patch3:         boost-jam-jam0_use_passed_cflags.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Boost Jam is a build tool based on FTJam, which in turn is based on
Perforce Jam. It contains significant improvements made to facilitate
its use in the Boost Build System, but should be backward compatible
with Perforce Jam.

%prep
%setup -q
find . -type f|xargs chmod -R u+w
%patch1
%patch2 -p1
%patch3

%build
%ifarch s390
#export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -O1"
%endif
export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wall -fno-strict-aliasing"
export CFLAGS="$RPM_OPT_FLAGS"
LOCATE_TARGET=bin ./build.sh gcc --symbols
# Trivial test: -- Documented used of bjam -v: Print the version of jam and exit:
bin/bjam -v
ln  -s bin bin.linux
cd ..
tar xvf %{SOURCE2}
ln -s %{name}-%{version} src
cd test
sh test.sh || if [ $? -gt 5 ]; then sh test.sh;fi

%install
mkdir -p %{buildroot}%{_bindir}
mkdir -p $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
install -m 755 bin/bjam %{buildroot}%{_bindir}/bjam-%{version}
ln -sf bjam-%{version} %{buildroot}%{_bindir}/bjam
ln -sf bjam-%{version} %{buildroot}%{_bindir}/jam

%files
%defattr(-,root,root)
%attr(755,root,root) %{_bindir}/*

%changelog
openSUSE Build Service is sponsored by