File python-heatclient.spec of Package python-heatclient

#
# spec file for package python-heatclient
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define component heatclient

Name:           python-%{component}
Version:        0.2.8.21.g644d148
Release:        0.<RELEASE7>
Summary:        OpenStack Orchestration (Heat) API Client
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            http://launchpad.net/python-heatclient
Source:         http://tarballs.openstack.org/python-heatclient/python-heatclient-master.tar.gz
BuildRequires:  openstack-suse-macros
BuildRequires:  python-base
BuildRequires:  python-setuptools
# Documentation build requirements:
BuildRequires:  python-PrettyTable
BuildRequires:  python-Sphinx
BuildRequires:  python-iso8601 >= 0.1.4
BuildRequires:  python-keystoneclient
BuildRequires:  python-pbr
Requires:       python >= 2.6.8
Requires:       python-PrettyTable >= 0.7
Requires:       python-PyYAML >= 3.1.0
Requires:       python-argparse
Requires:       python-iso8601 >= 0.1.8
Requires:       python-keystoneclient >= 0.4.2
Requires:       python-pbr >= 0.5.21
Requires:       python-requests >= 1.1
Requires:       python-six >= 1.4.1
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch:      noarch
%endif

%description
This is a client library for Heat built on the Heat orchestration API. It
provides a Python API (the heatclient module) and a command-line tool (heat).

%package doc

Summary:        OpenStack Orchestration (Heat) API Client - Documentation
Group:          Documentation/HTML
Requires:       %{name} = %{version}

%description doc
This package contains documentation files for %{name}.

%package test

Summary:        OpenStack Orchestration (Heat) API Client - Testsuite
Group:          Development/Languages/Python
Requires:       %{name} = %{version}
Requires:       python-coverage >= 3.6
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
Requires:       python-discover
%endif
Requires:       python-fixtures >= 0.3.14
Requires:       python-mock >= 1.0
Requires:       python-mox3 >= 0.7.0
Requires:       python-testrepository >= 0.0.17
Requires:       python-testscenarios >= 0.4
Requires:       python-testtools >= 0.9.32

%description test
This package contains testsuite files for %{name}.

%prep
%setup -q
%openstack_cleanup_prep
echo %{version} > heatclient/versioninfo

%build
python setup.py build
python setup.py build_sphinx
rm doc/build/html/.buildinfo

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot} --install-data=%{python_sitelib}

# bash completion
install -p -D -m 644 tools/heat.bash_completion %{buildroot}%{_sysconfdir}/bash_completion.d/openstack-heat.sh

### test subpackage
%openstack_test_package_install

%files
%defattr(-,root,root,-)
%doc LICENSE README.rst
%{_bindir}/heat
%{python_sitelib}/%{component}/
%{python_sitelib}/python_%{component}-*.egg-info
%{_sysconfdir}/bash_completion.d/openstack-heat.sh

%files doc
%defattr(-,root,root,-)
%doc LICENSE doc/build/html

%files test
%defattr(-,root,root,-)
%{_localstatedir}/lib/%{name}-test/

%changelog
openSUSE Build Service is sponsored by